Closed Bug 1157128 Opened 4 years ago Closed 4 years ago

Http Auth broken

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S11 (1may)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: jhao, Assigned: daleharvey)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(7 files)

Using Flame, open the browser and navigate to http://tiv-dmz.homeip.net

This website requires username and password, but I can't enter them because there's no input box.
Can we get a video?
Keywords: qawanted
And branch check.
This issue reproduces on Flame 3.0. If you access the website via a computer you can see the website's authentication method is a dialog popping up upon accessing, and on Flame 3.0 there is no dialog popping up and there are no input fields next to username and password. See video:

https://www.youtube.com/watch?v=_uv1oXSdv_g

Device: Flame 3.0
BuildID: 20150422010202
Gaia: 15134b080b5f406e5aa36f5136c17dafb4e31f64
Gecko: 946ac85af8f4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

----

This issue does NOT reproduce on Flame 2.2. There are two fields available on the website accepting input.

Device: Flame 2.2
BuildID: 20150422002505
Gaia: 41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gecko: a87a05e7d0ef
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawantedregression
Whiteboard: [systemsfe]
Note that on v2.2 although input fields are there, they're not labeled (username field doesn't say username, and password field doesn't say password. Although the order of these input boxes are intuitive, it does still seem odd without labeling)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I'm try to find the broken window.
According to the STR of comment 0, I find that the B2g-inbound regression results are abnormal.

--------------------------------------------------------------------------------------------
B2g-inbound Regression Window:

This issue DOES repro (Fail):only shows the words "username" and "password",no input box. (bug_NoInputbox.png)
This issue DOES NOT repro (Pass):it shows two input boxes, but no prompt text "username" and "password" in the website. (show_inputbox.png)

20150328214220 	-> Pass  	 
20150329042818  -> Fail 	 
20150329235918 	-> Fail	 
20150330001019 	-> Fail 	 
20150330140843 	-> Fail	 
20150330144345 	-> Fail	 
20150330162405 	-> Fail 
20150330171401 	-> Fail	 
20150330174902 	-> Fail	 
20150330180400 	-> Pass	 
20150330192902 	-> Pass		 	 
20150330230404  -> Pass	 	 
20150331010905  -> Fail	
20150401160204  -> Fail	

--------------------------------------------------------------------

Last Working Environmental Variables:
Device: Flame v3.0
Build ID               20150330230404
Gaia Revision          36b6f9f824782457ae0674382604cb69d915dee4
Gaia Date              2015-03-31 05:33:10
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/29b1685738e0
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.042104
Firmware Date          Sun Mar 29 04:21:16 EDT 2015
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame v3.0
Build ID               20150331010905
Gaia Revision          d08600b883589cfb556a7a3f39310b6b4e8106a0
Gaia Date              2015-03-31 07:21:41
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/e982d356e37a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.191926
Firmware Date          Mon Mar 30 19:19:35 EDT 2015
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia-Rev        d08600b883589cfb556a7a3f39310b6b4e8106a0
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/29b1685738e0

First Broken Gecko & Last Working Gaia - issue DOES NOT repro
Gaia-Rev        36b6f9f824782457ae0674382604cb69d915dee4
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/e982d356e37a

Gaia log: logcat_0225.txt.
Please see attachments: bug_NoInputbox.png and show_inputbox.png.
Duplicate of this bug: 1153614
blocking-b2g: --- → 3.0+
Ill take a look here
Assignee: nobody → dale
http auth is straight up broken, http://httpbin.org/basic-auth/user/passwd also fails, nothing particularly revealing in the log
Summary: Can't enter username and password at http://tiv-dmz.homeip.net → Http Auth broken
As a side note, could we have some test once this bug is fixed so we immediately get attention to this if we break HTTP Auth again? This is the second time in the last months that HTTP Auth is completely broken in some fashion. :(
Yup taking a look since there is an integration test for this functionality @ http://mxr.mozilla.org/gaia/source/apps/system/test/marionette/app_authentication_dialog_test.js?force=1, but checking why its not caught anything
https://github.com/mozilla-b2g/gaia/pull/29747 fixes this, was caused by a recent l10n changes that strip the input due to the l10n-id, the test doesnt actually perform a login which is why this isnt caught, will get a test written before getting this in to review
Bhavana, this should block Spark. Though it looks like it's going to be resolved soon, so it may land before we can set tracking.
Flags: needinfo?(bbajaj)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Dale, in bug 1157631 I'm fixing the same bug but I am leaving the l10n-ids. Do you prefer your solution?

If so, and if the entities are not used anywhere else, you should also remove the l10n strings from resource file.
Duplicate of this bug: 1157631
Comment on attachment 8598141 [details] [review]
[gaia] daleharvey:1157128 > mozilla-b2g:master

I added a thing in server_child that lets people login with 'username' and 'password', so now we test the actual login flow
Attachment #8598141 - Flags: review?(kgrandon)
Comment on attachment 8598141 [details] [review]
[gaia] daleharvey:1157128 > mozilla-b2g:master

LGTM. Thanks for the test.
Attachment #8598141 - Flags: review?(kgrandon) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Dale, could you please also uplift to v2.2 since the patch is also for bug 1157631 which is a 2.2 blocker?
Flags: needinfo?(dale)
blocking-b2g: 3.0+ → spark+
Flags: needinfo?(bbajaj)
Comment on attachment 8598141 [details] [review]
[gaia] daleharvey:1157128 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): https://bugzilla.mozilla.org/show_bug.cgi?id=1073893
[User impact] if declined: Cant log in to http auth websites
[Testing completed]: Manually verified, automated tests added
[Risk to taking this patch] (and alternatives if risky): low risk
[String changes made]: none
Flags: needinfo?(dale)
Attachment #8598141 - Flags: approval-gaia-v2.2?
Attachment #8598141 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v3.0.

Actual results:It shows "USERNAME","PASSWORD" and two inputing boxes.
See attachment: verified_v3.0.png
Reproduce rate: 0/5


Device: Flame 3.0 build(Pass)
Build ID               20150503160200
Gaia Revision          e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gaia Date              2015-05-02 04:27:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dc5f85980a82
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.193941
Firmware Date          Sun May  3 19:39:52 EDT 2015
Bootloader             L1TC000118D0

-----------------------------------------------------------------
Note:
On Flame v2.2,it only shows inputing boxes and doesn't show the words "USERNAME" "PASSWORD".
Status: RESOLVED → VERIFIED
Keywords: verifyme
Running a test against 2.2 and will land will green
NI myself for reminding, in case I miss the update. Need it to verify bug 1157432.
Flags: needinfo?(hcheng)
Dale, could you please take a look to the 2.2 uplift? Thanks!
Flags: needinfo?(dale)
Getting 218 failures on 2.2, certainly not caused by this patch, anyone know what the state of integration tests for 2.2. I cant really see landing this with so many failures.
Flags: needinfo?(kgrandon)
Flags: needinfo?(jlal)
Flags: needinfo?(dale)
Yeah, sounds like 2.2 try needs some help. I'm sure we're missing some chnages that we've done on master, but I'm not sure what they are. I think James or Aus might have an idea, so redirecting the needinfo.
Flags: needinfo?(kgrandon) → needinfo?(aus)
Duplicate of this bug: 1157432
So it looks like on v2.2 we where still pulling mozilla-central... (which no longer has builds for b2g-desktop) fixed here https://bugzilla.mozilla.org/show_bug.cgi?id=1162630
Flags: needinfo?(jlal)
Flags: needinfo?(aus)
Target Milestone: --- → 2.2 S11 (1may)
Flags: needinfo?(hcheng)
Keywords: verifyme
This bug has been verified as pass on latest Nightly build of Flame v2.2 by the STR in Comment 0.

Actual results:It shows "USERNAME","PASSWORD" and two inputing boxes in "http://tiv-dmz.homeip.net".
See above attachment: verified_v3.0.png
Reproduce rate: 0/5

Device: Flame v2.2 build(Pass)
Build ID               20150512162502
Gaia Revision          e048df68f6f4853b5826a8816e143d95258149de
Gaia Date              2015-05-12 19:10:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9edadb35caca
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.202452
Firmware Date          Tue May 12 20:25:03 EDT 2015
Bootloader             L1TC000118D0
blocking-b2g: spark+ → 2.5+
You need to log in before you can comment on or make changes to this bug.