[RTL][Notifications]The format of screenshot name at preview mode is incorrect.

VERIFIED FIXED in 2.2 S14 (12june)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: pdahiya)

Tracking

unspecified
2.2 S14 (12june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[RTL][Flame v2.2 & v3.0][Nexus5 2.2 & 3.0][Notifications]The name of screenshot in headers at preview mode is shown as "png.2015-04-22-20-29-03".
See attachment:screenshot_preview.png

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Take a screenshot.
3. Tap the notification to preview the screenshot.
4. Observe the format of name at headers.

[3.Expected Result]: 
4. The format of name should be same as that in LTR language.

[4.Actual Result]: 
4. The name is shown as "png.2015-04-22-20-29-03".

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150421162504
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e40544535399
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.200455
Firmware Date          Tue Apr 21 20:05:07 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150421160203
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/86725d1a2cf3
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.192130
Firmware Date          Tue Apr 21 19:21:42 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150421162504
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e40544535399
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150421.200335
Firmware Date          Tue Apr 21 20:03:52 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150421160203
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/86725d1a2cf3
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150421.192936
Firmware Date          Tue Apr 21 19:29:53 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Michael, is this part of SysFE or should this be moved over to Gallery?
Flags: needinfo?(mhenretty)
Priority: -- → P2
I'm thinking gallery.
Component: Gaia::System → Gaia::Gallery
Flags: needinfo?(mhenretty)
(Reporter)

Comment 3

4 years ago
Hi William,
This issue can be reproduced on latest build of Flame 2.2&3.0, Nexus 5 2.2&3.0 by STRs in comment 0.
Result: The name of screenshot is shown as "png.Name".
Could you please have someone help with this bug? Many thanks :)

Device information:
Flame 2.2 Build ID: 20150527002504
Flame 3.0 Build ID: 20150527160204
Nexus5 2.2 Build ID: 20150527002504
Nexus5 3.0 Build ID: 20150527160204
Flags: needinfo?(whsu)
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
RTL is v2.2 committed feature. Request for fixing.
blocking-b2g: --- → 2.2?
Flags: needinfo?(whsu)

Comment 5

4 years ago
Punam, 

Could you please take a look at this issue?

Thanks
Hema
Flags: needinfo?(pdahiya)
(Assignee)

Comment 6

4 years ago
Assigning myself to investigate and fix this issue
Flags: needinfo?(pdahiya)
(Assignee)

Updated

4 years ago
Assignee: nobody → pdahiya
(Assignee)

Comment 7

4 years ago
Hi Wilson
Please review attached CSS fix that ensures filename in header for files opened via gallery open activity is not mirrored.

Thanks!
Attachment #8615396 - Flags: review?(wilsonpage)
Attachment #8615396 - Flags: review?(wilsonpage) → review+
(Assignee)

Comment 8

4 years ago
Thanks Wilson! Patch landed on master

https://github.com/mozilla-b2g/gaia/commit/a99beb2c4b0a7e5e7d2a640d618db578fffabab1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

4 years ago
Comment on attachment 8615396 [details] [review]
PR with fix of Bug 1157147

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Not a regression
[User impact] if declined: In RTL mode, File name in header for files opened via gallery open activity will not be mirrored.
[Testing completed]: On master
[Risk to taking this patch] (and alternatives if risky): Very low
[String changes made]: None
Attachment #8615396 - Flags: approval-gaia-v2.2?(jocheng)
(Assignee)

Comment 10

4 years ago
Sorry, typo in #comment9 
[User impact] if declined: In RTL mode, File name in header for files opened via gallery open activity will not be mirrored.

should be

[User impact] if declined: In RTL mode, File name in header for files opened via gallery open activity will be mirrored and not display correct.
Comment on attachment 8615396 [details] [review]
PR with fix of Bug 1157147

Approving as this is trivial polish issue.
Attachment #8615396 - Flags: approval-gaia-v2.2?(jocheng) → approval-gaia-v2.2+
(Reporter)

Comment 12

4 years ago
This issue has been verified as pass on latest build of Flame master and Nexus5 master by STRs in comment 0.
Result:The format of screeshot name is same as that in LTR language.
See attachment:verify_master_pass.png
Rate:0/5

Device: Flame master (pass)
Build ID               20150607160204
Gaia Revision          1d62b32408567f9f7cf1c71c1e5a0c6593be757b
Gaia Date              2015-06-05 17:55:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7d4ab4a9febd
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150607.193246
Firmware Date          Sun Jun  7 19:32:58 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 master (pass)
Build ID               20150607160204
Gaia Revision          1d62b32408567f9f7cf1c71c1e5a0c6593be757b
Gaia Date              2015-06-05 17:55:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7d4ab4a9febd
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150607.193647
Firmware Date          Sun Jun  7 19:37:06 EDT 2015
Bootloader             HHZ12f
(Reporter)

Updated

4 years ago
According to the STR in comment 0, this issue is verified pass on latest flame 2.2 and N5 2.2 build.
Result:The format of screeshot name is same as that in LTR language.
See attachment: Verify2_v2.2_Pass.png.
Reproducing rate:0/10

Device:Flame 2.2 build (Pass)
Build ID               20150609081832
Gaia Revision          06edb0f8db7c2f45cde54401a8593663059861a4
Gaia Date              2015-06-08 14:29:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/239c59921129
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150609.122002
Firmware Date          Tue Jun  9 12:20:13 EDT 2015
Bootloader             L1TC000118D0

Device: N5 2.2 build (Pass)
Build ID               20150609081832
Gaia Revision          06edb0f8db7c2f45cde54401a8593663059861a4
Gaia Date              2015-06-08 14:29:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/239c59921129
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150609.121628
Firmware Date          Tue Jun  9 12:16:44 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
ni? Josh should this be 2.2+ (which I think at this stage just covers the bug for backout)
Flags: needinfo?(jocheng)
Hi Dave,
I have approved the Uplift request and this has been fix on 2.2. 
Make this 2.2+
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(jocheng)
You need to log in before you can comment on or make changes to this bug.