[Flame][Camera]The Flashlight at the back of the device will be turned on by itself.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Camera
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: helen(leave from Mozilla), Assigned: aosmond)

Tracking

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(7 attachments, 3 obsolete attachments)

(Reporter)

Description

3 years ago
Created attachment 8595859 [details]
logcat1645.txt

[1.Description]:
[Flame][v2.2][Camera]The flashlight will turn on by itself after quickly tapping the setting icon 3 times of the Preview page when we cancel sharing this photo with Email.
Occur Time:16:45
Attachment:logcat1645.txt &VIDEO.mp4

[2.Testing Steps]: 
Precondition:You've not create an Email account.
1.Launch Camera,turn to Flash On/Flash Auto mode.
2.Click the camera "shutter" button->click the thumbnail for the photo just taken.
3.Tap the share icon->choose E-Mail->tap Cancel in the Confirmation page
4.When the page of the photo was loading, put the device in low light environment, tap the Setting icon at the top right corner quickly for 3 times.
5.Tap cancel,and tap back icon to the Camera view.

[3.Expected Result]: 
4.The Flashlight at back of the device will not be on. 
5.The view will be normal.

[4.Actual Result]: 
4.The Flashlight at the back of the device is on for a seconds time.
5.The view will keep buffering all the time.

[5.Reproduction build]: 
Device:Flame 2.2(Affected)
Build ID               20150421002501
Gaia Revision          828dd03a0e3b140d74b2e49355197df4d91d9227
Gaia Date              2015-04-20 18:28:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/36f72a3efb9b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.041828
Firmware Date          Tue Apr 21 04:18:39 EDT 2015
Bootloader             L1TC000118D0

Device:Flame 3.0(Unaffected)
Build ID               20150421160203
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/86725d1a2cf3
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.192130
Firmware Date          Tue Apr 21 19:21:42 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
occasionally Recurrence,5/7

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8595865 [details]
VIDEO.mp4
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → unaffected
Reproducible although not likely to happen everyday, but the behavior is quite weird.

In v2.1 when tapping the cancel (in email), it returns to camera preview page, not the same as in v2.2 or master.
Flags: needinfo?(dflanagan)
Andrew and Justin: I have a feeling that we've had other flash-related bugs like this, but I don't know who has worked on them. Any ideas about this one?  Who can investigate it?
Flags: needinfo?(jdarcangelo)
Flags: needinfo?(dflanagan)
Flags: needinfo?(aosmond)
Diego: Justin says he is overloaded with Spark work, so setting needinfo for you on this one as well. Have you worked on the previous flash-related bugs?
Flags: needinfo?(dmarcos)
Created attachment 8597375 [details] [review]
[gaia] aosmond:bug1157163 > mozilla-b2g:master
(Assignee)

Comment 6

3 years ago
(In reply to Autolander from comment #5)
> Created attachment 8597375 [details] [review]
> [gaia] aosmond:bug1157163 > mozilla-b2g:master

No luck reproducing the flash issue yet but I did encounter the spinner problem which this PR should fix.
Flags: needinfo?(jdarcangelo)
Flags: needinfo?(dmarcos)
(Assignee)

Updated

3 years ago
Attachment #8597375 - Attachment is obsolete: true
Created attachment 8597514 [details] [review]
[gaia] aosmond:bug1157163-v2.2 > mozilla-b2g:v2.2
Created attachment 8597518 [details] [review]
[gaia] aosmond:bug1157163 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Flags: needinfo?(aosmond)
Attachment #8597514 - Flags: review?(jdarcangelo)
(Assignee)

Comment 9

3 years ago
Comment on attachment 8597518 [details] [review]
[gaia] aosmond:bug1157163 > mozilla-b2g:master

2.2 and master diverged a bit. I'm not sure if we need this on master... at present the bug isn't reproducible. Let the experts decide :).
Attachment #8597518 - Flags: review?(jdarcangelo)
(Assignee)

Comment 10

3 years ago
Helen: Since the camera should be released properly on 2.2 with my patch, you shouldn't see the flash turn on.

However I was unable to reproduce the flash turning on. I did notice I was able to trigger a touch to focus from the preview gallery which I believe is what is happening on your device. I suspect you have a different Flame version (whether base image of JB instead of KK or different hardware version) than me, and that is why the flash doesn't turn on. Either way, could you please confirm that the flash remains off with my patch given I was unable to reproduce fully? Thanks!
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Flags: needinfo?(hedan)
(Reporter)

Comment 11

3 years ago
Created attachment 8598462 [details]
VIDEOverify.mp4

I have applied this patch on Flame 2.2 and tested this issue with the same steps in comment 0, and this issue do not exist. The base image I used was v18D.

See attachment:VEDIOverify.mp4
Rate:0/5

Flame 2.2 build:
Build ID               20150427162501
Gaia Revision          9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gaia Date              2015-04-27 20:41:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e79c19bf19bf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150427.195038
Firmware Date          Mon Apr 27 19:50:51 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(hedan)
(Reporter)

Comment 12

3 years ago
Could you help with it again? Thanks!
Flags: needinfo?(aosmond)
(Assignee)

Comment 13

3 years ago
Thank you helen! Once it is reviewed we can land this then :).
Flags: needinfo?(aosmond)
Comment on attachment 8597518 [details] [review]
[gaia] aosmond:bug1157163 > mozilla-b2g:master

LGTM
Attachment #8597518 - Flags: review?(jdarcangelo) → review+
Comment on attachment 8597514 [details] [review]
[gaia] aosmond:bug1157163-v2.2 > mozilla-b2g:v2.2

LGTM. Thanks for the patches!
Attachment #8597514 - Flags: review?(jdarcangelo) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#JKASrL5qQ9SJwb2PmgjhlA

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Comment 17

3 years ago
Let's try this again...
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29723

The pull request could not be applied to the integration branch. Please try again after current integration is complete. You may need to rebase your branch against the target branch.
(Assignee)

Comment 19

3 years ago
No tests pending on the master pull request, come on Autolander! :)
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29723

The pull request could not be applied to the integration branch. Please try again after current integration is complete. You may need to rebase your branch against the target branch.
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1158075
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Whiteboard: [autoland:master]

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29723

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
https://github.com/mozilla-b2g/gaia/pull/29725

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
https://github.com/mozilla-b2g/gaia/pull/29725

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
(Assignee)

Comment 25

3 years ago
Comment on attachment 8597514 [details] [review]
[gaia] aosmond:bug1157163-v2.2 > mozilla-b2g:v2.2

Hasn't landed on master yet due to the tree being closed and a build/test backlog appearing yesterday.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Unknown
[User impact] if declined: Camera may be restarted in the background while in the preview gallery; if the user exits the preview gallery to return to the camera, they cannot use any of the controls due to the busy spinner appearing.
[Testing completed]: Added unit tests, verified manually on master and 2.2 via two different STR, along with independent verification on 2.2 (see comment 11).
[Risk to taking this patch] (and alternatives if risky): Low, minimal changes to camera controller. Behaviour only changed if the preview gallery is opened. Worst case there may be additional cases the spinner gets stuck that were missed and the user must restart the camera app.
[String changes made]: None.
Attachment #8597514 - Flags: approval-gaia-v2.2?(bbajaj)
(Assignee)

Updated

3 years ago
Flags: in-testsuite+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Whiteboard: [autoland:master] → [autoland-master]

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29723

The pull request could not be applied to the integration branch. Please try again after current integration is complete. You may need to rebase your branch against the target branch.
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Whiteboard: [autoland-master] → [autoland-master:8597518]

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29723

The pull request could not be applied to the integration branch. Please try again after current integration is complete. You may need to rebase your branch against the target branch.
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Whiteboard: [autoland-master:8597518] → [autoland-$branch:8597518]

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29723

The pull request could not be applied to the integration branch. Please try again after current integration is complete. You may need to rebase your branch against the target branch.
(Assignee)

Updated

3 years ago
Attachment #8597514 - Attachment is obsolete: true
Attachment #8597514 - Flags: approval-gaia-v2.2?(bbajaj)
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Whiteboard: [autoland-$branch:8597518]

Updated

3 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#ry0AY-nhS9CYkfsDTDi6yQ

The pull request failed to pass integration tests. It could not be landed, please try again.
Created attachment 8600874 [details] [review]
[gaia] aosmond:bug1157163-alt > mozilla-b2g:master [carries r=justindarc]
(Assignee)

Updated

3 years ago
Attachment #8600874 - Attachment description: [gaia] aosmond:bug1157163-alt > mozilla-b2g:master → [gaia] aosmond:bug1157163-alt > mozilla-b2g:master [carries r=justindarc]
Attachment #8600874 - Flags: review+
(Assignee)

Updated

3 years ago
Attachment #8597518 - Attachment is obsolete: true
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
(Assignee)

Comment 32

3 years ago
(In reply to Autolander from comment #31)
> Autolander could not locate a review from a user within the suggested
> reviewer list. Either the patch author or the reviewer should be in the
> suggested reviewer list.

Soon I will be reduced to begging. I am now on the suggested reviewer list, autolander engage!
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/f00b485676c2c1e1268dd40f3eb0618d733c6c39

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Created attachment 8600903 [details] [review]
[gaia] aosmond:bug1157163-alt-v2.2 > mozilla-b2g:v2.2 [carries r=justindarc]
(Assignee)

Comment 35

3 years ago
Comment on attachment 8600903 [details] [review]
[gaia] aosmond:bug1157163-alt-v2.2 > mozilla-b2g:v2.2 [carries r=justindarc]

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Unknown
[User impact] if declined: Camera may be restarted in the background while in the preview gallery; if the user exits the preview gallery to return to the camera, they cannot use any of the controls due to the busy spinner appearing.
[Testing completed]: Added unit tests, verified manually on master and 2.2 via two different STR, along with independent verification on 2.2 (see comment 11).
[Risk to taking this patch] (and alternatives if risky): Low, minimal changes to camera controller. Behaviour only changed if the preview gallery is opened. Worst case there may be additional cases the spinner gets stuck that were missed and the user must restart the camera app.
[String changes made]: None.
Attachment #8600903 - Attachment description: [gaia] aosmond:bug1157163-alt-v2.2 > mozilla-b2g:v2.2 → [gaia] aosmond:bug1157163-alt-v2.2 > mozilla-b2g:v2.2 [carries r=justindarc]
Attachment #8600903 - Flags: review+
Attachment #8600903 - Flags: approval-gaia-v2.2?(bbajaj)
Add "verifyme" for v2.2 verification.
Keywords: verifyme

Comment 37

3 years ago
(In reply to Shally from comment #36)
> Add "verifyme" for v2.2 verification.

Shally,
The fix is not on 2.2 yet. PLease verify this on master which is already landed.
status-b2g-master: unaffected → fixed
Flags: needinfo?(lixia)
(Assignee)

Comment 38

3 years ago
(In reply to Josh Cheng [:josh] from comment #37)
> (In reply to Shally from comment #36)
> > Add "verifyme" for v2.2 verification.
> 
> Shally,
> The fix is not on 2.2 yet. PLease verify this on master which is already
> landed.

Please use the STR in the duplicate bug 1158075 to verify on master. It only happens on 2.2 with the original STR.
Andrew, thank you very much for your kindly reminding.

This bug has been verified as pass on latest build of Flame v3.0 by the STR in "https://bugzilla.mozilla.org/show_bug.cgi?id=1158075#c0"

Actual results: Device backs to viewfinder normally and flashlight does not turn on by itself.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/5


Device: Flame 3.0 build(Pass)
Build ID               20150506160205
Gaia Revision          426fe6450ab8da92bb473fef12ccb39c6c920dd0
Gaia Date              2015-05-06 08:40:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5593ac626826
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.193508
Firmware Date          Wed May  6 19:35:21 EDT 2015
Bootloader             L1TC000118D0
status-b2g-master: fixed → verified
Flags: needinfo?(lixia)
Keywords: verifyme
Created attachment 8602488 [details]
verified_v3.0.mp4
QA Whiteboard: [MGSEI-Triage+]

Comment 41

3 years ago
Comment on attachment 8600903 [details] [review]
[gaia] aosmond:bug1157163-alt-v2.2 > mozilla-b2g:v2.2 [carries r=justindarc]

Approving this given this is regression and should be 2.2 blocker.
Attachment #8600903 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29864

The pull request could not be applied to the integration branch. Please try again after current integration is complete. You may need to rebase your branch against the target branch.
(Assignee)

Comment 43

3 years ago
Branch rebased.
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29864

The pull request could not be applied to the integration branch. Please try again after current integration is complete. You may need to rebase your branch against the target branch.
Possibly a problem with the integration branch? I've manually deleted so trying again. If the issue persists, we'll just land manually. Thanks!
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
Pull request has landed in v2.2: https://github.com/mozilla-b2g/gaia/commit/88d3ac2721a5484495c2ed60e4a068945f0de5aa
(Assignee)

Updated

3 years ago
Depends on: 1162890
Per Comment 46,this bug has been landed and fixed on v2.2.

This bug has been verified as pass on latest Nightly build of Flame v2.2 by the STR in Comment 0.

Actual results: The Flashlight will not be turned on by itself anymore.
See attachment: verified_v2.2.mp4
Reproduce rate: 0/8


Device: Flame v2.2 build(Pass)
Build ID               20150510002505
Gaia Revision          528ef60e7cda09ad43478065f5d33bda398fbeb7
Gaia Date              2015-05-08 23:40:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d04cc085cf5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.042512
Firmware Date          Sun May 10 04:25:23 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: affected → verified
Created attachment 8603947 [details]
verified_v2.2.mp4
Target Milestone: --- → 2.2 S12 (15may)
You need to log in before you can comment on or make changes to this bug.