[Browser]Multiple Locales: The hint text "Search or enter address" is displayed with truncation in URL.

VERIFIED FIXED

Status

Firefox OS
Gaia::Browser
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Lancy(Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 wontfix, b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.2,)

Attachments

(10 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8595868 [details]
Screenshot_hint text.png

[1.Description]:
[l10n][v2.2][Browser]Spanish:Enter "New Private Window" view, the hint text of "Search or enter address" is displayed with truncation in URL.
See attachment:Screenshot_hint text.png.

[2.Testing Steps]: 
1.Set your phone language to Spanish.
2.Connect to network and launch the Browser app
3.Tap on the "New Private Window" button 


[3.Expected Result]: 
3.The hint text of "Search or enter address" should not be displayed with truncation in URL.

[4.Actual Result]: 
3.The hint text of "Search or enter address" is displayed with truncation in URL.

[5.Reproduction build]: 
Device: Flame 2.2 user build (Affected)
Build ID               20150421002501
Gaia Revision          828dd03a0e3b140d74b2e49355197df4d91d9227
Gaia Date              2015-04-20 18:28:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/36f72a3efb9b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.042925
Firmware Date          Tue Apr 21 04:29:36 EDT 2015
Bootloader             L1TC000118D0

Device Flame 2.1 user build (Unffected)
Build ID               20150421001205
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.040717
Firmware Date          Tue Apr 21 04:07:27 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
16053

[8.Note]:
The "New Private Window" function dose not exist on Flame 2.1 user build.

Comment 1

3 years ago
I think this is a UX fix rather than a localization issue.
yup, I agree with Inma.
Moving over to FirefoxOS component. This is clearly a regression as you used the same string in 2.2 as in 2.1 and there was no issue there: https://transvision.mozfr.org/?recherche=earch+or+enter+address&repo=gaia_2_1&sourcelocale=en-US&locale=es&search_type=strings
Spanish is a shipping locale, and I assume this is going to affect other locales. Thus nominating
blocking-b2g: --- → 2.2?
Keywords: regression
Assignee: rpmdisguise-otros → nobody
Component: es-ES / Spanish → Gaia::Browser
Product: Mozilla Localizations → Firefox OS
Summary: [l10n][Browser]Spanish:The hint text "Search or enter address" is displayed with truncation in URL. → [Browser]Multiple Locales: The hint text "Search or enter address" is displayed with truncation in URL.
Created attachment 8596357 [details]
bn-IN.png

This problem can be reproduced in bn-IN language on Flame 2.2 user build.
See attachment: bn-IN.png
Device: Flame 2.2 user
Build ID               20150422002505
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a87a05e7d0ef
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.040316
Firmware Date          Wed Apr 22 04:03:27 EDT 2015
Bootloader             L1TC000118D0

Comment 4

3 years ago
Set system language to Portuguese Brazi,this issue exist on Flame2.2(Not exist on Flame User 2.1):
Flame 2.2 user: Affected
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Refer to picture 2015-04-24-16-40-22.png
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Spanish → LocRun2.2, MGSEI-l10n-1F-Spanish,MGSEI-l10n-1F-Portuguese Brazil

Comment 5

3 years ago
Created attachment 8597121 [details]
2015-04-24-16-40-22.png
Lancy, Shine and Elie: I'm going to need for all the locales that you've cited, screenshots for 2.1 as well. I can't see if this is really a regression or not if I don't get them. thanks
Flags: needinfo?(zikui.yang)
Flags: needinfo?(yulan.zhu)
Flags: needinfo?(yue.xia)
IIRC, I think that the "mask" image was added to the left of the url bar in 2.2. So this isn't a regression per say, I would say.
Taking out the keyword while waiting for the screenshots for confirmation...
Keywords: regression
(In reply to Delphine Lebédel [:delphine - PTO Monday April 27]] from comment #6)
> Lancy, Shine and Elie: I'm going to need for all the locales that you've
> cited, screenshots for 2.1 as well. I can't see if this is really a
> regression or not if I don't get them. thanks

Hi Delphine,
On Flame 2.1 user build, it doesn't support the function of "New Private Window" in Browser app.
Thanks!
Flags: needinfo?(zikui.yang)
Flags: needinfo?(yulan.zhu)
Flags: needinfo?(yue.xia)
Created attachment 8597849 [details]
pt-PT_ SearchOrEnterAddress.png

This problem can be reproduced on Flame 2.2 user build in pt-PT language.(Flame 2.1 user build doesn't support the function.)
See attachment: pt-PT_Private Window.png
Device: Flame 2.2 user (Affected)
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.040327
Firmware Date          Sun Apr 26 04:03:38 EDT 2015
Bootloader             L1TC000118D0
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Spanish,MGSEI-l10n-1F-Portuguese Brazil → LocRun2.2, MGSEI-l10n-1F-Spanish,MGSEI-l10n-1F-Portuguese Brazil,MGSEI-l10n-1F-Portuguese Portugal
Attachment #8597849 - Attachment is obsolete: true
Created attachment 8597858 [details]
pt-PT_Private Window.png

Sorry, I have uploaded the incorrect screenshot in comment 9, please see attachment: pt-PT_Private Window.png.
Nominating for general triage decision since this affects multiple shipping locales (and there's not much one can do to shorten this string)
status-b2g-v2.1: unaffected → wontfix
Seems like we need UX help here. What should we do in this case?
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 13

3 years ago
Flagging Amy. Again, some truncation is acceptable. The problem is if a term is so truncated that it no longer makes sense. Let us know if that's the case here.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(amlee)
(In reply to Stephany Wilkes from comment #13)
> Flagging Amy. Again, some truncation is acceptable. The problem is if a term
> is so truncated that it no longer makes sense. Let us know if that's the
> case here.

Flagging Eric to comment on this bug for browser.
Flags: needinfo?(amlee) → needinfo?(epang)
(In reply to Stephany Wilkes from comment #13)
> Flagging Amy. Again, some truncation is acceptable. The problem is if a term
> is so truncated that it no longer makes sense. Let us know if that's the
> case here.

Hi, before we make any changes Stephany asks a good question.  Are the truncations acceptable and understandable where they are being cut off?  Also, is there any way to reduce the strings?

If the answer is no for the above questions I'll explore a few options (most likely reducing the font size, but only for locales that need it).
Flags: needinfo?(epang)

Comment 16

3 years ago
(In reply to Eric Pang [:epang] from comment #15)
> (In reply to Stephany Wilkes from comment #13)
> > Flagging Amy. Again, some truncation is acceptable. The problem is if a term
> > is so truncated that it no longer makes sense. Let us know if that's the
> > case here.
> 
> Hi, before we make any changes Stephany asks a good question.  Are the
> truncations acceptable and understandable where they are being cut off? 

As a native Spanish speaker, I can say they're understandable.
Flagging all remaining localizers so they can say if the truncation is acceptable in their language (or if they can shorten the string), or if we need to get a fix for this.
Flags: needinfo?(mv.nsaad)
Flags: needinfo?(cesperanc)
Flags: needinfo?(brnet00)
(that said, this is affecting already 4 shipping locales. Probably means many more out of our 90 available locales are affected as well. And this isn't an easy string to shorten)
On the pt-PT locale what the user will read is something like: "Search or ente...". I think that the user won't to be able the infer that he or she must enter an address.

Maybe we can change the text to something like "Search or browse", which in Portuguese will be something like "Pesquisar ou navegar". Just an idea.
Flags: needinfo?(cesperanc)
Anyone that has ever used a modern browser will be able to figure out what the bar is there for. However, our target audience may not fit that scenario. I think that changing the string to something shorter is hardly possible without changing its meaning. I do Like what :cesperanc@ suggested.

If we're not going with that, I would say we need an UI change.
Flags: needinfo?(mv.nsaad)
According to this we already updated the string https://transvision.mozfr.org/?recherche=Search+or+enter+address&repo=gaia&sourcelocale=en-US&locale=bn-IN&search_type=strings .

But as I have seen it has not been updated in flame 2.2 and 2.1.

Please let me know if I am wrong at any point.
Flags: needinfo?(brnet00) → needinfo?(lebedel.delphine)
Biraj: for Pootle glitches please reach out to Dwayne who can help fix this.thanks
Flags: needinfo?(lebedel.delphine) → needinfo?(dwayne)
(Reporter)

Comment 23

3 years ago
Created attachment 8604513 [details]
Screenshot_Search or enter address_Basque.png

This issue also happen on latest Flame 2.2 user build in Basque language.
This issue does not exist in Serbian Cyrillic, Russian, Greek, Polish, Arabic.

See attachment:Screenshot_Search or enter address_Basque.png
Reporducing rate:10/10

Device: Flame 2.2 user build
Build ID               20150511162500
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150511.195649
Firmware Date          Mon May 11 19:56:59 EDT 2015
Bootloader             L1TC000118D0

Comment 24

3 years ago
Biraj: just checked there shouldn't be anything blocking 2.1 and 2.2 commits.  Let me know if you hit a problem again.
Flags: needinfo?(dwayne)
Ok then please go ahead and test for bn-IN.
Flags: needinfo?(yue.xia)
Created attachment 8604997 [details]
Verify_Pass_Bengali India_Search or enter address.png

Hi Biraj,
This problem is verified not to happen on latest Flame 2.2 user build in bn-IN language.
Actual Result: The "Search or enter address" string has been shortened, and it is displayed without truncation now.
Please see attachment: Verify_Pass_Bengali India_Search or enter address.png

Device: Flame 2.2 user 
Build ID               20150512002502
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.041710
Firmware Date          Tue May 12 04:17:22 EDT 2015
Bootloader             L1TC000118D0

Thanks!
Flags: needinfo?(yue.xia)
Thanks!

Could you test for 2.1 also ?
Hi Biraj,
On Flame 2.1 user build, it doesn't support the function of "New Private Window" in Browser app.
Thanks!
Flags: needinfo?(brnet00)
@shine thanks for letting me know.
Flags: needinfo?(brnet00)
Not blocking based on timelines and user impact.
blocking-b2g: 2.2? → ---
QA Whiteboard: [MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Spanish,MGSEI-l10n-1F-Portuguese Brazil,MGSEI-l10n-1F-Portuguese Portugal → LocRun2.2,
Claudio, Marcus: have you been able to shorten the string? If so, let's close this bug as resolved-fixed. thanks!
Flags: needinfo?(mv.nsaad)
Flags: needinfo?(cesperanc)
Fixed over here for pt-BR.
Flags: needinfo?(mv.nsaad)
String shortened for pt-PT v2.2.
Flags: needinfo?(cesperanc)
Ok closing this bug as resolved fix since the affected locales (Spanish, pt-PT and pt-BR) were corrected. As per localizers, string should be understandable now. QA please verify!
thanks
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 35

3 years ago
Created attachment 8621412 [details]
Verify2_PT-pt&Basque_v2.2_Fail.png

Hi Delphine,
This issue is verified pass on latest flame 2.2 user build in pt-BR language, but still exist on latest flame 2.2 user build in pt-PT and Basque languages.
Note:Per comment 16, the strings with truncation are understandable in Spanish language.
See attachment:Verify2_PT-pt&Basque_v2.2_Fail.png and Verify2_PT-BR_v2.2_Pass.png.
PT-BR reprroducing rate:0/10
PT-PT & Basque reproducing rate:10/10

Flame 2.2 user build:
Build ID               20150611162501
Gaia Revision          cfceba16e48ede3defee24be93637a0fa291c494
Gaia Date              2015-06-11 22:10:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3478f3c355c2
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150611.195442
Firmware Date          Thu Jun 11 19:54:53 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(lebedel.delphine)
(Reporter)

Updated

3 years ago
QA Whiteboard: [MGSEI-l10n-1F] → [MGSEI-l10n-1F][MGSEI-Triage+]
(Reporter)

Comment 36

3 years ago
Created attachment 8621417 [details]
Verify2_PT-BR_v2.2_Pass.png
Hello.

Apparently a couple of strings were skipped when I searched the string in Portuguese on Pootle. The problem is now fixed for pt-PT v2.2 on locamotion.

Sorry for the mistake.

Cheers, 

Cláudio
Created attachment 8622402 [details]
Verify_Pass_Flame2.2_Pt-pt.png

This Problem is verified as pass on latest flame 2.2 user build in pt-PT language.
Actual result: the string has been shortened to "Pesquisar ou navegar" and the string is displayed without truncation now.
Rate: 0/5
See attachment: Verify_Pass_Flame2.2_Pt-pt.png

Device information:
Flame 2.2 user (Pass)
Build ID               20150614162504
Gaia Revision          cfceba16e48ede3defee24be93637a0fa291c494
Gaia Date              2015-06-11 22:10:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cfd86c2ba1b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150614.200131
Firmware Date          Sun Jun 14 20:01:42 EDT 2015
Bootloader             L1TC000118D0
Flagging Basque localizer to see if he can shorten string, as per comment 35. thanks!
Flags: needinfo?(lebedel.delphine) → needinfo?(julenx)

Updated

3 years ago
Flags: needinfo?(julenx) → needinfo?(ibai)

Comment 40

3 years ago
I've shortened the string for Basque, it should fit now.
Flags: needinfo?(ibai)
QA: please verify, thanks!
Keywords: verifyme
(Reporter)

Comment 42

3 years ago
Created attachment 8624005 [details]
Verify4_Basque_v2.2_Pass.png

According to the STR in comment 0, this issue is verified pass on latest flame v2.2 user build, the hint text "Search or enter address" is displayed without truncation in Basque language. 
See attachment:Verify4_Basque_v2.2_Pass.png.
Reproducing rate:0/10

Device: Flame 2.2 user build (Pass)
Build ID               20150617162515
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a2db74491088
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150617.194909
Firmware Date          Wed Jun 17 19:49:20 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.2: affected → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.