[Cost Control] The "Reset mobile & Wi-Fi data" are displayed with truncation on "Reset data usage" view.

VERIFIED FIXED in 2.2 S12 (15may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yue.xia, Assigned: sfoster)

Tracking

({regression})

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: LocRun2.2)

Attachments

(7 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[110n][v2.2][Cost Control]Bengali India: Enter Usage settings view, tap 'Reset', the "Reset mobile & Wi-Fi data" are displayed with truncation on "Reset data usage" view.
See attachment: Reset mobile & Wi-Fi data.png

[2.Testing Steps]: 
Prerequisite: Have an active SIM card in the device  
1. Open Usage app 
2. Navigate through cost control FTE
3. Tap on the gear icon to access settings 
4. Tap 'Reset'  

[3.Expected Result]: 
4. The "Reset mobile & Wi-Fi data" should not be truncated.

[4.Actual Result]: 
4. The "Reset mobile & Wi-Fi data" are displayed with truncation.

[5.Reproduction build]: 
Device: Flame 2.2 user (Affected)
Build ID               20150421002501
Gaia Revision          828dd03a0e3b140d74b2e49355197df4d91d9227
Gaia Date              2015-04-20 18:28:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/36f72a3efb9b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.042925
Firmware Date          Tue Apr 21 04:29:36 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 user (Unaffected)
Build ID               20150421001205
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.040717
Firmware Date          Tue Apr 21 04:07:27 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
16010

[8. Note]:
This same problem in different language need different RD to resolve.
(Reporter)

Updated

4 years ago
See Also: → 1153174
(Reporter)

Updated

4 years ago
Summary: [110n][Cost Control]Bengali India: The "Reset mobile & Wi-Fi data" are displayed with truncation on "Reset data usage" view. → [l10n][Cost Control]Bengali India: The "Reset mobile & Wi-Fi data" are displayed with truncation on "Reset data usage" view.
not an l10n issue.
This affects Arabic and bn-BD, and probably more shipping locales. Regression: was fixed on 2.1. 
Flaggin UX for help on this. THanks!
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: regression
Summary: [l10n][Cost Control]Bengali India: The "Reset mobile & Wi-Fi data" are displayed with truncation on "Reset data usage" view. → [Cost Control] The "Reset mobile & Wi-Fi data" are displayed with truncation on "Reset data usage" view.
Duplicate of this bug: 1153174
Regression on shipping locales, nominating
blocking-b2g: --- → 2.2?
(Reporter)

Updated

4 years ago
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Bengali India → LocRun2.2
(Reporter)

Comment 4

4 years ago
Per comment 1, clear the MGSEI-l10n-1F-Bengali India whiteboard tag.

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
Hi Shine,
Can you provide how the screen looks like in 2.1?
Flags: needinfo?(yue.xia)
(Reporter)

Comment 6

4 years ago
Hi Josh,
Please see attachment: Flame2.1user_bn-IN.png. Thanks!
Device: Flame 2.1 user:
Build ID               20150422001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/685fa69b59dc
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.035556
Firmware Date          Wed Apr 22 03:56:07 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(yue.xia)
(Reporter)

Updated

4 years ago
Whiteboard: LocRun2.2 → LocRun2.2, MGSEI-l10n-1F-Bengali India

Comment 7

4 years ago
Hi Delphine,This issue exists on Flame 2.2 and 2.1,when set system language to Russian.

As https://etherpad.mozilla.org/l10n-fxos-testing-2-2 mentiond,when issue exist on both 2.2 and 2.1,this problem of Russia should be l10n issue.Need I file a new issue under Firefox localizations for Russian?
Flags: needinfo?(lebedel.delphine)

Updated

4 years ago
Component: bn-IN / Bengali (India) → Gaia::Cost Control
Product: Mozilla Localizations → Firefox OS
Comment hidden (obsolete)
Hi Elie,
If this issue happen on both 2.1 and 2.2 for Russia. Please open a new bug for l10n. If same issue happen on other language, just open one and attach comment. Thanks.
HI Salvador,
This is regression from 2.1. Could you please help to fix this issue? Thanks!
Flags: needinfo?(salva)
Josh, Elie: actually, no need to open other bugs for the same issue. This issue is going to affect multiple locales, and the fix we get should help cover them all. Please just leave a comment of the locales you see this happen in here. thanks
Flags: needinfo?(lebedel.delphine) → needinfo?(jocheng)
(In reply to Josh Cheng [:josh] from comment #9)
> Hi Elie,
> If this issue happen on both 2.1 and 2.2 for Russia. Please open a new bug
> for l10n. If same issue happen on other language, just open one and attach
> comment. Thanks.

Sorry kinda misread your comment Josh. Given both branches are affected for Russian let's do that. But please comment here that Russian (and whatever other locales) is also affected on 2.2. Thanks!

Comment 13

4 years ago
Already a +, removing the flag for UX. Should look as it did before it regressed.
Flags: needinfo?(firefoxos-ux-bugzilla)

Updated

4 years ago
See Also: → 1158039

Comment 14

4 years ago
This issue exists on Flame 2.2 and 2.1,when set system language to Russian.Create a new issue 1158039  to tracking the problem for Russian.
Flags: needinfo?(zikui.yang)
Flags: needinfo?(marina.rodrigueziglesias)

Updated

4 years ago
Flags: needinfo?(jocheng)
Noemi,

can you help here?

Thanks
Flags: needinfo?(noemi.freiredecarlos)
Excuse me, are you saying at some point in 2.1 we don't have this truncation issue?
Flags: needinfo?(salva)
Yes: see screenshots attached.
This affects multiple shipping locales
Per comment 10 asking for regression window. Thanks!
Flags: needinfo?(noemi.freiredecarlos)
QA Contact: bzumwalt
Mozilla-Inbound Regression Window (Bengali):

Russian and Arabic issues appear to be separate as Russian is broken earlier on central buildid 20150304133643 while Arabic is affected with this issue as far back as 20150218162944 (before affected string was even translated in Russian.)


Last working Mozilla-Inbound build:
Device: Flame 3.0
Build ID: 20150319193147
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 4d2d97b3ba34
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First broken Mozilla-Inbound build:
Device: Flame 3.0
Build ID: 20150319211513
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 9590d9ed9e76
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Working Gaia with Broken Gecko issue DOES reproduce:
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
9590d9ed9e76

Working Gecko with Broken Gaia issue does NOT reproduce:
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 4d2d97b3ba34


Mozilla-Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4d2d97b3ba34&tochange=9590d9ed9e76


Issue appears to have been caused by changes made in bug 1010675
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
David, can you take a look at this please? This might have been caused by the work done for bug 1010675.
Blocks: 1010675
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(dbaron)
(Assignee)

Comment 21

4 years ago
I looked into this. The new truncation might be in part because of bug 1010675. I'll attach a pull request to get some of that space back for the button label. But also note that the string is:

মোবাইল এবং ওয়ই-ফাই ডাটা পুনরায় সেট করুন

..which is significantly longer than will fit in that button. In the 2.1 screenshot we seem to be missing the last word 'করুন'. I wonder if this was always truncated and we are just seeing the ellipsis now? Or if the string also changed. 

I'm going to cancel dbaron's needinfo as I think the motivation and impact of bug 1010675 is well understood at this point, and this is a bug we want to fix in Gaia, not at the platform layer.
Assignee: nobody → sfoster
Flags: needinfo?(dbaron)
(Assignee)

Comment 22

4 years ago
reset-all string was renamed in bug #1089968; in 2.1 it was reset-all-data-usage = মোবাইল এবঙ ওয়াই-ফাই তথ্য রিসেট করুন. So that's a new string, which accounts in part for the difference.
(Assignee)

Comment 24

4 years ago
Screenshot of the reset dialog with patch applied, bn-IN locale
(Assignee)

Comment 25

4 years ago
Comment on attachment 8600977 [details] [review]
[gaia] sfoster:action-menu-buttons-bug-1157174 > mozilla-b2g:master

The patch adjusts the -end padding for action menu buttons to the effective value prior to bug #1010675 - in which long strings were allowed to overflow into the button padding. This buys enough space to avoid truncation of the label. It is tight however and not ideal from a UX point of view. We can't do much here at a code level for v2.2 without triggering widespread string changes; we're just trying to plug the regression. This string in particular is new in v2.2 and we might be able to improve things here by revisiting the translation.
Attachment #8600977 - Flags: review?(kgrandon)
Comment on attachment 8600977 [details] [review]
[gaia] sfoster:action-menu-buttons-bug-1157174 > mozilla-b2g:master

I didn't actually test this on a device, but the code looks simple enough to me. R+ from me, thanks!
Attachment #8600977 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Target Milestone: --- → 2.2 S12 (15may)
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
If we move this to shared (which is where the code change was), checkin-needed should work. Adding it again.
Component: Gaia::Cost Control → Gaia::Shared
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 30

4 years ago
See comment #21 and comment #22, the code change here should help with many locales, but may not be enough by itself to fix bn-IN. Can we verify this on master and file any l10n follow-up bugs so we can get started on requesting uplift for the code change?
Flags: needinfo?(lebedel.delphine)
Hey Sam! Yes that sounds good. Let's follow up on Mozilla localizations for any bugs where the string continues to be too long, and see if localizers can shorten it.
Flagging Marigold so they are aware of this (see this comment and comment 30).
Also, asking QA to verify this on master. thanks!
Flags: needinfo?(lebedel.delphine) → needinfo?(yue.xia)
Keywords: verifyme
(Reporter)

Comment 32

4 years ago
Hi Sam,
* On latest user build of Flame 3.0 in the language of Bengali India, the "Reset mobile & Wi-Fi data" are displayed without truncation now, but the last word 'করুন' is too closed to right border. Please see attachment: Bengali India_3.0user_Reset mobile & Wi-Fi data.png

* This problem is verified pass on latest user build of Flame 3.0 in the language of Spanish, Serbian Cyrillic, Russian, Greek, Polish, Basque, Portuguese from Portugal.
Please see attachment: Verify_Pass_3.0user_Reset mobile & Wi-Fi data.png

* This problem is verified fail on latest user build of Flame 3.0 in the language of Portuguese from Brazil and Arabic.
A bug for Arabic language has already been submitted. Please see bug 1153174.
And I have filed a new bug for the Portuguese Brazil language. Please see bug 1162382.

Many thanks!
Flags: needinfo?(yue.xia)
(Reporter)

Updated

4 years ago
See Also: → 1162382
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
(Assignee)

Comment 35

4 years ago
(In reply to Shine from comment #32)
> * On latest user build of Flame 3.0 in the language of Bengali India, the
> "Reset mobile & Wi-Fi data" are displayed without truncation now, but the
> last word 'করুন' is too closed to right border. Please see attachment:
> Bengali India_3.0user_Reset mobile & Wi-Fi data.png

I agree it is too close, but the patch effectively puts back the left/right padding that was being applied in 2.1. So, while I agree we want to fix this, its no longer a regression and we should probably file a new bug. Fixing the padding issue is what created these regressions. We are simply out of space there - maybe UX have some ideas on how to handle it, but I suspect this will go back to the localizers as being a string that needs shortening. So, while it sounds pedantic, I think your screenshot shows this bug is verified as we no longer truncate.
I agree with Sam. Let's file a follow-up bug for Bengali (bn-IN) (and any other locale that might still be affected) under Mozilla Localizations so localizers can try to shorten string there.
Changing the flag to verified on master to reflect comment 35.
(Assignee)

Comment 38

4 years ago
Comment on attachment 8600977 [details] [review]
[gaia] sfoster:action-menu-buttons-bug-1157174 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): System action menu buttons (post-fix for bug 1010675)
[User impact] if declined: Button labels in action menus may be truncated and their meaning unclear in some languages
[Testing completed]: Tested on device in various languages, verified on master
[Risk to taking this patch] (and alternatives if risky): Low risk, CSS-only change
[String changes made]: None
Attachment #8600977 - Flags: approval-gaia-v2.2?
Attachment #8600977 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Flags: needinfo?(marina.rodrigueziglesias)
Issue verified fixed on Flame 2.2

No truncation occurs in Bengali-India, Spanish, Serbian Cyrillic, Russian, Greek, Polish, Basque, or Portuguese from Portugal on Reset mobile & Wi-Fi data string.

Device: Flame 2.2
Build ID: 20150511002500
Gaia: 528ef60e7cda09ad43478065f5d33bda398fbeb7
Gecko: 8d04cc085cf5
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+] → [QAnalyst-Triage?][MGSEI-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Comment 41

4 years ago
* Per comment 40, the verification results of Spanish, Serbian Cyrillic, Russian, Greek, Polish, Basque, or Portuguese from Portugal are pass.
* In the language of Bengali India, "Reset mobile & Wi-Fi data" string has been shortened successfully.
See attachment: Verify_Pass_2.2user_Bengali India_Reset mobile & Wi-Fi data.png
* This problem is verified fail on latest user build of Flame 2.2 in the language of Portuguese Brazil and Arabic.
Bugs for Arabic language and Portuguese Brazil language have already been submitted. Please see bug 1153174 and bug 1162382.

Device: Flame2.2 user
Build ID               20150511162500
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150511.195649
Firmware Date          Mon May 11 19:56:59 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Bengali India → LocRun2.2
You need to log in before you can comment on or make changes to this bug.