[First Time Experience] The string in Join button is truncated.

VERIFIED WORKSFORME

Status

defect
VERIFIED WORKSFORME
4 years ago
4 years ago

People

(Reporter: zikui.yang, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: LocRun2.2, [systemsfe])

Attachments

(4 attachments)

Reporter

Description

4 years ago
[1.Description]:
[110n][]v2.2[First Time Experience]Russian:Enter Select network page and open a encrypted wifi,the string in Join button is truncated.
Attchemnt:2015-04-22-07-53-50.png

[2.Testing Steps]: 
1.Launch FTE
2.Set system langua to Russian
3.Tap next to go Select a network page
4.Tap a encrypted wifi 

[3.Expected Result]: 
4.The string in Join button should be shown completely.

[4.Actual Result]: 
4.The string in Join button is truncated.

[5.Reproduction build]: 
Device: Flame 2.2 user (Affected)
Build ID               20150421002501
Gaia Revision          828dd03a0e3b140d74b2e49355197df4d91d9227
Gaia Date              2015-04-20 18:28:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/36f72a3efb9b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2

Device Flame 2.1 user build (Unaffected)
Build ID               20150421001205
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.040717
Firmware Date          Tue Apr 21 04:07:27 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12257
Reporter

Comment 1

4 years ago
Reporter

Updated

4 years ago
Reporter

Updated

4 years ago
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Russia → LocRun2.2, MGSEI-l10n-1F-Russian
Reporter

Updated

4 years ago
Summary: [110n][First Time Experience]Russian:The string in Join button is truncated. → [l10n][First Time Experience]Russian:The string in Join button is truncated.
Yet another regression from 2.1 and 2.2. Russian used same string in both branches, but now the string truncates: https://transvision.mozfr.org/?recherche=Join&repo=gaia_2_1&sourcelocale=en-US&locale=ru&search_type=strings

Since this is FTE, a regression and an issue on a shipping locale (and probably more affected), nominating this for 2.2
blocking-b2g: --- → 2.2?
Component: ru / Russian → Gaia::First Time Experience
Keywords: regression
Product: Mozilla Localizations → Firefox OS
Summary: [l10n][First Time Experience]Russian:The string in Join button is truncated. → [First Time Experience] The string in Join button is truncated.
Asking for ux help on this thanks!
Flags: needinfo?(firefoxos-ux-bugzilla)
While each of these issues is minor individually, together they add up to a bad first-time experience. I'm inclined to either block on each, or perhaps to create an umbrella bug for clipping/truncation in FTU and block on that. IIRC there was a fix landed in gecko which has probably precipitated these regressions, I'll try and find the bug #.
Reporter

Updated

4 years ago
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Russian → LocRun2.2
Reporter

Updated

4 years ago
Whiteboard: LocRun2.2 → LocRun2.2,MGSEI-l10n-1F-Russian

Comment 5

4 years ago
This is a regression so 2.2+.
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: LocRun2.2,MGSEI-l10n-1F-Russian → LocRun2.2,MGSEI-l10n-1F-Russian [systemsfe]
Please provide a screenshot for 2.1 as well.
Flags: needinfo?(zikui.yang)
Reporter

Comment 7

4 years ago
(In reply to Gregor Wagner [:gwagner] from comment #6)
> Please provide a screenshot for 2.1 as well.

Attach 2.1 screenshot.
Flags: needinfo?(zikui.yang)
I've shortened this string for Russian l10n:
http://hg.mozilla.org/gaia-l10n/ru/rev/ea171cc55845
See comment 8.
Flags: needinfo?(zikui.yang)
Keywords: verifyme
Reporter

Comment 10

4 years ago
Add Flame2.1Screenshot for this issue.
Flags: needinfo?(zikui.yang)
We need a screenshot for the current version of 2.2. Comment 8 suggests that the new translation might fit and we can close the bug.
Flags: needinfo?(zikui.yang)
Reporter

Comment 12

4 years ago
(In reply to Gregor Wagner [:gwagner] from comment #11)
> We need a screenshot for the current version of 2.2. Comment 8 suggests that
> the new translation might fit and we can close the bug.
Add the curent version of 2.2 screenshot:
Build version:
Build ID               20150427002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150427.040119
Firmware Date          Mon Apr 27 04:01:31 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(zikui.yang)
Thanks!
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Per Comment 12 and Comment 13,clear "verifyme" keyword.
Keywords: verifyme
QA Whiteboard: [MGSEI-Triage+]
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2,MGSEI-l10n-1F-Russian [systemsfe] → LocRun2.2, [systemsfe]
You need to log in before you can comment on or make changes to this bug.