Closed Bug 1157186 Opened 5 years ago Closed 5 years ago

"search" vanishes from options when clicked

Categories

(Firefox :: Preferences, defect)

40 Branch
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mark, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150421030209

Steps to reproduce:

1. Load up Firefox (release or nightly)
2. Go to Options, this opens "about:preferences"
3. Click the "Search" tab.


Actual results:

The search tab vanishes when clicked. Also, the selection drop-down for search engines is empty.
This also happens in Safe Mode (no extensions)
Clicking "restore default search engines" also does nothing.


Expected results:

The search pane should work properly and the search tab should not vanish.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150422030206

(In reply to Mark Straver from comment #0)
> 1. Load up Firefox (release or nightly)
> 2. Go to Options, this opens "about:preferences"

No, it doesn't. In Firefox 37, you get an options window. Anyway, I can't reproduce this in the current Nightly. Disabling e10s and hardware acceleration made no difference. Can you reproduce this in a brand new profile?
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Component: Untriaged → Preferences
Flags: needinfo?(mark)
I'm sorry but it does open the in-content preferences, even on a blank profile. I think with Nightly sharing the profile with release, it may enforce the in-content preferences on -release. That's really not very nice in that case. Why can't these remain separated like they were before?

The blank profile does fix the issue this bug is about though, so I'm not entirely sure what would have caused this then. Maybe having nightly run and muddle up more things in my release version profile caused this. Now for the joy to re-build my entire FF profile... :(
Flags: needinfo?(mark)
(In reply to Mark Straver from comment #2)
> I think with Nightly sharing the profile with release, it may enforce
> the in-content preferences on -release.

Running Nightly sets the browser.preferences.inContent preference to true. If you want to return to Options in a window on Release,
1. In the address bar, paste the following, then press Enter:
about:config?filter=browser.preferences.inContent
2. To bypass the warning, press the big button labeled “I'll be careful, I promise!”.
3. In the search results, right-click “browser.preferences.inContent” and choose Reset.

Note that this will probably only have an effect until May 12 or so, when Firefox 38 will most likely feature Options in a tab.

> Now for the joy to re-build my entire FF profile... :(

Unless you're experiencing other issues, that seems unnecessary.

> Why can't these remain separated like they were before?

I don't know what you mean. Firefox Developer Edition (formerly Aurora) is the only version that sets up a separate profile automatically. For every other version, you need to do this manually [1], using the profile manager, then creating shortcuts with the -p ProfileName -no-remote command line parameters. At some point in the future, this situation may change [2].

―――――――
[1]
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
https://developer.mozilla.org/docs/Mozilla/Command_Line_Options

[2]
Bug 895030
https://wiki.mozilla.org/Features/Desktop/Ability_to_run_concurrent_channels
> I don't know what you mean

Well, Nightly/Aurora always (I don't know when this changed) used their own profile, and only beta would share with release. I think part of my profile issues causing this particular bug to appear would be the result of running release and nightly alternatingly on one and the same profile - some nightly build introducing a bug and having it confuse release, resulting in profile corruption.

Rebuilding my profile seems the wise thing to do in that case, since I don't know what all else has been screwed up in the meantime. I'll use the profile manager to separate them out from now on, and chalk this bug up to profile corruption. I'll WFM it.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
This is probably bug 1160076, which is now fixed.

(In reply to Mark Straver from comment #4)
> Well, Nightly/Aurora always (I don't know when this changed) used their own
> profile, and only beta would share with release.

Once again, Nightly never had automatic profile separation. That's specific to Firefox Developer Edition.
I seem to recall that Nightly and Aurora were separate from beta and Release, but maybe I remember wrong. In any case it's off-topic for this bug.
You need to log in before you can comment on or make changes to this bug.