Closed Bug 1157190 Opened 5 years ago Closed 5 years ago

[System] User could receive cell broadcast notification even turn it off in settings

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

defect
Not set

Tracking

(blocking-b2g:2.2+)

RESOLVED WONTFIX
blocking-b2g 2.2+

People

(Reporter: steveck, Assigned: steveck)

Details

Attachments

(1 file)

In bug 1113466 comment 14 we found an issue that we seems forget to check the CB disabled option in settings before showing notification. That cause the the CB notification popped even the user disabled the CB message notification in settings.
Comment on attachment 8595912 [details] [review]
[gaia] steveck-chung:system-cb-disabling > mozilla-b2g:master

Hi Kevin, I think the root cause is quite clear that we didn't check the settings. Maybe we assume the message won't be fired when settings is off, but the fact is we could still receive the event after turn off.

Hi Bevis, not sure if it's more reasonable to stop firing the event from gecko, maybe you can give some comments about this?
Flags: needinfo?(btseng)
Attachment #8595912 - Flags: review?(kgrandon)
(In reply to Steve Chung [:steveck] from comment #2)
> Comment on attachment 8595912 [details] [review]
> [gaia] steveck-chung:system-cb-disabling > mozilla-b2g:master
> 
> Hi Kevin, I think the root cause is quite clear that we didn't check the
> settings. Maybe we assume the message won't be fired when settings is off,
> but the fact is we could still receive the event after turn off.
> 
> Hi Bevis, not sure if it's more reasonable to stop firing the event from
> gecko, maybe you can give some comments about this?

Hi Carol,

As I know, when the setting of CB "ril.cellbroadcast.disabled" is set to true, we expect to request the deactivation of CB service to the modem. [1][2]

Is there any difference in your implementation compared to MOZ-RIL?

[1] https://dxr.mozilla.org/mozilla-central/source/dom/cellbroadcast/gonk/CellBroadcastService.js#119-135,274-280
[2] https://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_worker.js#1557-1568,1601-1611
Flags: needinfo?(btseng) → needinfo?(cyang)
Comment on attachment 8595912 [details] [review]
[gaia] steveck-chung:system-cb-disabling > mozilla-b2g:master

Not sure if I am the best reviewer, but lgtm!
Attachment #8595912 - Flags: review?(kgrandon) → review+
(In reply to Bevis Tseng[:bevistseng][:btseng] from comment #3)
> (In reply to Steve Chung [:steveck] from comment #2)
> > Comment on attachment 8595912 [details] [review]
> > [gaia] steveck-chung:system-cb-disabling > mozilla-b2g:master
> > 
> > Hi Kevin, I think the root cause is quite clear that we didn't check the
> > settings. Maybe we assume the message won't be fired when settings is off,
> > but the fact is we could still receive the event after turn off.
> > 
> > Hi Bevis, not sure if it's more reasonable to stop firing the event from
> > gecko, maybe you can give some comments about this?
> 
> Hi Carol,
> 
> As I know, when the setting of CB "ril.cellbroadcast.disabled" is set to
> true, we expect to request the deactivation of CB service to the modem.
> [1][2]
> 
> Is there any difference in your implementation compared to MOZ-RIL?
> 
> [1]
> https://dxr.mozilla.org/mozilla-central/source/dom/cellbroadcast/gonk/
> CellBroadcastService.js#119-135,274-280
> [2]
> https://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_worker.
> js#1557-1568,1601-1611

Hmm, true, I was testing this in a simulated environment. Perhaps this is not needed up at Gaia level.
Flags: needinfo?(cyang)
Hi Carol, seems like you also agree that RIL should check this. Will you fix this right in QC RIL or you think it's safer to double-check in gaia?
Flags: needinfo?(cyang)
(In reply to Steve Chung [:steveck] from comment #6)
> Hi Carol, seems like you also agree that RIL should check this. Will you fix
> this right in QC RIL or you think it's safer to double-check in gaia?

Yeah, I think RIL should take care of this. I guess we can close this bug then. Thanks!
Flags: needinfo?(cyang)
blocking-b2g: 2.2? → 2.2+
Not sure if Moz RIL need to have a bug for tracking. Hi Bevis, you can rename this bug if you want to track this issue in our RIL, otherwise you can just close it if not necessary, thanks!
Flags: needinfo?(btseng)
This depends on whether vendor follow the same rule to deactivate the CB service if CB settings is turned off.
There is nothing can do in Mozilla side.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(btseng)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.