Clear Private Data - SQL error or missing database no such table: logins

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: st3fan)

Tracking

unspecified
ARM
iOS 8
Dependency tree / graph

Firefox Tracking Flags

(fxios+)

Details

(Reporter)

Description

4 years ago
Saw this dumped on a new profile and just opened a few tabs and did a clear

Error Domain=org.mozilla Code=1 "SQL error or missing database no such table: logins" UserInfo=0x7fddc4bc3500 {NSLocalizedDescription=SQL error or missing database no such table: logins}
I've also seen this when Sync does a pre-emptive wipe of the clients table. It looks like maybe our DB access is lazy, so we don't necessarily create the tables by the time we come to wipe them?
Flags: needinfo?(wjohnston)
Component: General → Data Storage
Assignee: nobody → wjohnston
tracking-fennec: ? → +
Flags: needinfo?(wjohnston)
Status: NEW → ASSIGNED
Depends on: 1147071

Updated

3 years ago
tracking-fxios: --- → +
Assignee: wjohnston → rnewman

Updated

3 years ago
Assignee: rnewman → administration
Status: ASSIGNED → NEW
tracking-fennec: + → ---
(Assignee)

Updated

3 years ago
Assignee: administration → sarentz
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
I cant reproduce this error. Since logins code has gone through a bunch of iterations since this bug was filed, I am going to close this.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Blocks: 1224756
You need to log in before you can comment on or make changes to this bug.