Closed Bug 1157399 Opened 6 years ago Closed 6 years ago

Clone failed with a traceback in reviewboard extension

Categories

(Developer Services :: Mercurial: hg.mozilla.org, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1085066

People

(Reporter: dcamp, Unassigned)

Details

Waited a long time to clone fx-team, and right at the end it tracebacked in some extension that I think was auto-added to my .hgrc at some point?

To be fair, it's been a depressing amount of time since the last time I cloned.

Unfortunately I ran emacs in the terminal and it cleared out the backtrace except for:

 File "/Library/Python/2.7/site-packages/mercurial/commands.py", line 1371, in clone
    branch=opts.get('branch'))
  File "/Library/Python/2.7/site-packages/mercurial/hg.py", line 423, in clone
    destpeer.local().clone(srcpeer, heads=revs, stream=stream)
  File "/Library/Python/2.7/site-packages/mercurial/localrepo.py", line 1751, in clone
    ret = exchange.pull(self, remote, heads).cgresult
  File "/Library/Python/2.7/site-packages/mercurial/extensions.py", line 196, in wrap
    return wrapper(origfn, *args, **kwargs)
  File "/Users/dcamp/.mozbuild/version-control-tools/hgext/firefoxtree/__init__.py", line 239, in pull
    repo._updateremoterefs(remote, tree)
  File "/Library/Python/2.7/site-packages/mercurial/repoview.py", line 307, in __getattr__
    return getattr(self._unfilteredrepo, attr)
AttributeError: 'reviewboardrepo' object has no attribute '_updateremoterefs'
Manually clearing .mozbuild extensions out of my .hgrc let me clone.
This was fixed ~6 months ago. Pull down the latest version-control-tools repo and this should go away.

We really need a better mechanism to do periodic updating of tools...
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1085066
You need to log in before you can comment on or make changes to this bug.