Problem of display between Firefox and chrome, element with float and next element with positin relative

RESOLVED DUPLICATE of bug 738926

Status

()

Core
Layout: Floats
RESOLVED DUPLICATE of bug 738926
3 years ago
3 years ago

People

(Reporter: Esteban, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36

Steps to reproduce:

Create two elements, first with float and second with position relative.
http://jsfiddle.net/qrqrcz19/10/ 


Actual results:

The second does not take into account the height of the first one and they takes place at the same level as the first one in FF  but in chrome it's work

to look in chrome and firefox : http://jsfiddle.net/qrqrcz19/10/ 


Expected results:

I would want to know which one is the good behavior and if you have way to correct it

Updated

3 years ago
Component: Untriaged → Layout: Floats
Product: Firefox → Core
Version: 37 Branch → Trunk
The problem is not the position:relative but the overflow:hidden.  And Chrome's behavior is correct.

> and if you have way to correct it

A workaround would be to style the overflow:hidden thing with "clear: left" or "clear: both"...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738926
You need to log in before you can comment on or make changes to this bug.