[Contacts]If user taps "enter" key in add contact page, device will add phone field automatically.

RESOLVED FIXED

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Verson Xiong (Leave from Mozilla), Assigned: sousmangoosta, Mentored)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l] [good-first-bug])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8596458 [details]
video_2300.mp4

[1.Description]:
[Nexus5 2.2&3.0][Flame 2.2&3.0]Add or edit a contact without entering things in Phone field, and delete the Phone field. When user taps "enter" key on keyboard, the Phone field will appear automatically.
Found time:23:00
See attachment:logcat_2300.txt & video_2300.mp4

[2.Testing Steps]: 
Prerequisite:Don't set a contact picture.
1.Open contacts app.
2.Tap "+" icon(Don't set the contact picture.).
3.Tap "X" iocn of Phone field.
4.Tap any input box and input any words.
5.Tap enter key on keyboard.

[3.Expected Result]: 
5.Nothing abnormal will happen.

[4.Actual Result]: 
5.Device will add Phone field automatically.

[5.Reproduction build]: 
Flame 2.2(affected):
Build ID               20150422002505
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a87a05e7d0ef
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.040348
Firmware Date          Wed Apr 22 04:03:59 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(affected):
Build ID               20150422160203
Gaia Revision          9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gaia Date              2015-04-22 17:32:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a9311ec2dd39
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.193515
Firmware Date          Wed Apr 22 19:35:27 EDT 2015
Bootloader             L1TC000118D0

Nexus5 2.2(affected):
Build ID               20150422162503
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/367b3e608cd8
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150422.195718
Firmware Date          Wed Apr 22 19:57:35 EDT 2015
Bootloader             HHZ12f

Nexus5 3.0(affected):
Build ID               20150422010202
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/946ac85af8f4
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150422.044004
Firmware Date          Wed Apr 22 04:40:22 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8596459 [details]
logcat_2300.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Interesting edge case. It's also in 2.1[1]. Francisco, does this look like a good first bug to you?

[1] Build ID               20150421001205
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20141120.194707
Firmware Date          Thu Nov 20 19:47:17 EST 2014
Bootloader             L1TC00011880
status-b2g-v2.1: --- → affected
Flags: needinfo?(francisco)
tracking-b2g: --- → backlog
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #2)
> Interesting edge case. It's also in 2.1[1]. Francisco, does this look like a
> good first bug to you?

Definitely :)
Mentor: francisco@jordano.es
Flags: needinfo?(francisco)
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l] [good-first-bug]

Comment 4

3 years ago
Hi, 

I'd like to work on this. 
give me heads up on how to do it, please? 


Thanks.
Hi,

I would suggest first to try to reproduce to get familiar with the behavior that we want to solve.

Then go to the following file:

https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/contacts/js/views/form.js

That's the javascript that controls the contact details form. Also you could check if:
https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/contacts/js/views/form.js#L437

Is being triggered.
Flags: needinfo?(akshaytiwari.003)

Updated

3 years ago
Flags: needinfo?(akshaytiwari.003)
Created attachment 8610845 [details] [review]
[gaia] sousmangoosta:v3.0 > mozilla-b2g:master
(Assignee)

Comment 7

3 years ago
Hey Francisco,

You can assign it to me.

Thank you.
Flags: needinfo?(francisco)
Thanks Ronald, once patch is ready you can ask for review to :ferjm or myself.
Assignee: nobody → sousmangoosta
Flags: needinfo?(francisco)
(Assignee)

Comment 9

3 years ago
Comment on attachment 8610845 [details] [review]
[gaia] sousmangoosta:v3.0 > mozilla-b2g:master

Francisco,

I used same workaround as delButton.

Thank you
Attachment #8610845 - Flags: review?(francisco)
Comment on attachment 8610845 [details] [review]
[gaia] sousmangoosta:v3.0 > mozilla-b2g:master

lgtm,

Thanks!
Attachment #8610845 - Flags: review?(francisco) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/30247

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
(Assignee)

Comment 12

3 years ago
Francisco,

I think R=you missing on the commit description, do I have to commit again ?
Flags: needinfo?(francisco)
Ronald,

You can do a commit --amend and modify the commit description, it will later need a force to update as it will be a new commit id.
Flags: needinfo?(francisco) → needinfo?(sousmangoosta)
(Assignee)

Comment 14

3 years ago
Francisco,

Done, but new test is running, is this correct ?
Flags: needinfo?(sousmangoosta) → needinfo?(francisco)
Sure, no problem :)
Flags: needinfo?(francisco)
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Reverting for causing gaia unit test failures.

Example of failures: https://treeherder.mozilla.org/logviewer.html#?job_id=249020&repo=gaia-master

Backout: https://github.com/mozilla-b2g/gaia/commit/8e6a357587086815590f7b1a24563d141a25dc71

Please address the failures and request a new review. Thanks!
Status: RESOLVED → REOPENED
Flags: needinfo?(sousmangoosta)
Resolution: FIXED → ---
Note that they were present in the Gaia Try run for the pull request as well. Please check your results carefully before setting checkin-needed in the future.
(Assignee)

Comment 19

3 years ago
The test need to be modified, because it generate click without coordinates.
Flags: needinfo?(sousmangoosta) → needinfo?(francisco)
Hi Ronald,

please go ahead, modify the PR with the test working ok.

Do you need any help on how to work with our test suite?
Flags: needinfo?(francisco) → needinfo?(sousmangoosta)
(Assignee)

Comment 21

3 years ago
Hey Francisco,

Does the test can be in the same commit or does it need an other bug ?

I'm following this guide to try the tests locally : https://developer.mozilla.org/en-US/Firefox_OS/Automated_testing/gaia-ui-tests/Gaia_UI_Tests_Run_Tests is this correct ?

Thx you
Flags: needinfo?(sousmangoosta) → needinfo?(francisco)
Those guides are perfect.

The fix can be in the same PR, ideally you should squash the commits into a single one, once everything is ready.
Flags: needinfo?(francisco)
Created attachment 8612886 [details] [review]
[gaia] sousmangoosta:v3.0 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8610845 - Attachment is obsolete: true
(Assignee)

Comment 25

3 years ago
Comment on attachment 8612886 [details] [review]
[gaia] sousmangoosta:v3.0 > mozilla-b2g:master

Hey Francisco,

I changed the workaround, not the test, and this one pass, could you please check ?

Thanks
Flags: needinfo?(francisco)
Attachment #8612886 - Flags: review?(francisco)
Comment on attachment 8612886 [details] [review]
[gaia] sousmangoosta:v3.0 > mozilla-b2g:master

Great, tested on the phone and working for me.

Excellent job!
Flags: needinfo?(francisco)
Attachment #8612886 - Flags: review?(francisco) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#tmy63L7GRai8BEDvExS_5Q

The pull request failed to pass integration tests. It could not be landed, please try again.
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#ky27oWNKQQKQABQxRUwNZA

The pull request failed to pass integration tests. It could not be landed, please try again.
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/30314

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#EJ5nEx2zSTKOS9oAXWrHog

The pull request failed to pass integration tests. It could not be landed, please try again.
Sorry, seems Autolander has been having a lot of issues lately. Because of that I'm going to land manually for now.

https://github.com/mozilla-b2g/gaia/commit/6d657b4292dae9ef995e73f011e2d1f5e812f6f9
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
This bug has been verified as pass on latest Nightly build of Flame v3.0 and Nexus 5 v3.0 by the STR in Comment 0.

Actual results: After tapping "enter" key, device does not add "Phone" field automatically.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/10


Device: Flame v3.0 build(Pass)
Build ID               20150603160203
Gaia Revision          45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Gaia Date              2015-06-03 17:32:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0920f2325a6d
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150603.192042
Firmware Date          Wed Jun  3 19:20:53 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v3.0 build(Pass)
Build ID               20150603160203
Gaia Revision          45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Gaia Date              2015-06-03 17:32:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0920f2325a6d
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150603.193140
Firmware Date          Wed Jun  3 19:31:59 EDT 2015
Bootloader             HHZ12f
status-b2g-master: fixed → verified
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.