[Window Management]Device will switch to another app which you've launched before when you tap the left and right edge at the same time.

VERIFIED FIXED in 2.2 S12 (15may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: liuke, Assigned: etienne)

Tracking

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [v2.2-nexus-5-l] [systemsfe])

Attachments

(4 attachments)

Posted file logcat_220.txt
[1.Description]:
[Nexus 5 v2.2 & v3.0][Flame v2.2 & v3.0][Window Management]When you use two fingers to tap the left and right edge at the same time, device will switch to another app which you've launched before.
Found time:2:20
See attachment:220.mp4 and logcat_220.txt

[2.Testing Steps]: 
1.Launch some apps.
2.Back to home, launch any app.
3.Use two fingers to tap left and right edge at the same time.
4.Lock screen, then wake up screen, drag the icon to unlock.

[3.Expected Result]: 
3.Device will have no response and still stay in current view.
4.User can unlock screen successfully.

[4.Actual Result]: 
3.Device will switch to another app which you've launched before.
4.Sometimes, device has no response when you slide the icon to unlock.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150422002505
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a87a05e7d0ef
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.040348
Firmware Date          Wed Apr 22 04:03:59 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 version(Affected):
Build ID               20150422160203
Gaia Revision          9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gaia Date              2015-04-22 17:32:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a9311ec2dd39
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.193515
Firmware Date          Wed Apr 22 19:35:27 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 version(Affected):
Build ID               20150422162503
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/367b3e608cd8
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150422.195718
Firmware Date          Wed Apr 22 19:57:35 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5_3.0 version(Affected):
Build ID               20150422010202
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/946ac85af8f4
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150422.044004
Firmware Date          Wed Apr 22 04:40:22 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,2/5

[7.TCID]: 
Free Test
Reporter

Comment 1

4 years ago
Posted video 220.MP4
Etienne, is this edge gesture code?
Flags: needinfo?(etienne)
Assignee

Comment 3

4 years ago
(In reply to Gregor Wagner [:gwagner] from comment #2)
> Etienne, is this edge gesture code?

Ha! Nice!
Don't see any OOM kill in the logcat (which is really helpful since it has the system trace).

So there's a good chance for this to be an edge gesture bug.
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Assignee

Comment 5

4 years ago
Comment on attachment 8598658 [details] [review]
[gaia] etiennesegonzac:bug-1157615 > mozilla-b2g:master

quick one :)
Attachment #8598658 - Flags: review?(alive)
Comment on attachment 8598658 [details] [review]
[gaia] etiennesegonzac:bug-1157615 > mozilla-b2g:master

Huh, interesting bug.
Attachment #8598658 - Flags: review?(alive) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29771

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Assignee

Updated

4 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#CsaBdfNyRAufULYJr7z9Bg

The pull request failed to pass integration tests. It could not be landed, please try again.
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Per Comment 9,this bug has been landed and fixed on master.


This bug has been verified as pass on latest Nightly build of Flame v3.0 and Nexus 5 v3.0 by the STR in Comment 0.

Actual results: Device will still stay in current app view,and user can unlock screen successfully.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/5

-----------------------------------------------------------------------------
Device: Flame 3.0 build(Pass)
Build ID               20150505010204
Gaia Revision          70077825aab2c7a79611befb40a5fe7e610d5443
Gaia Date              2015-05-04 18:09:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/102d0e9aa9e1
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150505.043622
Firmware Date          Tue May  5 04:36:34 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v3.0 build (Pass)
Build ID               20150505160203
Gaia Revision          42dc5f02a9df006b129824cd9bffa93cab937ab2
Gaia Date              2015-05-05 11:06:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5907a8eca521
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150505.192812
Firmware Date          Tue May  5 19:28:29 EDT 2015
Bootloader             HHZ12f

-------------------------------------------------------------
Add "verifyme" for v2.2 uplift & verification.
QA Whiteboard: [MGSEI-Triage+]
Hi Etienne,

Could you confirm whether the patch will land on v2.2 or not? thanks :)
Flags: needinfo?(etienne)
Assignee

Comment 13

4 years ago
(In reply to Norry.L.F from comment #12)
> Hi Etienne,
> 
> Could you confirm whether the patch will land on v2.2 or not? thanks :)

Lets see, if it is 2.2+ I'll work on the approval.
blocking-b2g: --- → 2.2?
Flags: needinfo?(etienne)

Comment 14

4 years ago
Hi Gregor, can you help to triage this one? thanks.
Flags: needinfo?(anygregor)
Whiteboard: [v2.2-nexus-5-l] → [v2.2-nexus-5-l] [systemsfe]
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(anygregor)

Comment 15

4 years ago
Hi Etienne, 

Could you please uplift this patch to v2.2? Thanks.
Flags: needinfo?(etienne)
Assignee

Comment 16

4 years ago
Comment on attachment 8598658 [details] [review]
[gaia] etiennesegonzac:bug-1157615 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):the original edge gesture feature back in 2.0
[User impact] if declined: See Description of the bug
[Testing completed]: edge gesture and touch forwarding scenarios + unit tests for the STR
[Risk to taking this patch] (and alternatives if risky): low, and it has been on master for a while
[String changes made]: none
Flags: needinfo?(etienne)
Attachment #8598658 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8598658 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been verified as pass on latest Nightly build of Flame v2.2 and Nexus 5 v2.2 by the STR in Comment 0.

Actual results: Device will still stay in current app view,and user can unlock screen successfully.
See above attachment: verified_v3.0.mp4
Reproduce rate: 0/8


Device: Flame v2.2 build(Pass)
Build ID               20150531162502
Gaia Revision          b4582cc394e0919623263997c0cdb0b4751a1403
Gaia Date              2015-05-31 11:06:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/78d8b0a4303d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150531.195816
Firmware Date          Sun May 31 19:58:28 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v2.2 build(Pass)
Build ID               20150531002502
Gaia Revision          0a46394dbee0ed2eb71a136cee38ddd8549dd597
Gaia Date              2015-05-30 14:50:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ed2f6aeb1d81
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150531.043812
Firmware Date          Sun May 31 04:38:27 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.