[e10s]Flickering while scrolling flash content (aka plugins lag while scrolling)

RESOLVED WORKSFORME

Status

()

Core
Panning and Zooming
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: VarCat, Unassigned)

Tracking

40 Branch
Unspecified
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s-, firefox40 affected)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Environment:

FF 40
Build Id: 20150422030206 
OS: Win 7 x64, WIn 8.1 x64
Graphics: AMD Radeon HD 5450

STR:

1. Go to a page with heavy flash content eg http://www.twitch.tv/
2. Scroll the page.

Issue:
The flash content is flickering while scrolling.
(Reporter)

Comment 1

3 years ago
This bug is reproducible only with e10s enabled.
Summary: Flickering while scrolling flash content → [e10s]Flickering while scrolling flash content
I saw this with with APZ enabled (and told kats on irc). NI'ing him and -'ing for e10s.
tracking-e10s: --- → -
Flags: needinfo?(bugmail.mozilla)
Blocks: 1157745
Flags: needinfo?(bugmail.mozilla)
OS: Unspecified → Windows

Updated

3 years ago
Whiteboard: [gfx-noted]
Blocks: 1143856
OS: Windows → All
I've been running into the same thing for a few days while running nightly. Using slightly different STR:

* Go to http://live.mlssoccer.com/mlsmdl/
* Open a random game to watch in a new window (either a live stream or a previously saved game)
* Once the game is being played, scroll up and down on any website in the other window and you'll notice the game will flicker when you scroll

The other thing that I noticed is that some websites that you scroll through won't produce the flickering but that's pretty rare.

Info:

Built from https://hg.mozilla.org/mozilla-central/rev/8aff0d2a7bc7
Win 8.1 x64
Adapter Description NVIDIA GeForce GTX 670
Adapter Description (GPU #2) Intel(R) HD Graphics 4000
Duplicate of this bug: 1105059
Created attachment 8609807 [details]
example.gif

Attached a quick example as a .gif. Had a website that scrolls through content every few seconds in the background. The main window with the flash video was constantly flickering. If you minimize the second window with the scrolling content, the flickering stops.
Hm, that's odd. Did the background window also have flash content by any chance?
Ya, the page behind the one with the video had flash content as well.
Blocks: 1178298
No longer blocks: 1143856, 1157745
Summary: [e10s]Flickering while scrolling flash content → [e10s]Flickering while scrolling flash content (aka plugins lag while scrolling)
Duplicate of this bug: 1186601

Comment 9

3 years ago
The flickering problem discussed here may have been bug 1152326.

Updated

3 years ago
Duplicate of this bug: 1187651

Updated

3 years ago
Depends on: 1137944
Duplicate of this bug: 1188602
Duplicate of this bug: 1192419

Updated

3 years ago
Duplicate of this bug: 1192638

Comment 14

3 years ago
For me it happens only when e10s is enabled. Maybe this is not an entirely e10s problem but it could help with narrowing the possible causes.

Comment 15

3 years ago
Another test case. Every video on the bbc seems to suffer from this pretty badly. Interestingly on latest nightly flash plugin has now started hanging when you try to change tab. 

eg http://www.bbc.co.uk/news/world-34049153

Comment 16

3 years ago
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #2)
> I saw this with with APZ enabled (and told kats on irc). NI'ing him and
> -'ing for e10s.

IMO removing tracking-e10s is wrong as with e10s enabled this behavior is permanent. For me this is a no-no for e10s and I will never enable it until this is really fixed.

Comment 17

3 years ago
(In reply to byornski from comment #15)
> Another test case. Every video on the bbc seems to suffer from this pretty
> badly. 

Does the plugin window flicker on and off or are you seeing positional lag when scrolling?

The "hang" you see is bug 1196539. It's an initial painting problem.

Comment 18

3 years ago
(In reply to Bartosz Piec from comment #16)
> (In reply to Brad Lassey [:blassey] (use needinfo?) from comment #2)
> > I saw this with with APZ enabled (and told kats on irc). NI'ing him and
> > -'ing for e10s.
> 
> IMO removing tracking-e10s is wrong as with e10s enabled this behavior is
> permanent. For me this is a no-no for e10s and I will never enable it until
> this is really fixed.

If you set 'layers.async-pan-zoom.enabled' to false, restart, and keep e10s enabled, do you still see the problem?

Comment 19

3 years ago
(In reply to Jim Mathies [:jimm] from comment #18)
> If you set 'layers.async-pan-zoom.enabled' to false, restart, and keep e10s
> enabled, do you still see the problem?

Yes, I do. But it behaves a bit better now.

Comment 20

3 years ago
I see pretty bad positional lag. It is not as bad when using the scroll bar rather than the mouse wheel but still noticeable. I did manage to even get it to glitch with a static frame of the video stuck outside of the flash window covering the top line of text. Unfortunately that is not reliably reproducible. 

Rather than hang, I should have said crash. It stops down the plugin container thread (and sometimes the entire nightly thread). "A process is causing Nightly to run slowly".

Updated

3 years ago
Blocks: 1193055
Duplicate of this bug: 1204821

Updated

3 years ago
See Also: → bug 1204835

Comment 22

3 years ago
fixed by bug 1137944.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
\o/

Thanks for your work on this, Jim!

Comment 24

3 years ago
Actually it is not really fixed… When I am trying to scroll the page using mouse wheel the video is turning all black when the scrolling starts and restores the playback when scrolling ends.

Comment 25

3 years ago
(In reply to Bartosz Piec from comment #24)
> Actually it is not really fixed… When I am trying to scroll the page using
> mouse wheel the video is turning all black when the scrolling starts and
> restores the playback when scrolling ends.
Yes, it's bug 1212813

Updated

3 years ago
No longer blocks: 1193055
You need to log in before you can comment on or make changes to this bug.