[Rocketbar] Minimized rocketbar doesn't open search directly

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: apastor, Assigned: kgrandon)

Tracking

({regression})

unspecified
2.2 S11 (1may)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

Reporter

Description

4 years ago
STR:

1.- Open the browser
2.- Scroll in order to minimize the rocketbar
3.- Click on the search input

Expected:

The search gets activated 

Actual:

The chrome expands, but the search screen is not shown
Reporter

Comment 1

4 years ago
It seems to have been caused by bug 1144777.

Brian, can you take a look?

Thanks!
Flags: needinfo?(bbirtles)
Reporter

Updated

4 years ago
Whiteboard: [systemsfe]
Assignee

Comment 2

4 years ago
Thanks for filing and finding the root cause. I have a pretty good idea of what's going on here so I will take a look.
Assignee: nobody → kgrandon
Blocks: 1144777
Status: NEW → ASSIGNED
Flags: needinfo?(bbirtles)
Assignee

Comment 3

4 years ago
I suppose we need to block since bug 1144777 was uplifted to 2.2.
blocking-b2g: --- → 2.2?
Assignee

Comment 4

4 years ago
I actually don't think this is related to bug 1144777 anymore. Likely some RTL work. Continuing to investigate.
No longer blocks: 1144777
Assignee

Comment 6

4 years ago
On second thought, let's start with branch checks here as we're not sure of the offending bug anymore.
blocking-b2g: 2.2? → ---
status-b2g-v2.1: --- → ?
status-b2g-v2.2: --- → ?
Keywords: qawanted
Assignee

Comment 7

4 years ago
Comment on attachment 8596702 [details] [review]
[gaia] KevinGrandon:bug_1157741_event_safety_scope > mozilla-b2g:master

Etienne or Alberto - could either of you review this? It seems this is a combination of a few patches breaking this, and insufficient infrastructure on desktop to test this (no APZ/scrollgrab).

The fix is to move a previously used check into the eventSafety function. It think this is acceptable because the main use-case of this library is transition events. Making this be opinionated to filter is a good thing IMO. Thanks!
Attachment #8596702 - Flags: review?(etienne)
Attachment #8596702 - Flags: review?(apastor)
QA Contact: ychung
This issue reproduces on Flame 2.2 and 3.0.

Result: The search overlay and keyboard do not appear when tapping the minimized search bar.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150423065001
Gaia: 4d87112bbf48cdd09c19e553cc9aebd2a2c4ddfd
Gecko: 10a237997b8d
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150423074202
Gaia: b838d0e7c163e66660dcb6e387d8339944a7a30e
Gecko: 5fe76b26e55f
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

======================================
This issue does NOT reproduce on Flame 2.1.

Result: The search overlay and keyboard appear properly when tapping the minimized search bar.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150422095813
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: 6a68a038146a
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawantedregression
blocking-b2g: --- → 2.2+
Flags: needinfo?(ktucker)
Comment on attachment 8596702 [details] [review]
[gaia] KevinGrandon:bug_1157741_event_safety_scope > mozilla-b2g:master

Yep it's pretty safe to think that this is the intended behavior.
Attachment #8596702 - Flags: review?(etienne)
Attachment #8596702 - Flags: review?(apastor)
Attachment #8596702 - Flags: review+
Assignee

Comment 10

4 years ago
Adding checkin-needed to get this landed. Not sure if we still need a regression window here.
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 12

4 years ago
Comment on attachment 8596702 [details] [review]
[gaia] KevinGrandon:bug_1157741_event_safety_scope > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 2.2 bug fixes I think?
[User impact] if declined: Poor UX when browsing the web, probably something we should be good at.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, smalllish patch.
[String changes made]: None.
Attachment #8596702 - Flags: approval-gaia-v2.2?(bbajaj)
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150324165816
Gaia: 9ba16c09fa6934b06f900bcc564e98fea803b1dc
Gecko: 75dd12a4039e
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150324181915
Gaia: 419b6873b4dc310e0099ba269dd5364985b76539
Gecko: f037e9c31eed
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 9ba16c09fa6934b06f900bcc564e98fea803b1dc
Gecko: f037e9c31eed

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 419b6873b4dc310e0099ba269dd5364985b76539
Gecko: 75dd12a4039e

https://github.com/mozilla-b2g/gaia/compare/9ba16c09fa6934b06f900bcc564e98fea803b1dc...419b6873b4dc310e0099ba269dd5364985b76539

Caused by bug 1144777
Flags: needinfo?(ktucker)
QA Contact: ychung
Keywords: verifyme
Attachment #8596702 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Brian, can you take a look at this please? This might have been caused by the work done for bug 1144777.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Depends on: 1144777
Flags: needinfo?(ktucker) → needinfo?(bbirtles)
Assignee

Comment 15

4 years ago
(In reply to KTucker [:KTucker] from comment #14)
> Brian, can you take a look at this please? This might have been caused by
> the work done for bug 1144777.

This is already fixed.
Flags: needinfo?(bbirtles)
Issue verified fixed on Flame 3.0 

When user taps minimized rocketbar from browser, chrome expands, current url is displayed and highlighted, and keyboard opens. Search does not close without user input.

Leaving verifyme keyword until fix lands on nightly 2.2 tomorrow

Device: Flame 3.0
Build ID: 20150427010202
Gaia: b4c949cdc780893897c9b45c1adea46e2eb694ff
Gecko: 37d60e3b8be6
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Verified with STR at comment 0 and below test env.

*test env
Build ID               20150428002500
Gaia Revision          9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gaia Date              2015-04-27 20:41:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e79c19bf19bf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150428.042318
Firmware Date          Tue Apr 28 04:23:30 EDT 2015
Bootloader             L1TC000118D0
Duplicate of this bug: 1157617
You need to log in before you can comment on or make changes to this bug.