Closed Bug 1157816 Opened 6 years ago Closed 1 month ago

[e10s] in ilooping content script, unable to stop execution after continue

Categories

(DevTools :: Debugger, defect)

defect
Not set
normal

Tracking

(firefox40 affected)

RESOLVED DUPLICATE of bug 1157820
Tracking Status
firefox40 --- affected

People

(Reporter: luke, Unassigned)

References

(Blocks 1 open bug)

Details

STR:
 - start ilooping content script
 - the slow-script bar comes up, click 'Debug Script'
 - click 'Continue' in debugger
After this, neither clicking the 'Pause' button nor 'Debug Script' in future slow-script dialogs stops the script in the debugger.  The latter works in non-e10s FF (it's impossible to click the pause button in non-e10s FF, though, b/c the UI is hung).
tracking-e10s: --- → ?
Luke, do you have a reduced test case of an ilooping content script?
Flags: needinfo?(luke)
Blocks: dte10s
Just <script>while(1) {}</script> will do.
Flags: needinfo?(luke)
Product: Firefox → DevTools

Luke, is this still relevant?

tracking-e10s: - → ---
Flags: needinfo?(luke)

I don't actually see the 'Debug Script' button anymore (Just 'Wait' and 'Stop It'), so I can't tell. Is there a pref or config I should set to get a 'Debug Script' button?

Flags: needinfo?(luke)
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157820
You need to log in before you can comment on or make changes to this bug.