Closed Bug 1157895 Opened 7 years ago Closed 7 years ago

[Everything.me][Smart Collection] Smart collections that are scrollable, and have all rows full of apps will have an unessecary blank row at the bottom

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master verified)

RESOLVED FIXED
2.2 S11 (1may)
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected
b2g-master --- verified

People

(Reporter: dharris, Assigned: cwiiis)

References

()

Details

(Keywords: polish, regression, Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(3 files)

Description:
When the user is viewing a smart collection that has all of its rows full (4 across with no unfinished rows) then there will be an unessacry blank row at the bottom of the collection. This can be seen occuring in the Games and Sports collections.


Repro Steps:
1) Update a Flame to 20150423010203
2) Open Games Smart Collection
3) Scroll to the bottom


Actual:
A blank row is shown at the bottom of the app. There is not functional reason for this gap due to not being able to access a long press menu from inside the smart collection


Expected:
(Describe the behavior you expected to have observed)

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150423010203
Gaia: 9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gecko: 0b202671c9e2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 10/10
See attached: Logcat, Video - https://youtu.be/oDHcbGmbWIA
Expected Result for comment 0: There is not a blank row present at the bottom of the smart collection

==================================================================================================================

This issue DOES occur on Flame 2.2

A blank row is shown at the bottom of the app. There is not functional reason for this gap due to not being able to access a long press menu from inside the smart collection

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150421002501
Gaia: 828dd03a0e3b140d74b2e49355197df4d91d9227
Gecko: 36f72a3efb9b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

===================================================================================================================

This issue does NOT occur on Flame 2.1

There is not a blank row present at the bottom of the smart collection

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150423001201
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: 6a68a038146a
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: polish
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
This issue is caused by bug 1150464.

b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150411145338
Gaia: 9e8b2f2b54aada3858f1629f11c8276ff5c2adb1
Gecko: 4a85bded5122
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150410165338
Gaia: be1a3183dc6027eddf16256f46513314f291c2cf
Gecko: 6efab519326f
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 9e8b2f2b54aada3858f1629f11c8276ff5c2adb1
Gecko: 6efab519326f

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: be1a3183dc6027eddf16256f46513314f291c2cf
Gecko: 4a85bded5122

https://github.com/mozilla-b2g/gaia/compare/be1a3183dc6027eddf16256f46513314f291c2cf...9e8b2f2b54aada3858f1629f11c8276ff5c2adb1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Kevin, can you take a look at this please? This might have been caused by the work done for bug 1150464.
Blocks: 1150464
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(kgrandon)
I don't think this is a correct regression window - bug 1150464 fixed not being able to scroll *at all* - so whether the cause for this bug existed or not, you'd not be able to tell when that bug was exhibited.

I don't think this will be hard to fix, I'll take this and have a look on Monday.
Assignee: nobody → chrislord.net
No longer blocks: 1150464
Status: NEW → ASSIGNED
Flags: needinfo?(kgrandon)
Target Milestone: --- → 2.2 S11 (1may)
Attachment #8598144 - Flags: review?(kgrandon)
Comment on attachment 8598144 [details] [review]
[gaia] Cwiiis:bug1157895-fix-gaia-grid-height > mozilla-b2g:master

Nice, thank you!
Attachment #8598144 - Flags: review?(kgrandon) → review+
Blimey, that was quick!
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Please help to verify this bug.
Keywords: verifyme
Attached video verified_v3.0.mp4
Per Comment 8,this bug has been landed and fixed on master.


This bug has been verified as pass on latest Nightly build of Flame v3.0 and Nexus 5 v3.0 by the STR in Comment 0.

Actual results: There is no a blank row shown at the bottom of the smart collections.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/5

--------------------------------------------------------------
Device: Flame v3.0 build(Pass)
Build ID               20150525160205
Gaia Revision          5bcc08a732163087999251b523e3643db397412c
Gaia Date              2015-05-24 14:44:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b6623a27fa64
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150525.192755
Firmware Date          Mon May 25 19:28:07 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v3.0 build(Pass)
Build ID               20150525160205
Gaia Revision          5bcc08a732163087999251b523e3643db397412c
Gaia Date              2015-05-24 14:44:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b6623a27fa64
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150525.192207
Firmware Date          Mon May 25 19:22:24 EDT 2015
Bootloader             HHZ12f
Leaving "verifyme" for v2.2 uplift & verification
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.