Status

Webtools Graveyard
Bonsai
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: lonnen, Unassigned)

Tracking

(Blocks: 1 bug, {spring-cleaning})

Trunk
spring-cleaning
Dependency tree / graph

Details

(Whiteboard: [vm-delete:1])

(Reporter)

Description

3 years ago
CVS is read only. When it is turned off, we can decomm bonsai.
This was apparently done... and now we have no working web blame UI for CVS-era code anymore as far as I can tell.
:bz, it's highly doubtful the right people will see your comment. If this is a real problem for you, you should reach out via other mediums (new bug report against IT, mailing list thread, etc.).
I was explicitly told by the people who hardhatted bonsai to put discussion in this bug...
(In reply to Boris Zbarsky [:bz] from comment #3)
> I was explicitly told by the people who hardhatted bonsai to put discussion
> in this bug...

Well, I doubt anybody will see it, just saying (the right people aren't even CC'd). If you really care about it, I would escalate.
(Reporter)

Comment 5

3 years ago
Thanks Reed. This has been discussed in a few different places at this point. Boris -- I encourage you to work with GPS and dev services. At Whistler he offered to tackle the problem and had an HG based solution.
Update: bonsai is offline due to bug 620201
(In reply to Chris Lonnen :lonnen from comment #5)
> Boris -- I encourage you to work with GPS and dev services. At
> Whistler he offered to tackle the problem and had an HG based solution.

I disagree -- needs commitment to operations from higher up to get prioritized. Working the issue from the bottom has not produced a result in 5 years.
Duplicate of this bug: 1200249
(In reply to Boris Zbarsky [:bz] from comment #1)
> This was apparently done... and now we have no working web blame UI for
> CVS-era code anymore as far as I can tell.

The gecko-dev github repo works for this, though it is a little clunky, and can time out on things like nsGlobalWindow. But it is something. For instance:

https://github.com/mozilla/gecko-dev/blame/master/dom/base/Attr.cpp
We don't have mxr->git annotate links for CVS era code, as far as I know.
> and can time out on things like nsGlobalWindow. 

It actually times out on most of the files I care about, so it's pretty much totally useless for my purposes.  :(

Updated

3 years ago
Blocks: 1200362

Comment 12

3 years ago
Now that CVS is decom'ed, what's to do here?  Just pulling the bonsai webservice, or could all of webtools2.dmz.scl3 be decom'ed?
(Reporter)

Comment 13

3 years ago
I'm not sure if anything else is on that host, and don't have direct access to check. Is there any indication on inventory or otherwise that anything else runs on it?

Comment 14

3 years ago
gcox@webtools2.dmz.scl3:~$ sudo /usr/sbin/httpd -t -D DUMP_VHOSTS
[Thu Dec 03 18:39:39 2015] [warn] NameVirtualHost *:81 has no VirtualHosts
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:8000                 build-graphs.mozilla.org (/etc/httpd/conf/domains/build-graphs.conf:2)
*:80                   is a NameVirtualHost
         default server webtools.mozilla.org (/etc/httpd/conf/domains/a-default.conf:2)
         port 80 namevhost webtools.mozilla.org (/etc/httpd/conf/domains/a-default.conf:2)
                 alias wt.mozilla.org
                 alias dm-webtools01.mozilla.org
                 alias dm-webtools02.mozilla.org
                 alias dm-webtools03.mozilla.org
         port 80 namevhost bonsai.mozilla.org (/etc/httpd/conf/domains/bonsai.conf:2)
                 alias bonsai-stage.mozilla.org
         port 80 namevhost bonsai-l10n.mozilla.org (/etc/httpd/conf/domains/bonsai.conf:46)
                 alias bonsai-l10n-stage.mozilla.org
         port 80 namevhost bonsai-www.mozilla.org (/etc/httpd/conf/domains/bonsai.conf:88)
                 alias bonsai-www-stage.mozilla.org
(Reporter)

Comment 15

3 years ago
I can't resolve the non-bonsai hosts. It's probably safe to shut down.

Comment 16

3 years ago
Pulled from nagios in change 111109.
Halted zeus server, halted VM

10.22.74.142  = webtools2.dmz.scl3
63.245.215.55 = bonsai-zlb.vips.scl3

No netvault, no NFS.  Powered off.  Idling here to wait for fallout.
Keywords: spring-cleaning

Comment 17

2 years ago
Killed some extra external DNS:  bonsai-l10n.mozilla.org bonsai-www.mozilla.org bonsai.mozilla.org
Deleted DNS and inventory, rhn and puppetdashboard
Removed puppet manifest in change 112869.

Zeus:
VS:   bonsai.mozilla.org-http
TIG:  bonsai-zlb.vips.scl3.mozilla.com / 63.245.215.55
Pool: bonsai-http / webtools2.dmz.scl3.mozilla.com:80

VM deleted from disk and spreadsheets.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Whiteboard: [vm-delete:1]
(Assignee)

Updated

2 years ago
Product: Webtools → Webtools Graveyard

Updated

a year ago
status-firefox40: affected → ---
You need to log in before you can comment on or make changes to this bug.