Closed Bug 1157936 Opened 5 years ago Closed 5 years ago

[Scrolling][Scroll Bar]The scroll bar is choppy and jumpy when scrolling on any screen with a scroll bar

Categories

(Core :: Layout, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
blocking-b2g 2.5?
Tracking Status
firefox40 --- fixed
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: dharris, Assigned: mstange)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing][319MB-Flame-Support])

Attachments

(2 files)

Attached file Scrolling Logcat
Description:
If the user is on a screen where the scrollbar appears, the scrollbar will move jittery and jump across the screen. The scrolling animation is choppy and highly noticable


Repro Steps:
1) Update a Flame to 20150423010203
2) Scroll up and Down on the homescreen
3) Observe the scrollbar


Actual:
Scroll bar scrolling is choppy


Expected:
Scroll bar scrolls smoothly up and down

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150423010203
Gaia: 9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gecko: 0b202671c9e2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 10/10
See attached: Logcat, Video - https://youtu.be/69ZFdySKL8o
This issue does NOT occur on Flame 3.0 (512mb Memory), or Flame 2.2

Scroll bar scrolls smoothly up and down

Environmental Variables:
Device: Flame 3.0 (512mb)(Kitkat)(Full Flash)
Build ID: 20150423010203
Gaia: 9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gecko: 0b202671c9e2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150421002501
Gaia: 828dd03a0e3b140d74b2e49355197df4d91d9227
Gecko: 36f72a3efb9b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Blocks: 1148515
Component: Panning and Zooming → Layout
[Blocking Requested - why for this release]:
Performance regression.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][319MB-Flame-Support]
We're fairly confident that this was caused by bug 1148515.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
QA Contact: bzumwalt
Mozilla-Inbound Regression Window:

Markus' hypothesis in comment 4 appears to be correct

Last working Mozilla-Inbound build:
Device:  Flame 3.0
BuildID: 20150421142413
Gaia: 0645bbed4d6cbd8064652eebafe011edc3e417fd
Gecko: df384f61363a
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First broken Mozilla-Inbound build:
Device: Flame 3.0
Build ID: 20150421144810
Gaia: 0645bbed4d6cbd8064652eebafe011edc3e417fd
Gecko: 80518fa5c0d6
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Working Gaia with Broken Gecko issue DOES reproduce:
Gaia: 0645bbed4d6cbd8064652eebafe011edc3e417fd
Gecko: 80518fa5c0d6

Working Gecko with Broken Gaia issue does NOT reproduce:
Gaia: 0645bbed4d6cbd8064652eebafe011edc3e417fd
Gecko: df384f61363a


Mozilla-Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=df384f61363a&tochange=80518fa5c0d6


Issue appears to have been caused changes made in bug 1148515
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Markus, can you take a look at this please? The landing for bug 1148515 looks to be the cause here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(mstange)
Attached patch patchSplinter Review
Duh.
Flags: needinfo?(mstange)
Attachment #8598162 - Flags: review?(tnikkel)
Attachment #8598162 - Flags: review?(tnikkel) → review+
https://hg.mozilla.org/mozilla-central/rev/762d5d1fcc07
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.