Intermittent testTrackingProtection | GeckoEventExpecter - blockForEvent timeout: Robocop:JS

RESOLVED DUPLICATE of bug 1094649

Status

()

Firefox for Android
Testing
RESOLVED DUPLICATE of bug 1094649
3 years ago
3 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

({intermittent-failure})

Trunk
ARM
Android
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

(Reporter)

Description

3 years ago
16:27:08 INFO - java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(AbstractQueuedSynchronizer.java:2019)
16:27:08 INFO - java.util.concurrent.LinkedBlockingQueue.take(LinkedBlockingQueue.java:413)
16:27:08 INFO - java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:1013)
16:27:08 INFO - java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1073)
16:27:08 INFO - java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:573)
16:27:08 INFO - java.lang.Thread.run(Thread.java:841)
16:27:08 WARNING - TEST-UNEXPECTED-FAIL | testTrackingProtection | GeckoEventExpecter - blockForEvent timeout: Robocop:JS
16:27:08 INFO - EventExpecter: no longer listening for Robocop:JS
16:27:08 INFO - Unregistered listener for Robocop:JS
16:27:08 INFO - 0 ERROR Exception caught during test! - junit.framework.AssertionFailedError: TEST-UNEXPECTED-FAIL | testTrackingProtection | GeckoEventExpecter - blockForEvent timeout: Robocop:JS
16:27:08 INFO - at junit.framework.Assert.fail(Assert.java:50)
16:27:08 INFO - at org.mozilla.gecko.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:128)
16:27:08 INFO - at org.mozilla.gecko.FennecMochitestAssert.ok(FennecMochitestAssert.java:150)
16:27:08 INFO - at org.mozilla.gecko.FennecNativeActions$GeckoEventExpecter.blockForEvent(FennecNativeActions.java:96)
16:27:08 INFO - at org.mozilla.gecko.FennecNativeActions$GeckoEventExpecter.blockForEvent(FennecNativeActions.java:80)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1094649
You need to log in before you can comment on or make changes to this bug.