Closed Bug 1157990 Opened 7 years ago Closed 3 years ago

"Assertion failure: compositor->GetBackendType() == LayersBackend::LAYERS_OPENGL" with layers.acceleration.disabled

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox40 --- affected

People

(Reporter: jruderman, Assigned: lsalzman)

References

Details

(Keywords: assertion, regression, testcase, Whiteboard: [gfx-noted])

Attachments

(2 files, 2 obsolete files)

Attached file i.html
Assertion failure: compositor->GetBackendType() == LayersBackend::LAYERS_OPENGL, at gfx/layers/composite/TextureHost.cpp:908

This assertion is part of code added in https://hg.mozilla.org/mozilla-central/rev/a957533009df (one of the patches in bug 1066280)
Attached file stack
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(jdashg)
Whiteboard: [gfx-noted]
I don't see any reason we wouldn't create GLTextureShare SharedSurface with BasicLayers, so we need to handle this case.
Flags: needinfo?(matt.woodrow)
I don't have access to a Mac to test this on, but this seems like what would be necessary to fix it.

Jesse, would you be able to test this patch and see if it fixes it for you?
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Flags: needinfo?(jruderman)
Attachment #8617655 - Flags: review?(matt.woodrow)
Removed some accidental debugging code
Attachment #8617655 - Attachment is obsolete: true
Attachment #8617655 - Flags: review?(matt.woodrow)
Attachment #8617657 - Flags: review?(matt.woodrow)
This should no longer be necessary since bug 1144906 landed. Please double-check.
Comment on attachment 8617657 [details] [diff] [review]
handle conversion of SharedSurface_IOSurface to MacIOSurfaceTextureSourceBasic

This is apparently fixed as :jgilbert mentioned and the patch is not necessary.
Attachment #8617657 - Attachment is obsolete: true
Flags: needinfo?(jruderman)
Attachment #8617657 - Flags: review?(matt.woodrow)
Jesse, can you verify that this is fixed for you in nightly?
Flags: needinfo?(jruderman)
WFM with a build from yesterday.
Flags: needinfo?(jruderman)
(In reply to Jesse Ruderman from comment #8)
> WFM with a build from yesterday.

We cannot backport the fix from 41 to 40. Can you still reproduce the issue on Fx40?
Flags: needinfo?(jdashg) → needinfo?(jruderman)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(jruderman)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.