[Flame][Camera]Camera is awalys in loading status after user deletes a photo.

RESOLVED DUPLICATE of bug 1157163

Status

Firefox OS
Gaia::Camera
RESOLVED DUPLICATE of bug 1157163
3 years ago
3 years ago

People

(Reporter: Verson Xiong (Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8597146 [details]
video_0722.mp4

[1.Description]:
[Flame][v2.2 & v3.0][Camera]When user tries to delete a photo in preview page, but do not confirm, return homescreen, and relaunch camera to tap delete, camera will keep loading all the time.
Found time:07:22
See attachment:logcat_0722.txt & video_0722.mp4

[2.Testing Steps]: 
1.Open camera and take a photo.
2.Try to delete it from preview, but don't confirm.
3.Open homescreen then reopen camera.
4.Tap "delete".

[3.Expected Result]: 
5.Device back to viewfinder normally. 

[4.Actual Result]: 
5.Camera is awalys in loading status.

[5.Reproduction build]: 
Flame 2.2(affected):
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035703
Firmware Date          Thu Apr 23 03:57:16 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(affected):
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.193607
Firmware Date          Thu Apr 23 19:36:18 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 version(Unaffected):
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.035409
Firmware Date          Thu Apr 23 03:54:27 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5_3.0 version(Unaffected):
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.192918
Firmware Date          Thu Apr 23 19:29:36 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8597151 [details]
logcat_0722.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
status-b2g-v2.1: --- → affected
Edge case, but still worth fixing, ni RD for backlogging, thanks.
Flags: needinfo?(dflanagan)
Andrew and Justin: I think you two were talking about a bug that sounded similar to this. Is this another case where the camera never gets the ready event it is expecting because it is already ready?

Is there an easy fix we can try to squeeze into 2.2?
Flags: needinfo?(jdarcangelo)
Flags: needinfo?(dflanagan)
Flags: needinfo?(aosmond)
Same root cause as bug 1157163. Patches applied to that bug will fix this one too.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jdarcangelo)
Flags: needinfo?(aosmond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1157163
You need to log in before you can comment on or make changes to this bug.