bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Add support for temporarily disabling a JS event handler from being run when an event occurs.

RESOLVED DUPLICATE of bug 1226637

Status

DevTools
Inspector
P3
enhancement
RESOLVED DUPLICATE of bug 1226637
3 years ago
a month ago

People

(Reporter: Jukka Jylänki, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox40 affected)

Details

(Reporter)

Description

3 years ago
It would ease debugging if it was possible to disable specific JS event handlers from being run via the inspector for events (e.g. a temp toggle button in the UI to disconnect/reconnect registered event handlers to events). This would allow quickly testing if the page is behaving badly with respect to some event.

A good use case to attempt is to download https://dl.dropboxusercontent.com/u/40949268/emcc/bugs/moz_strategyGame_v2.zip

The page most likely has a bug related to the execution of the page "blur" and "focus" handlers, however, editing the .js file is tricky since it is minified, and need to find a good large file editor because the .js file is so large.
Inspector bug triage (filter on CLIMBING SHOES).
Priority: -- → P3
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226637

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.