[Contacts]Russian:The birthday field does not fit screen width.

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: arcturus)

Tracking

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: LocRun2.2, )

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Contacts][v2.2&2.1]Russian:Add a new number to an exist facebook contact, the birthday filed does not fit screen width.

Attachment:2015-04-23-22-20-30.png

[2.Testing Steps]: 
Precondition:Set system language to Russian.Sync some contacts from Facebook
1.Launch Phone
2.Input an new phone number
3.Tap + to invoke action menu
4.Tap "add to exist contact"
5.Select a facebook contact

[3.Expected Result]: 
5.The birthday field should fit screen width and is displayed properly.

[4.Actual Result]: 
5.The birthday box is displayed out of screen.

[5.Reproduction build]: 
Flame 2.2 user: Affected
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2

Flame 2.1 user: Affected
Build ID               20150423001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6a68a038146a
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Since Russian is a shipping locale, nominating to see if we can get a fix there. thanks
blocking-b2g: --- → 2.2?
Duplicate of this bug: 1158096
triage: this looks very ugly
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → francisco
Cannot repro in a 2.2 build, also in master is working fine for me.
Removed blocker and leaving nomination until qawanted passed.
blocking-b2g: 2.2+ → 2.2?
Keywords: qawanted
QA Contact: ychung
This issue still reproduces on Flame 2.2 and Master.

Result: When the device is in Russian and the user tries to add a number to a Facebook contact, the birthday dropdown menu does not fit on the screen.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150429064553
Gaia: 1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gecko: 265fa29ffe7e
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 3.0
BuildID: 20150429031314
Gaia: 6e35b0948c42a4398b8a5916015de167121683a1
Gecko: a0787486ecf5
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Restoring the blocker since is qa verified, and I verified my self
blocking-b2g: 2.2? → 2.2+
Posted file Pointer to PR 29804
Attachment #8599475 - Flags: review?(ferjmoreno)
Attachment #8599475 - Flags: review?(ferjmoreno) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/c46682b156a45a3734388f87e7674a5478273658
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8599475 [details] [review]
Pointer to PR 29804

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Bad user experience
[User impact] if declined:
[Testing completed]:
On master
[Risk to taking this patch] (and alternatives if risky):
Pretty low
[String changes made]:
None
Attachment #8599475 - Flags: approval-gaia-v2.2?
Attachment #8599475 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame 2.2 and 3.0. Following STR, birthday field now fits within screen. See attached screenshot for verified behavior.

Device: Flame 3.0
BuildID: 20150504010202
Gaia: e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gecko: dc5f85980a82
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150504002502
Gaia: 8d14361337e608c8cdf165ea5034db5eda23b618
Gecko: cb7cb6597c91
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Russian → LocRun2.2,
You need to log in before you can comment on or make changes to this bug.