[Browser]Device will open a small window after user signs in MDN.

RESOLVED WONTFIX

Status

Firefox OS
FxA
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Verson Xiong (Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 wontfix, b2g-master unaffected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8597185 [details]
video_0723.mp4

[1.Description]:
[Flame v2.2][Nexus 5 v2.2][Browser]If user open MDN page form settings,then try to sign in,device will open a small window, instead of a full-screen one, and task manager become not smooth.
Found time:07:23
See attachment:video_0723.mp4 & logcat_0723.txt

[2.Testing Steps]: 
1.Open Settings>Device Information>Legal Information>Obtaining Source Code.
2.Tap "Mozilla Developer Network" link open MDN page.
3.Tap "Sign in".
4.Tap "Persona".
5.Open task manager and do any operation.

[3.Expected Result]: 
4.Device will open sign in page via standard full-screen window.
5.Task manager works normally.

[4.Actual Result]: 
4.Device will open sign in page via a small window.
5.Task manager become not smoothly.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035703
Firmware Date          Thu Apr 23 03:57:16 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 version(Unaffected):
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.193607
Firmware Date          Thu Apr 23 19:36:18 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 version(Affected):
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.035409
Firmware Date          Thu Apr 23 03:54:27 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5_3.0 version(Unaffected):
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.192918
Firmware Date          Thu Apr 23 19:29:36 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8597187 [details]
logcat_0723.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → unaffected
blocking-b2g: --- → 2.2+
Component: Gaia::System::Window Mgmt → FxA

Comment 2

3 years ago
Chris, could you help on this? thanks.
Flags: needinfo?(ckarlof)

Comment 3

3 years ago
Hi Gregor,
Could you please help to find someone who can help checking this bug?
Thanks!
Flags: needinfo?(anygregor)

Updated

3 years ago
Flags: needinfo?(ckarlof)
Flags: needinfo?(anygregor)
Keywords: regressionwindow-wanted
QA Contact: bzumwalt
I am seeing the Persona login open in a small window at step 4 of STR without opening task manager on the latest, earliest, and build closest to the originally reported build in mozilla-b2g37_v2_2-flame-kk-eng from PVT server.

Unable to find a window. Are you able to reproduce this Verson?


Earliest available:
Device: Flame 2.2
Build ID: 20150112081448
Gaia: b0254d13e67b0bd4c74c2f2c9b9ea1251949d9fe
Gecko: cac64af410a1
Version: 37.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Closest to originally reported:
Device: Flame 2.2
Build ID: 20150423061402
Gaia: b838d0e7c163e66660dcb6e387d8339944a7a30e
Gecko: fa1fc6a9a4cb
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Latest available:
Device: Flame 2.2
Build ID: 20150516033044
Gaia: b388a235e89dab76c24323767cd87ebd7c4c8b17
Gecko: 54ae7c7182bc
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(xiongfuchao)

Comment 5

3 years ago
Triage 2.2+

Hi Ryan, are you in charge of Firefox Account engineering related? Please help to have a look, or lead this bug to right person. Thanks!
Flags: needinfo?(rfkelly)
It looks like this is Persona-related rather than Firefox Accounts, so I'm out of my depth here.  `hg blame` says that Sam Penrose has some familiarity with this code - Sam, can you suggest what to do or who to bug about this bug?
Flags: needinfo?(rfkelly) → needinfo?(spenrose)

Comment 7

3 years ago
That's called the "TrustedUI" -- it's a window that Gaia's System App opens to show the user that the login dialog can be trusted. Around FxOS 1.2, the Gaia team and the Persona team settled on it as the right way to handle Persona login. Unfortunately, Gaia soon migrated away from using the TrustedUI for any other purposes, and so it became a bit of an orphan. Because it interacts with the System App at a low level, you need a core Gaia developer to take a look.
Flags: needinfo?(spenrose)
(Reporter)

Comment 8

3 years ago
Hi Brogan,

I can reproduce this bug on earliest 2.2 build that I can find in b2g-inbound.
So I can't find the broken window.
BTW,It work normally on 3.0 build,so I guess we can find the build where this bug is fixed?

b2g-inbound
Flame 2.2(Affected)
Gaia-Rev        457e94636b74516e10abc1da026ce2b622713d95
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/7453c9e6a353
Build-ID        20141215020340
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150520.195701
FW-Date         Wed May 20 19:57:10 EDT 2015
Bootloader      L1TC000118D0
Flags: needinfo?(xiongfuchao)

Comment 9

3 years ago
[Blocking Requested - why for this release]:

Not a function broken blocker, polish issue.
nominate to 3.0?
blocking-b2g: 2.2+ → 3.0?
(In reply to Verson from comment #8)
> Hi Brogan,
> 
> I can reproduce this bug on earliest 2.2 build that I can find in
> b2g-inbound.
> So I can't find the broken window.
> BTW,It work normally on 3.0 build,so I guess we can find the build where
> this bug is fixed?

Yes, please find the patch that fixed this issue.
Reverse regression window (to find when 3.0 was fixed):


Last Broken B2G-Inbound build:
Device: Flame 3.0
Build ID: 20150114193435
Gaia: 48a42366a89bcda06ef22a9e53344176fef453cb
Gecko: e7146878be54
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Working B2G-Inbound build:
Device: Flame 3.0
Build ID: 20150114200734
Gaia: fa88d91984cf9813120dc7bb3e6a70f273457c84
Gecko: df624082f169
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Broken Gaia with Working Gecko issue DOES reproduce (broken build):
Gaia: 48a42366a89bcda06ef22a9e53344176fef453cb
Gecko: df624082f169

Broken Gecko with Working Gaia issue does NOT reproduce (working build):
Gaia: fa88d91984cf9813120dc7bb3e6a70f273457c84
Gecko: e7146878be54


B2G-Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/48a42366a89bcda06ef22a9e53344176fef453cb...fa88d91984cf9813120dc7bb3e6a70f273457c84


Issue appears to have been fixed on 3.0 by changes made in bug 911880
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
George, can you take a look at this please? This looks to have been fixed by the work done on bug 911880.

Can we get this uplifted to 2.2?

---------------------------

Josh, 3.0 is unaffected did you mean to nominate 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Depends on: 911880
Flags: needinfo?(ktucker)
Flags: needinfo?(jocheng)
Flags: needinfo?(gduan)

Comment 13

3 years ago
Hi Kevin,
Thanks for the reminder.
Mark to 2.2? and see whether bug 911880 can fix this issue.
blocking-b2g: 3.0? → 2.2?
Flags: needinfo?(jocheng)

Comment 14

3 years ago
(In reply to Verson from comment #0)
> Created attachment 8597185 [details]
> video_0723.mp4
> 
> [1.Description]:
> [Flame v2.2][Nexus 5 v2.2][Browser]If user open MDN page form settings,then
> try to sign in,device will open a small window, instead of a full-screen
> one, and task manager become not smooth.
> Found time:07:23
> See attachment:video_0723.mp4 & logcat_0723.txt
> 
> [2.Testing Steps]: 
> 1.Open Settings>Device Information>Legal Information>Obtaining Source Code.
> 2.Tap "Mozilla Developer Network" link open MDN page.
> 3.Tap "Sign in".
> 4.Tap "Persona".
> 5.Open task manager and do any operation.
> 
> [3.Expected Result]: 
> 4.Device will open sign in page via standard full-screen window.
> 5.Task manager works normally.
> 
> [4.Actual Result]: 
> 4.Device will open sign in page via a small window.
> 5.Task manager become not smoothly.
> 
> [5.Reproduction build]: 
> Flame 2.2 version(Affected):
> Build ID               20150423002502
> Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
> Gaia Date              2015-04-23 02:32:46
> Gecko Revision        
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
> Gecko Version          37.0
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150423.035703
> Firmware Date          Thu Apr 23 03:57:16 EDT 2015
> Bootloader             L1TC000118D0
> 
> Device: Flame 3.0 version(Unaffected):
> Build ID               20150423160207
> Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
> Gaia Date              2015-04-23 16:10:10
> Gecko Revision        
> https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
> Gecko Version          40.0a1
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150423.193607
> Firmware Date          Thu Apr 23 19:36:18 EDT 2015
> Bootloader             L1TC000118D0
> 
> Device: Nexus 5_2.2 version(Affected):
> Build ID               20150423002502
> Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
> Gaia Date              2015-04-23 02:32:46
> Gecko Revision        
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
> Gecko Version          37.0
> Device Name            hammerhead
> Firmware(Release)      5.1
> Firmware(Incremental)  eng.cltbld.20150423.035409
> Firmware Date          Thu Apr 23 03:54:27 EDT 2015
> Bootloader             HHZ12f
> 
> Device: Nexus 5_3.0 version(Unaffected):
> Build ID               20150423160207
> Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
> Gaia Date              2015-04-23 16:10:10
> Gecko Revision        
> https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
> Gecko Version          40.0a1
> Device Name            hammerhead
> Firmware(Release)      5.1
> Firmware(Incremental)  eng.cltbld.20150423.192918
> Firmware Date          Thu Apr 23 19:29:36 EDT 2015
> Bootloader             HHZ12f
> 
> [6.Reproduction Frequency]: 
> Always Recurrence,5/5
> 
> [7.TCID]: 
> Free Test

I don't get that, but I cannot even get passed the signin process (when I try to sign into MDN using Firefox OS Flame phone, I get an error message stating "Error Please close this Window and try again." Then option to see more information.

Comment 15

3 years ago
(In reply to Verson from comment #0)
> Created attachment 8597185 [details]
> video_0723.mp4
> 
> [1.Description]:
> [Flame v2.2][Nexus 5 v2.2][Browser]If user open MDN page form settings,then
> try to sign in,device will open a small window, instead of a full-screen
> one, and task manager become not smooth.
> Found time:07:23
> See attachment:video_0723.mp4 & logcat_0723.txt
> 
> [2.Testing Steps]: 
> 1.Open Settings>Device Information>Legal Information>Obtaining Source Code.
> 2.Tap "Mozilla Developer Network" link open MDN page.
> 3.Tap "Sign in".
> 4.Tap "Persona".
> 5.Open task manager and do any operation.
> 
> [3.Expected Result]: 
> 4.Device will open sign in page via standard full-screen window.
> 5.Task manager works normally.
> 
> [4.Actual Result]: 
> 4.Device will open sign in page via a small window.
> 5.Task manager become not smoothly.
> 
> [5.Reproduction build]: 
> Flame 2.2 version(Affected):
> Build ID               20150423002502
> Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
> Gaia Date              2015-04-23 02:32:46
> Gecko Revision        
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
> Gecko Version          37.0
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150423.035703
> Firmware Date          Thu Apr 23 03:57:16 EDT 2015
> Bootloader             L1TC000118D0
> 
> Device: Flame 3.0 version(Unaffected):
> Build ID               20150423160207
> Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
> Gaia Date              2015-04-23 16:10:10
> Gecko Revision        
> https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
> Gecko Version          40.0a1
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150423.193607
> Firmware Date          Thu Apr 23 19:36:18 EDT 2015
> Bootloader             L1TC000118D0
> 
> Device: Nexus 5_2.2 version(Affected):
> Build ID               20150423002502
> Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
> Gaia Date              2015-04-23 02:32:46
> Gecko Revision        
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
> Gecko Version          37.0
> Device Name            hammerhead
> Firmware(Release)      5.1
> Firmware(Incremental)  eng.cltbld.20150423.035409
> Firmware Date          Thu Apr 23 03:54:27 EDT 2015
> Bootloader             HHZ12f
> 
> Device: Nexus 5_3.0 version(Unaffected):
> Build ID               20150423160207
> Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
> Gaia Date              2015-04-23 16:10:10
> Gecko Revision        
> https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
> Gecko Version          40.0a1
> Device Name            hammerhead
> Firmware(Release)      5.1
> Firmware(Incremental)  eng.cltbld.20150423.192918
> Firmware Date          Thu Apr 23 19:29:36 EDT 2015
> Bootloader             HHZ12f
> 
> [6.Reproduction Frequency]: 
> Always Recurrence,5/5
> 
> [7.TCID]: 
> Free Test

The fulle error message actually states:

"Error
Please close this window and try again.

Action: Eestablishing Relay
Now: Fri, 22 May 2015 07:10:38p.m. GMT

Relay frame could not be found"

Then I have to hurt my fingers trying to push down hard on the OK button cus it acts frosen. But, I am able to go to Home using the round Home button.
It's not obvious why we need to take a v3.0 "feature" into v2.2 just because the behavior is different. Reading comment 0, I think the key point is why task manager is not smooth with the old trusted UI. Could we investigate why instead of picking a big patch?
As I know, step 4 of comment 0 will launch a trusted dialog and it's a smaller window than app just behaves the same as 2.1 2.0 ... . It might not be a bug here.

The commit from bug 911880 has changed many code in system app, and it also has some follow-up like bug 1124114 bug 1122011 bug 1122007 and probably others . I think it might be very risky to uplift those bugs to only fix step 5 of comment 0.
Flags: needinfo?(gduan)

Comment 18

3 years ago
Thanks George,
Marked as won't fix per comment 17.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → wontfix
Resolution: --- → WONTFIX

Updated

3 years ago
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.