sort personalization menu

RESOLVED DUPLICATE of bug 997761

Status

()

RESOLVED DUPLICATE of bug 997761
4 years ago
4 years ago

People

(Reporter: 21Naown, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

303.06 KB, image/png
Details
(Reporter)

Description

4 years ago
Created attachment 8597227 [details]
bug.png

Isn't possible to sort/move many icons here since a few weeks ? Is a bug or ? We can change their positions, but when we come back, positions are reset.

Comment 1

4 years ago
It should be possible to reorder items. Do none of your changes stay after a restart, or just ones in one of the areas? (does changing things in the toolbar work?)

Can you reproduce this issue on a clean profile? ( https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles )
Flags: needinfo?(21Naown)
(In reply to :Gijs Kruitbosch from comment #1)
> It should be possible to reorder items.

Really? I thought we've had this bug since the dawn of time with the palette. Where do we store the palette order?
Flags: needinfo?(gijskruitbosch+bugs)
(Reporter)

Comment 3

4 years ago
Created attachment 8597264 [details]
bug.png

Sorry, the area of this "bug" is into the red area. This "bug" produces when we leave/save changes of personalization. Even if it's a new profile/profile by default.

A video is finally better to explain : https://youtu.be/hvzKf5WYtaQ

In the past, I'm sure that all of icons could be sorted.
Attachment #8597227 - Attachment is obsolete: true
Flags: needinfo?(21Naown)

Comment 4

4 years ago
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #2)
> (In reply to :Gijs Kruitbosch from comment #1)
> > It should be possible to reorder items.
> 
> Really? I thought we've had this bug since the dawn of time with the
> palette. Where do we store the palette order?

I assumed they meant the panel menu, on the right. comment #3 helps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 997761
(Reporter)

Comment 5

4 years ago
(In reply to :Gijs Kruitbosch from comment #4)
> 
> I assumed they meant the panel menu, on the right. comment #3 helps.
> 
> *** This bug has been marked as a duplicate of bug 997761 ***

The panel menu at the right ? I focus on the left area in this report (the red area in the screenshot too), not right. Or I don't understand something. But, I assume the "palette" mentioned in the real thread about this ( https://bugzilla.mozilla.org/show_bug.cgi?id=997761 ) is the area what I marked.

I wanted just check if it was a bug. I could use a sort here (I can be manic) but, without a sort here, I don't care. A sort or not, it's not a problem.
Flags: needinfo?(gijskruitbosch+bugs)

Comment 6

4 years ago
(In reply to 21Naown from comment #5)
> (In reply to :Gijs Kruitbosch from comment #4)
> > 
> > I assumed they meant the panel menu, on the right. comment #3 helps.
> > 
> > *** This bug has been marked as a duplicate of bug 997761 ***
> 
> The panel menu at the right ? I focus on the left area in this report (the
> red area in the screenshot too), not right.

Right, I initially misunderstood you, and thought you meant the area on the right. Your last comment helped clarify this was about the area on the left, and so I marked it as being the same as an earlier issue filed for this.

> Or I don't understand something.
> But, I assume the "palette" mentioned in the real thread about this (
> https://bugzilla.mozilla.org/show_bug.cgi?id=997761 ) is the area what I
> marked.

Yes, I understood now. Thanks!

> I wanted just check if it was a bug. I could use a sort here (I can be
> manic) but, without a sort here, I don't care. A sort or not, it's not a
> problem.

If someone wrote a patch to make this sorting stay between opening customize mode, I think we might take it, but I don't know that the core developers will spend time adding code for it - we have a lot of other bugs to worry about. Still, thanks for reporting this - it's always useful to know what people think!
Flags: needinfo?(gijskruitbosch+bugs)
You need to log in before you can comment on or make changes to this bug.