When swapping docshells the frameloader reloads all existing framescripts

RESOLVED INVALID

Status

()

Core
DOM: Content Processes
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: mossop, Assigned: krizsa)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(e10sm7+)

Details

(Reporter)

Description

3 years ago
In bug 1134518 comment 25 Tim reports that swapping a docshell to a new window its frameloader reloads all frame scripts regardless of whether it has already loaded them.
Oh, it might load window level frame scripts again, I guess.

Updated

3 years ago
tracking-e10s: ? → m7+
(Assignee)

Updated

3 years ago
Assignee: nobody → gkrizsanits
(Assignee)

Comment 2

2 years ago
I've been trying to reproduce this issue for a while. In my experience this is not the case, swapping docshells do not trigger frame-scripts to be reloaded. I tried browser.ownerDocument.defaultView.messageManager level frame-scripts and browser.messageManager as well. It seems to be that the reason of those test failures were something else... I'm leaning toward won't fix this bug, but want to ask Tim about it first, maybe he knows how to reproduce it.
Flags: needinfo?(ttaubert)
TBH, I can't quite remember the exact problem I had when I worked on that other bug. We can file it again if we ever hit it again I guess?
Flags: needinfo?(ttaubert)
(Assignee)

Comment 4

2 years ago
(In reply to Tim Taubert [:ttaubert] from comment #3)
> TBH, I can't quite remember the exact problem I had when I worked on that
> other bug. We can file it again if we ever hit it again I guess?

I agree, let's do that.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.