[First Time Experience] The string "{{imported}}/{{total}} friends imported" is truncated

VERIFIED DUPLICATE of bug 1157157

Status

Firefox OS
Gaia::First Time Experience
VERIFIED DUPLICATE of bug 1157157
3 years ago
3 years ago

People

(Reporter: delphine, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.2,MGSEI-l10n-1F-Portuguese Portugal )

Attachments

(11 attachments)

Follow-up of Bug 1157157 that was covering multiple strings, see that bug for detailed info about the builds used and screenshots.

String {{imported}}/{{total}} friends imported is truncated for multiple shipping locales, for ex. pt-BR and serbian-Cyrl
Whiteboard: LocRun2.2
status-b2g-v2.2: --- → affected
Sue: since you filed Bug 1157157, please do a check on this string for all 2.2 tested locales on both 2.1 and 2.2
I imagine many must truncate here, and that we might need a dev fix for this. It doesn't look like a string that can be easily shortened by localizers. thanks
Flags: needinfo?(lulu.tian)

Comment 2

3 years ago
So, for string "aa/bb friends imported" I don't see truncation in pt-BR on 2.1, which should be the same in 2.2.

Pootle shows "{{imported}}/{{total}} amigos importados" for 2.2, which is the same as 2.1

Resolved-Invalid for pt-BR.
:msaad: there can be regressions between 2.2 and 2.1, than cause truncation even though the string is the same. I would suggest to check on a device on 2.2, just in case.
I've asked QA to do so in this bug, and on all the locales they are testing.

Comment 4

3 years ago
Okey, didn't knew that. I'll have to wait since I don't own a device :/. Will follow the bug.

Comment 5

3 years ago
Created attachment 8597862 [details]
Bengali India.png

Hi Delphine,
I have checked on this string for all tested locales on both 2.1 and 2.2. When user only imports one friend from Facebook, the results of displaying text "One friend imported" are as follows:
When the language is set as Spanish, Serbian Cyrillic, Serbian Latin, Portuguese Brazil and Portuguese Portugal, both Flame 2.1 and 2.2 are unaffected, the string is shown correctly.
When the language is set as Bengali India, both Flame 2.1 and Flame 2.2 are affected.
When the language is set as Polish and Russian, Flame 2.1 is unaffected, Flame 2.2 is affected.
When the language is set as Greek, Flame 2.1 is affected, Flame 2.2 is unaffected.
I have uploaded the screenshot of all languages, please check it. Thanks!
See attachment:
Bengali India.png
Greek.png
Polish.png
Portuguese Brazil.png
Portuguese Portugal.png
Russian.png
Serbian Cyrillic.png
Serbian Latin.png
Spanish.png
Flags: needinfo?(lulu.tian)

Comment 6

3 years ago
Created attachment 8597864 [details]
Greek.png

Comment 7

3 years ago
Created attachment 8597866 [details]
Polish.png

Comment 8

3 years ago
Created attachment 8597867 [details]
Portuguese Brazil.png

Comment 9

3 years ago
Created attachment 8597868 [details]
Portuguese Portugal.png

Comment 10

3 years ago
Created attachment 8597869 [details]
Russian.png

Comment 11

3 years ago
Created attachment 8597870 [details]
Serbian Cyrillic.png

Comment 12

3 years ago
Created attachment 8597871 [details]
Serbian Latin.png

Comment 13

3 years ago
Created attachment 8597872 [details]
Spanish.png

Device informations:
Device: Flame 2.1 user
Build ID               20150426001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/82a14be0462c
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.035220
Firmware Date          Sun Apr 26 03:52:31 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.040327
Firmware Date          Sun Apr 26 04:03:38 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(lebedel.delphine)
Whiteboard: LocRun2.2 → LocRun2.2,MGSEI-l10n-1F-Portuguese Portugal
Good, pt-BR is fine. Removing myself from the cc'ed list.
So it seems that shipping locales affected on 2.2 are:  bn-IN, Polish and Russian.
They are affected not because of UI regression, but because they used a longer string on 2.2 vs 2.1. Flagging localizers so they can shorten their strings on 2.2 once more. thanks!
Flags: needinfo?(unghost)
Flags: needinfo?(splewako)
Flags: needinfo?(lebedel.delphine)
Flags: needinfo?(brnet00)
What is the main string? So I can short them.
I think bug 1157157 should fix this also, the patch there allows this string to wrap onto multiple lines as necessary. If you do want to revisit these strings, they are 'facebook-import-msg' etc. at https://github.com/mozilla-b2g/gaia/blob/v2.2/apps/ftu/locales/ftu.en-US.properties#L201,L207
Adding verifyme keyword so Marigold can check once Bug 115157 lands if this fixed the issue on all concerned locales.
Keywords: verifyme
Meant Bug bug 1157157 in comment 18...
I've shortened strings in Russian l10n:
http://hg.mozilla.org/gaia-l10n/ru/rev/431150c20e9e
Flags: needinfo?(unghost)
I've shortened strings for bn-IN l10n in pootle
Flags: needinfo?(brnet00)
I'm going to mark this as a dupe as the fix in bug 1157157 affects the way this string is displayed also. It allows for longer strings to wrap as necessary. Lets verify as planned (I think comment #18 has the wrong bug number, it should have been 1157157) before seeking uplift.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1157157
Clearing ni? under assumption that this was fixed in bug 1157157.
Flags: needinfo?(splewako)
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
Keywords: qawanted
Created attachment 8609245 [details]
Verify1_bn-IN_v2.1&v2.2_Pass.png

This issue is verified pass on latest flame v2.2 user build in bn-IN, Polish and Russian languages.
See attachments: Verify1_bn-IN_v2.1&v2.2_Pass.png and Verify1_Polish&Russian_v2.2_Pass.png
Reproducing rate:0/5
STR:
1.Flash new user build or reset the device to enter FTE.
2.Set the phone language to bn-IN, Polish and Russian.
3.Connect the network and go to the "Import contacts" view.
4.Sign in facebook account and select more than one contact to import.
5.Observe the "Import contacts" view.

Result:The string "{{imported}}/{{total}} friends imported" is displayed without truncation.

Device: Flame2.1 User build (bn-IN verified Pass)
Build ID               20150521001201
Gaia Revision          c80865cb0bf73f1b97defbc646083b404feb3ac4
Gaia Date              2015-05-12 06:26:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ddb03c402946
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150521.040744
Firmware Date          Thu May 21 04:07:53 EDT 2015
Bootloader             L1TC000118D0

Device: Flame2.2 user build (bn-IN, Polish and Russian verified Pass)
Build ID               20150521162503
Gaia Revision          8099d4fbdcc659d3f6a75e98346a1214cca26802
Gaia Date              2015-05-21 14:39:42
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/fd7b06b22d00
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150521.200244
Firmware Date          Thu May 21 20:02:53 EDT 2015
Bootloader             L1TC000118D0
Created attachment 8609246 [details]
Verify1_Polish&Russian_v2.2_Pass.png
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-v2.2: affected → verified
Keywords: qawanted, verifyme
You need to log in before you can comment on or make changes to this bug.