If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Browser][Private Window] Trying to access the options window of a private browser while the page is loading will render the device unusable until restart

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Browser
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: DerekH, Assigned: johnhu)

Tracking

({regression})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], [systemsfe], URL)

Attachments

(1 attachment)

Created attachment 8597369 [details]
Browser Private Logcat

Description:
When opening the options menu of a private browser window while the page is loading, the device becomes unusable until a device restart. A passcode lock appears to overlay the screen, but non of the buttons on it work and it cannot be dismissed. When going to the homescreen the homescreen appears blank, but the tops of some of the apps can be seen at the very top of the screen


Repro Steps:
1) Update a Flame to 20150424010200
2) Connect to a WiFi or data connection
3) Open Browser app> Tap on "New private window"
4) Quickly tap on the "..." Elipsies


Actual:
Passcode lock appears (even without setting a passcode) and Overlays the device. When going home, the homescreen appears blank, but the tops of apps can be seen at the top of the screen. Restart device to fix this issue


Expected:
User is taken to browser options menu

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150424010200
Gaia: 0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gecko: 22a157f7feb7
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 20/20
See attached: Logcat, Video - https://www.youtube.com/watch?v=cJ7lQGaMYJE&edit=vd
This issue does NOT occur on Flame 2.2

User is taken to browser options menu

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150424002507
Gaia: b838d0e7c163e66660dcb6e387d8339944a7a30e
Gecko: 5fe76b26e55f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
blocking-b2g: --- → 3.0+
Keywords: regressionwindow-wanted
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing], [systemsfe]
QA Contact: pcheng
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150420171900
Gaia: e62169edf3010cce33bac5df48aa8a9c241ce736
Gecko: b43ffb8aa510
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken
Device: Flame
BuildID: 20150420195300
Gaia: 3be562701d5b276ff2ac46a5e9fbd63a9b378d4d
Gecko: b09299831d7e
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: e62169edf3010cce33bac5df48aa8a9c241ce736
Gecko: b09299831d7e

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 3be562701d5b276ff2ac46a5e9fbd63a9b378d4d
Gecko: b43ffb8aa510

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/e62169edf3010cce33bac5df48aa8a9c241ce736...3be562701d5b276ff2ac46a5e9fbd63a9b378d4d

Caused by Bug 1154642.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
John, can you take a look at this please? This looks to have been caused by the landing for Bug 1154642. We may need this backed out.
Blocks: 1154642
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(im)
Thanks KTucker,

I will back it out. Sorry about this.
Assignee: nobody → im
Flags: needinfo?(im)
The patch of bug 1154642 is backed out. I will check this bug and try to add the test case to unit test or integration test.
Close this issue, since bug 1154642 is backed out.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Keywords: verifyme
Resolution: FIXED → WORKSFORME
I believe this falls under resolved fixed and not worksforme because this is fixed by the backout of offending patch. Changing it to resolved fixed. I'm unable to verify this issue on today's nightly because the fix is not included. I'll verify this on tomorrow's nightly.
status-b2g-master: affected → fixed
Resolution: WORKSFORME → FIXED
This issue is verified fixed on today's nightly. Following STR, the options menu is opened without screen going haywire. Since this is a bit of a timing issue, I've tried this 6 times and made sure it didn't reproduce.

Device: Flame 3.0 Master (full flashed 319MB KK)
BuildID: 20150428010206
Gaia: 0636405f0844bf32451a375b2d61a2b16fe33348
Gecko: caf25344f73e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
status-b2g-v2.5: --- → verified
Target Milestone: --- → 2.2 S11 (1may)
status-b2g-v2.5: verified → ---
You need to log in before you can comment on or make changes to this bug.