Operator shelf is not created because of the JS error TypeError: o is null include.js:7:28572

VERIFIED FIXED in 2015-04-28

Status

Marketplace
Curation Tools
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: krupa, Assigned: mat)

Tracking

({regression})

2015-04-28
regression
Points:
---

Details

(URL)

(Reporter)

Description

3 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/operators/shelves/create as an admin
2. Enter all the required fields to create an op shelf
3. Save the new op shelf

expected behavior:
New op shelf created

actual behavior:
Operator shelf is not created because of the JS error
TypeError: o is null include.js:7:28572

https://www.dropbox.com/s/h53zervvmrma8s9/Screenshot%202015-04-24%2011.20.39.png?dl=0
(Assignee)

Comment 1

3 years ago
Might be my fault following the regions&carriers update, taking to investigate.
Assignee: nobody → mpillard
(Assignee)

Comment 2

3 years ago
Weird. https://marketplace-dev-cdn.allizom.org/media/marketplace-operator-dashboard/js/include.js?b=1427304058526 does not seem to contain my code (carriers array is still in the setting module, carriers module is absent, usage of CARRIER_SLUGS variable is not found anywhere, etc). I don't get the same result when running make build locally.
Priority: -- → P2
Target Milestone: --- → 2015-04-28
(Assignee)

Comment 3

3 years ago
It was a deploy issue, resolved now. It should not be happening on stage/prod.

If you still don't see an operator/region in the header and just see " / ", then you need to clear your localStorage to refresh the list (the wrong deploy made you store an empty list). In the console, do localStorage.clear();
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 4

3 years ago
Verified on MP-dev FF40(Win 7).
After localStorage.clear() I was able to see the operator/region in the header. When trying to submit the created operator, I received an error message, but the operator was created.
Please see the screencast: http://screencast.com/t/mOc7m1tQLxj

Also, I can still reproduce this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1158109 with the message "Internal Server Error" and error code 500 in the console, and no op shelf created.
Maybe are related.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

3 years ago
Since the opshelf is created, this is a different issue. I'd open a new bug.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

3 years ago
Also, can you reproduce this on stage ?

Comment 7

3 years ago
(In reply to Mathieu Pillard [:mat] from comment #5)
> Since the opshelf is created, this is a different issue. I'd open a new bug.
You will open, or should I?

I can not reproduce the issue mentioned at comment #0 and neither the one from comment #5 in MP-stage.
(Assignee)

Comment 8

3 years ago
Please open it since you found it :)

Comment 9

3 years ago
(In reply to Mathieu Pillard [:mat] from comment #8)
> Please open it since you found it :)

Deal!

Closing the issue from comment #0 according to comment #5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.