service-workers/cache-storage wpt tests expect to store VARY:* Responses

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bkelly, Assigned: bkelly)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

3 years ago
There are tests in service-workers/cache-storage that expect to store Responses with a VARY:* header.  The spec now requires this to throw a TypeError.  For example:

  5. If response's associated response's header list contains a header named
     `Vary`, then:
    1. Let varyHeaders be the array containing the elements corresponding to the
       field-values of the Vary header.
    2. For each f in varyHeaders:
      1. If f matches "*", return a promise rejected with a TypeError.

From:

  https://slightlyoff.github.io/ServiceWorker/spec/service_worker/index.html#cache-put
(Assignee)

Updated

3 years ago
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1154975
(Assignee)

Comment 2

3 years ago
Merged from upstream in bug 1161535.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Depends on: 1161535
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.