Proxy on Document or Element throws an error

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: Florent Fayolle, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150420134330

Steps to reproduce:

1. Run this snippet: https://gist.github.com/zenparsing/9ff3036b6eb15fa436e4
2. Run: Maybe(self).document.querySelector("foo")
   => throws "TypeError: 'querySelector' called on an object that does not implement interface Document."
3. Run: Maybe(self).document instanceof Document // true

Also there is this simpler test case:
https://pastebin.mozilla.org/8831388



Expected results:

I would expect (maybe naively?) this should call querySelector correctly. 

Note: arai pointed out that the exception raises here: https://dxr.mozilla.org/mozilla-central/source/dom/bindings/BindingUtils.cpp#2571

Florent
Sorry for the late reply: tested your sample on the latest nightly: <Version 46.0a1 / Build ID 20151221114259 and it seems the problem is not reproducible anymore. 

Also it seems to me that the latest gist version(4) code modifications do not contain the reported problem even on the original Firefox version that was reported on(version 38.0.1 /Build ID 20150513174244).
I will mark this issue as invalid. 
@reporter Please reopen if I'm missing something.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.