Closed Bug 1158500 Opened 5 years ago Closed 4 years ago

Make writing-mode a mapped CSS property

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: longsonr, Assigned: longsonr)

References

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
Blocks: 319163
Attached patch mapped.txt (obsolete) — Splinter Review
The SVG 2 specification needs to change to have text-orientation as a mapped CSS property and deprecate glyph-orientation.
Assignee: nobody → longsonr
Attachment #8597623 - Flags: review?(cam)
Comment on attachment 8597623 [details] [diff] [review]
mapped.txt

Review of attachment 8597623 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for forgetting about this review.

Although it was not my preference, the WG decided that we will not add new presentation attributes.  The Styling chapter in SVG 2 is still yet to be rewritten, but when I get around to it I will make it clear what the exact set of presentation attributes that must be supported are.

(Happy to take a separate patch removing the now unused atoms, though.)
Attachment #8597623 - Flags: review?(cam) → review-
Does that mean that writing-mode should be mapped since it is present in SVG 1.1 even though we support none of the SVG 1.1 values for it?
Flags: needinfo?(cam)
The baseline is the set of presentation attributes supported by SVG 1.1, minus any properties we dropped support for in SVG 2.  A couple were implemented in Gecko and Blink before the decision was made (paint-order comes to mind) to we likely need to keep.

So to answer your question: probably. :-)  The fact that we have a completely separate set of values now might argue for treating it as a "new" property and thus not have a presentation attribute, though.  We have a F2F in a couple of weeks; I'll ask about writing-mode there.
Flags: needinfo?(cam)
Duplicate of this bug: 1259038
Do you want me to strip out text-orientation from this patch Cameron?
Flags: needinfo?(cam)
Yes, please.  The outcome of the F2F discussion was to indeed to restrict presentation attributes to properties that had one in SVG 1.1, plus one or two others, and that doesn't include text-orientation.  The list now at https://svgwg.org/svg2-draft/styling.html#PresentationAttributes should reflect the WG decision.  Thanks!
Flags: needinfo?(cam)
Summary: Make writing-mode and text-orientation mapped CSS properties → Make writing-mode a mapped CSS property
Comment on attachment 8736020 [details] [diff] [review]
add writing-mode, and remove various other related obsolete SVG text atoms

Review of attachment 8736020 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/base/nsGkAtomList.h
@@ +1312,5 @@
>  GK_ATOM(headerDNSPrefetchControl,"x-dns-prefetch-control")
>  GK_ATOM(headerCSP, "content-security-policy")
>  GK_ATOM(headerCSPReportOnly, "content-security-policy-report-only")
>  GK_ATOM(headerXFO, "x-frame-options")
> +GK_ATOM(writing_mode, "writing-mode")

Probably better to put this around line 1590, in the group of atoms for SVG element and attribute names.
Attachment #8736020 - Flags: review?(cam) → review+
Flags: in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/104e03d0e408
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Duplicate of this bug: 1276535
You need to log in before you can comment on or make changes to this bug.