Closed Bug 1158531 Opened 5 years ago Closed 5 years ago

[e10s] F6 no longer gives focus to the web page, only focuses the location bar

Categories

(Core :: User events and focus handling, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1132518
Tracking Status
e10s ? ---
firefox40 --- affected

People

(Reporter: gingerbread_man, Unassigned)

Details

(Keywords: access)

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150425030208

Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150425030208

Steps to reproduce:
1. https://en.wikipedia.org
2. Press Ctrl+K to focus the search bar.
3. Press F6 repeatedly.

Actual results:
The location bar is focused and retains the focus.

Expected results:
The web page is focused on the first key press, then the location bar is focused, then the web page again, and so on. This still works in a non-e10s window.
(In reply to [:Aleksej] from comment #1)
> bug 1132518?

Yes. Thank you.
Status: NEW → RESOLVED
Closed: 5 years ago
Component: Keyboard Navigation → Event Handling
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1132518
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.