Switch to tab doesn't work when browsing history is disabled

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: claritise, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20150710])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150425030208

Steps to reproduce:

Switch to tab suggestions only suggests switching tab if there is a matching tab in the browsing history.



Expected results:

Switch to tab suggestions should work without requiring history enabled.
Please rewrite steps to reproduce. What you have written is difficult to comprehend. [testday-20150710]
Couldn't reproduce this on Firefox 40 beta

working as expected on Mozilla/5.0 (Windows NT 6.1; rv:40.0) Gecko/20100101 Firefox/40.0

are you still having this issue?
Whiteboard: [testday-20150710]
Flags: needinfo?(claritise)
(Reporter)

Comment 3

3 years ago
I tested again and the switch-to-tab feature now works as suggested. 
However, a switch-to-tab match will only occur with the matching URL, rather than the webpage title which is less than ideal.
Most URLs are completely disconnected with the webpage title and so practically makes switch-to-tab useless. Only with browsing history enabled is the switch-to-tab match linked with the actual webpage title.
Flags: needinfo?(claritise)
Per comment 3, I will close this bug. If any new information arises I will happily reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.