Closed Bug 1158604 Opened 9 years ago Closed 8 years ago

Dynamic content is not refreshed for accessibility products

Categories

(Firefox :: Disability Access, defect)

37 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: fjestrad, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

I have found this bug while I was developing with Angular JS.
I used data binding for many variables which should be updated when users take some actions (like increase or decrease the amount of products at a spinner).


Actual results:

The interface elements which depend of this data were updated for the screen, but screen reader still read the old value.


Expected results:

The screen reader should read the new value. It works with other browsers.
Hello,

Could you please provide me with more detailed steps.

I can not replicate with the information provided.
Flags: needinfo?(fjestrad)
The task where I found this bug was simple. I had a shopping cart view like a table. The web app took the unitary price for each product from the database and it was binded to the view by Angular. For each row, I had an input field of type number that marked the amount of each product. Finally, each row had a total field, that dynamically calculated the value from both previous. Each row was something like this:

<tr>
<td>{{product.name}}</td>
<td>{{product.price}}</td>
<td><input type="number" data-ng-model="product.amount" /></td>
<td>{{product.price * product.amount}}</td>
</tr>

The isue made that while the view was refreshed and you could see the new value, screen reader (used Jaws in Windows) still read the old value and did not refresh it. Internet Explorer did refresh the value for screen reader too.

I suspect it is related with non-dettach/insert DOM elements, because the screen reader worked perfectly with dynamic lists and so on.

I hope it helps you to identify the isue.
Flags: needinfo?(fjestrad)
Component: Untriaged → Disability Access
Can we get a live example somewhere, please?
Flags: needinfo?(fjestrad)
I have reviewed some examples which didn't work fine previously and I have found that they work now. Maybe an update has corrected the bug indirectly since I reported it? Whatever, it looks like solved. Thanks for your time.
Flags: needinfo?(fjestrad)
Thanks for re-testing! Closing as WORKSFORME as per comment #4.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.