Closed Bug 1158617 Opened 5 years ago Closed 5 years ago

Zooming in to images on Ebay and Imgur brings up the context menu

Categories

(Firefox for Android :: Toolbar, defect)

40 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 40
Tracking Status
firefox37 --- affected
firefox38 --- affected
firefox39 --- verified
firefox40 --- verified

People

(Reporter: Ashley, Assigned: kats)

Details

(Keywords: reproducible)

Attachments

(2 files)

Attached video Context menu shows
User Agent: Mozilla/5.0 (Android; Tablet; rv:40.0) Gecko/40.0 Firefox/40.0
Build ID: 20150425030208

Steps to reproduce:

1. Go to http://m.imgur.com/mkd0kEG
2. Pinch to zoom in slowly
3. Context menu shows 


Actual results:

Context menu shows
Example video in attatchments


Expected results:

Not to show up. Annoying
Thanks for the report, ashley! What device are you using? I suspect I know what's causing this but I cannot reproduce on my nexus 4.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> Thanks for the report, ashley! What device are you using? I suspect I know
> what's causing this but I cannot reproduce on my nexus 4.

Are you sure you're zooming in to the image on the link I provided? I'm using the LG G PAd 8.3, a tablet.
Yeah I used the link you provided. I thought it might be easier to reproduce on lower-resolution devices but the device you have is pretty high resolution too so it can't be that. Not sure then why I don't see this problem.
Aaron, are you able to repro?
Flags: needinfo?(aaron.train)
Flags: needinfo?(aaron.train) → needinfo?(flaviu.cos)
Its a lot harder to reproduce in a lower resolution devices im guessing. I tried it on an old 480x800 resolution phone and needs multiple tries to get a context menu while zooming in/out. On the tablet its very easy to do.
The issue is reproducible using the link provided in comment 0;
Tested on Nexus 7 (Android 5.1).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(flaviu.cos)
Keywords: reproducible
OS: Unspecified → Android
Hardware: Unspecified → ARM
Attached patch WIPSplinter Review
This is a possible fix for the issue although since I can't reproduce it I can't really test it. I pushed a build on the try server at https://treeherder.mozilla.org/#/jobs?repo=try&revision=b6bafe45a5b9; when that's done I'd like one of you to test the build to see if the problem still happens.
The build is at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kgupta@mozilla.com-b6bafe45a5b9/try-android-api-11/ - can either of you try it out to see if you can reproduce the problem on that build?
Flags: needinfo?(flaviu.cos)
Flags: needinfo?(Ashley)
(Note: it will install as "Nightly" and use your nightly profile)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #9)
> The build is at
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kgupta@mozilla.com-
> b6bafe45a5b9/try-android-api-11/ - can either of you try it out to see if
> you can reproduce the problem on that build?

Works well. No context menu anymore for me.
Flags: needinfo?(Ashley)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #9)
> The build is at
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kgupta@mozilla.com-
> b6bafe45a5b9/try-android-api-11/ - can either of you try it out to see if
> you can reproduce the problem on that build?

The issue is not reproducible. Works fine on Nexus 7 (Android 5.1).
Flags: needinfo?(flaviu.cos)
Comment on attachment 8599385 [details] [diff] [review]
WIP

Review of attachment 8599385 [details] [diff] [review]:
-----------------------------------------------------------------

I think I've seen this too, so I'm happy this is getting fixed!
Attachment #8599385 - Flags: review?(bnicholson) → review+
Assignee: nobody → bugmail.mozilla
https://hg.mozilla.org/mozilla-central/rev/e9ddb507f072
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Comment on attachment 8599385 [details] [diff] [review]
WIP

Approval Request Comment
[Feature/regressing bug #]: none really, but on some newer devices this bug gets hit more frequently. would be nice to get this fix out sooner.
[User impact if declined]: when doing a pinch-zoom on websites that implement their own pinch-zoom, the user might get a context menu unexpectedly
[Describe test coverage new/current, TreeHerder]: no automated tests, but tested locally by reporter/QA
[Risks and why]: fairly small patch, low-risk
[String/UUID change made/needed]: none
Attachment #8599385 - Flags: approval-mozilla-aurora?
Verified as fixed in build 40.0a1 (2015-05-04);
Device: Asus Transformer Tab (Android 4.2.1).
Comment on attachment 8599385 [details] [diff] [review]
WIP

Approved for uplift to aurora. This has only had manual testing, but has had a few days on Nightly without incident, and looks fairly low-risk.
Attachment #8599385 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed in build 39.0a2 (2015-05-07);
Device: Nexus 7 (Android 5.1.1).
You need to log in before you can comment on or make changes to this bug.