"New e10s Window" menuitem should be hidden when browser does not support e10s

RESOLVED INVALID

Status

()

Core
Plug-ins
--
trivial
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({crash})

Trunk
Unspecified
Windows 10
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

3 years ago
After landing Bug 1155976 and Bug 115827.
Flash plungin not working sometimes. 
Page is blank. Nothing to load.
Shutdown crash


Steps to reproduce(Windows8.1/10TP):
1. Start Nightly(fx-team cset f43178fc99aa)
   and disable e10s when e10s notification pops up.(due to accessibility is not support)
   --- then Nightly will be restated 
2. Open http://www.adobe.com/software/flash/about/
   --- Flash Plugin working as expected
3. Open new e10s window from menu
4. Open http://www.adobe.com/software/flash/about/
   --- Page is blank. Nothing to load.
5. Quit Nightly
   --- Crashes

Actual Results:
Not working properly.
Crashes when shutdown

Expected results:
Browser should be working properly.
Not crash.

OR

"New e10s Window" menuitem should be hidden when browser does not support e10s.
And vice versa
(Reporter)

Comment 1

3 years ago
[Tracking Requested - why for this release]:
status-firefox40: affected → ---
tracking-e10s: --- → ?
(Reporter)

Updated

3 years ago
Severity: critical → trivial
tracking-e10s: ? → ---
Version: 40 Branch → Trunk

Comment 2

3 years ago
Alice, do you have crash IDs?

Does this only happen if you mix e10s and non-e10s windows?
Flags: needinfo?(alice0775)
Keywords: ux-consistency
(Reporter)

Comment 3

3 years ago
https://hg.mozilla.org/mozilla-central/rev/caf25344f73e
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0 ID:20150428030209

bp-30677552-71d5-4ff1-8dee-75a442150428
Flags: needinfo?(alice0775)

Updated

3 years ago
Flags: needinfo?(jmathies)

Comment 4

3 years ago
(In reply to Alice0775 White from comment #0)
> After landing Bug 1155976 and Bug 115827.
> Flash plungin not working sometimes. 
> Page is blank. Nothing to load.
> Shutdown crash
> 
> 
> Steps to reproduce(Windows8.1/10TP):
> 1. Start Nightly(fx-team cset f43178fc99aa)
>    and disable e10s when e10s notification pops up.(due to accessibility is
> not support)
>    --- then Nightly will be restated 
> 2. Open http://www.adobe.com/software/flash/about/
>    --- Flash Plugin working as expected
> 3. Open new e10s window from menu
> 4. Open http://www.adobe.com/software/flash/about/
>    --- Page is blank. Nothing to load.
> 5. Quit Nightly
>    --- Crashes

Alice, in step #3 did you mean open a non-e10s window?

I can't reproduce using your steps here using "open new window" or ctrl-n which gives me a new e10s window.
Flags: needinfo?(jmathies) → needinfo?(alice0775)

Comment 5

3 years ago
The shutdown hang+crash alice ran into is bug 1127270.
(Reporter)

Comment 6

3 years ago
(In reply to Jim Mathies [:jimm] from comment #4)
> (In reply to Alice0775 White from comment #0)
> > After landing Bug 1155976 and Bug 115827.
> > Flash plungin not working sometimes. 
> > Page is blank. Nothing to load.
> > Shutdown crash
> > 
> > 
> > Steps to reproduce(Windows8.1/10TP):
> > 1. Start Nightly(fx-team cset f43178fc99aa)
> >    and disable e10s when e10s notification pops up.(due to accessibility is
> > not support)
> >    --- then Nightly will be restated 
> > 2. Open http://www.adobe.com/software/flash/about/
> >    --- Flash Plugin working as expected
> > 3. Open new e10s window from menu
> > 4. Open http://www.adobe.com/software/flash/about/
> >    --- Page is blank. Nothing to load.
> > 5. Quit Nightly
> >    --- Crashes
> 
> Alice, in step #3 did you mean open a non-e10s window?

No. New e10s Window.

 
> 
> I can't reproduce using your steps here using "open new window" or ctrl-n
> which gives me a new e10s window.

So,probably, your pc does not activate any accessibility tool.

On my pc, E10s is disabled by default on Windows10TP due to an accessibility tool is or was active. (I do not know which is the accessibility tool)
Flags: needinfo?(alice0775)

Updated

3 years ago
Blocks: 1159326

Updated

3 years ago
tracking-e10s: --- → +
(In reply to Jim Mathies [:jimm] from comment #5)
> The shutdown hang+crash alice ran into is bug 1127270.

Given the crash is captured there, I'm going to change the bug summary to describe the remaining issue.
Summary: Confuse that Flash plugin is sometimes working and sometimes not working regardless of e10s. and shutdown crash → "New e10s Window" menuitem should be hidden when browser does not support e10s
Jimm, I think this remaining work (to disable the e10s window menu option) got done somewhere else but I'm not sure where. Can this bug be closed?
Flags: needinfo?(jmathies)

Comment 9

3 years ago
yeah, looks like we removed it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jmathies)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.