ServiceWorkerClient is linked to outer windows

RESOLVED DUPLICATE of bug 1158728

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1158728
3 years ago
3 years ago

People

(Reporter: catalinb, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

(Reporter)

Description

3 years ago
Client objects are linked to outer windows, which allows situations such as:
1. service worker creates a client (using matchAll).
2. the corresponding window navigates to google.com
3. client.postMessage will now dispatch messages to the google.com window.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1158728
You need to log in before you can comment on or make changes to this bug.