[Flame][Dialer]The "Call forwarding" header is shown truncated.

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yue.xia, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.2, )

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8597898 [details]
pt-PT Call forwarding.png

[1.Description]:
[Flame][v2.2][Dialer]Dialer "*#21#", the "Call forwarding" header is shown truncated.
See attachment: pt-PT Call forwarding.png

[2.Testing Steps]: 
1. Insert a SIM card into device and set language to  Portuguese Portugal (pt-PT).
2. Launch Phone app.
3. Type in "*#21#", tap "Dial" icon and check all the strings on the "Call Forwarding" screen. 

[3.Expected Result]: 
3. The "Call forwarding" header should not be truncated.

[4.Actual Result]: 
3. The "Call forwarding" header is shown truncated.

[5.Reproduction build]: 
Device: Flame 2.1 user (Unaffected)
Build ID               20150426001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/82a14be0462c
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.035220
Firmware Date          Sun Apr 26 03:52:31 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user (Affected)
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.040327
Firmware Date          Sun Apr 26 04:03:38 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12332
(Reporter)

Updated

4 years ago
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Assignee: nobody → joao.neves
Component: Gaia::Dialer → pt-PT / Portuguese
Product: Firefox OS → Mozilla Localizations
QA Contact: joao.neves
Regression: this was looking good on 2.1 but not 2.2, though localizer used the same string.
Blocking as this affects a shipping locale
blocking-b2g: --- → 2.2?
Keywords: regression
blocking-b2g: 2.2? → 2.2+
Assignee: joao.neves → nobody
Component: pt-PT / Portuguese → Gaia::Dialer
Product: Mozilla Localizations → Firefox OS
QA Contact: joao.neves
Actually the string is exactly the same on the two versions.

I think that this issue is caused by the difference in the font size on the title (which is greater on 2.2 that it was on 2.1).

I removed the translation of the term "Call" (which removed the "de chamadas" from the string). This means that the title will now be "Forwarding" ("Reencaminhamento") for this screen in pt-PT. The user can still get the context from the string "Call forwarding status" in the same screen.

Thank you
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Since localizer was able to fix this, I'll leave the bug as closed and won't block on it. However, if other locales are truncated as well and this regression affects them, then let's try and get a fix other than l10n.
Shine: can you please check this string across the other shipping locales, and let me know here if there are other instances were this was fixed on 2.1 but not 2.2, although localizer used the *same* string? thanks
blocking-b2g: 2.2+ → ---
Flags: needinfo?(yue.xia)
(Reporter)

Comment 4

4 years ago
Created attachment 8599730 [details]
screenshots.zip

Hi Delphine,
1. I have checked on this string for all tested locales on both 2.1 and 2.2 user build. 
There's no instance that this bug was fixed on 2.1 but not 2.2. But in Greek language, the Flame 2.1 is Affected, Flame 2.2 is Unaffected.
2. All localizer used the same string.
The check result are as follow:
Spanish: both Flame 2.1 and Flame 2.2 are Unaffected
Serbian Cyrillic: both Flame 2.1 and Flame 2.2 are Unaffected
Serbian Latin: both Flame 2.1 and Flame 2.2 are Unaffected
Russian: both Flame 2.1 and Flame 2.2 are Unaffected
Bengali from India: both Flame 2.1 and Flame 2.2 are Unaffected
Greek: Flame 2.1 is Affected, Flame 2.2 is Unaffected
Polish: both Flame 2.1 and Flame 2.2 are Unaffected
Basque: both Flame 2.1 and Flame 2.2 are Unaffected
Portuguese from Brazil: both Flame 2.1 and Flame 2.2 are Unaffected
Please check the screenshots of all languages.
See attachment: screenshots.zip
Thanks!

Device: Flame 2.1 user
Build ID               20150429001202
Gaia Revision          9fda4aec7f9495a27a335ccaf3b1a4dc9c4c6db0
Gaia Date              2015-04-28 19:33:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/38ab00c01159
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.034244
Firmware Date          Wed Apr 29 03:42:55 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.040640
Firmware Date          Wed Apr 29 04:06:52 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(yue.xia)
great, thanks Shine! Let's keep doing like mentioned in comment 3 then. Thanks!
(Reporter)

Comment 6

4 years ago
Created attachment 8601885 [details]
Verify_Pass_2.2user_Portuguese Portugal.png

This problem is verified pass on latest user build of Flame 2.2 in Portuguese Portugal language by the STR in comment 0.
See attachment: Verify_Pass_2.2user_Portuguese Portugal.png
Rate: 0/5

Device: Flame 2.2 user (Pass)
Build ID               20150505002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2df83538ae20
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150505.041457
Firmware Date          Tue May  5 04:15:08 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: affected → verified
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Portuguese Portugal → LocRun2.2,
You need to log in before you can comment on or make changes to this bug.