Browser crashes when switching skins

VERIFIED DUPLICATE of bug 116038

Status

--
critical
VERIFIED DUPLICATE of bug 116038
17 years ago
10 years ago

People

(Reporter: pmac, Assigned: hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Seen on Mac OS 9.2 only (2001-12-18-08-trunk)

1. Launch the netscape.
2. Select View > Apply theme...classic
or select View > Edit > Preferences > appearance > Theme... Apply Classic or 
Apply Modern.
Notice it crashes.

Below here is the talkback report on Mac OS 9.2:

Stack Trace

0x14ad01f4 
content.shlb + 0x252ab0 (0x3d810560) 
content.shlb + 0x2506cc (0x3d80e17c) 
content.shlb + 0x24ff98 (0x3d80da48) 
content.shlb + 0x252ac8 (0x3d810578) 
content.shlb + 0x2506cc (0x3d80e17c) 
content.shlb + 0x24ff98 (0x3d80da48) 
content.shlb + 0x252ac8 (0x3d810578) 
content.shlb + 0x2506cc (0x3d80e17c) 
content.shlb + 0x24ff98 (0x3d80da48) 
content.shlb + 0x252ac8 (0x3d810578) 
content.shlb + 0x2506cc (0x3d80e17c) 
content.shlb + 0x24ff98 (0x3d80da48) 
content.shlb + 0x252ac8 (0x3d810578) 
content.shlb + 0x2506cc (0x3d80e17c) 
content.shlb + 0x24ff98 (0x3d80da48) 
content.shlb + 0x252ac8 (0x3d810578) 
content.shlb + 0x2506cc (0x3d80e17c) 
layout.shlb + 0x132030 (0x3c0dfbc0) 
layout.shlb + 0x132480 (0x3c0e0010) 
layout.shlb + 0x131d08 (0x3c0df898) 
layout.shlb + 0x132480 (0x3c0e0010)
(Reporter)

Comment 1

17 years ago
it also crashes on windows 98 as well (2001-12-18-06-trunk)
-> hyatt
Assignee: ben → hyatt

Comment 3

17 years ago
skinability issues on macos goes to pinkerton, IIRC.
Assignee: hyatt → pinkerton
not when they're in content or layout and happens on win98. -> apps
Assignee: pinkerton → trudelle
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: Mac OS 9.2--the browser crashes when switching skins → Browser crashes when switching skins

Comment 5

17 years ago
->hyatt/critical
Assignee: trudelle → hyatt
Severity: normal → critical
(Reporter)

Comment 6

17 years ago
Since this is a crash bug, this need to be fixed for march v. I add the keyword: 
nsbeta1
Keywords: nsbeta1
(Reporter)

Comment 7

17 years ago
Peter, this bug was reported almost two months ago dated: 12/18/01. Currently,
I couldn't reproduce this crash any more using commercial build (MAC OS 9.2: 
2002-02-06-08-trunk).
Could anyone reproduce this on the recent build? Thanks!
(Reporter)

Comment 8

17 years ago
On mac os 9.2 (commercial build: 2002-02-06-08-trunk), I could 'not' reproduce 
the crash on http://home netscape.com like the orginal of this bug that I filed 
couple months ago.
However, I could reproduce easily by clicking on this url: http://
www3.nameplanet.com/mail , then it crashs!
The stack trace of this is exactly the same as the original stack trace.
So please refer to bug: http://bugzilla.mozilla.org/show_bug.cgi?id=116038
additional comment #26. Thanks!

Comment 9

17 years ago
Patty: So, is this a dup of 116038?
(Reporter)

Comment 10

17 years ago
Peter, yes, it's a dup of 116038 since the stracktrace is exactly the same.

Comment 11

17 years ago
resolving as dup per pmac

*** This bug has been marked as a duplicate of 116038 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

17 years ago
Verified dup of bug: 116038.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.