[Camera]The "Don‘t share" is truncated in Camera permission screen.

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: sfoster)

Tracking

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: LocRun2.2, [systemsfe])

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.2][Camera] Launch camera for the first time, then Camera permission screen pops up. You can see the "Don‘t share" is truncated.
Attchment:21-4.png

[2.Testing Steps]: 
1. Flash or reset the phone to bring up the FTE and finish the FTE to view the homescreen 
2. Tap 'Camera' from the home screen and wait for the Camera permission screen to pop up 


[3.Expected Result]: 
3.Nothing is not truncated in Camera permission screen.

[4.Actual Result]: 
3.The "Don't share" is truncated in  Camera permission screen.

[5.Reproduction build]: 
Device: Flame 2.1 user (unaffected)
Build ID               20150426001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/82a14be0462c
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.035220
Firmware Date          Sun Apr 26 03:52:31 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user (affected)
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.040327
Firmware Date          Sun Apr 26 04:03:38 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12760
(Reporter)

Comment 1

4 years ago
Posted image 21-4.png
(Reporter)

Updated

4 years ago
Same string size, so probably a regression between 2.1 and 2.2. 
Since this affects a shipping locale (and probably others), blocking 2.2 on this.
blocking-b2g: --- → 2.2+
That is a system app permission dialog. It appears in the camera app (or any app that uses geolocation) but is not a camera bug, so changing the component.

Sam is working on bugs like this one and trying to figure out how and why the button margins changed.
Component: Gaia::Camera → Gaia::System
Flags: needinfo?(sfoster)
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Portuguese Brazil → LocRun2.2, MGSEI-l10n-1F-Portuguese Brazil, [systemsfe]
(Assignee)

Comment 4

4 years ago
Thanks David. It turns out bug 1010675 fixed some issues we had down in Layout with button content overflowing into padding. Our feeling (in bug 1157173) was that this was a good thing and that those instances should have never worked to begin with, so we're fixing them in Gaia, as we find them.
Assignee: nobody → sfoster
Flags: needinfo?(sfoster)
Priority: -- → P2
Target Milestone: --- → 2.2 S11 (1may)
I looked around a little bit on this one....

Possibly the fix should go here: https://github.com/mozilla-b2g/gaia/blob/v2.2/apps/system/style/themes/default/buttons.css#L17
(Assignee)

Comment 6

4 years ago
We need to revisit the default padding in https://github.com/mozilla-b2g/gaia/blob/master/shared/style/buttons.css#L20, which is currently set at 0 1.2rem. The fix in bug 1010675 changes the way these labels overflow, with the result that they will ellipsize sooner. This screenshot shows the result of setting left/right padding to 0.5rem - which is as big as I could get it without causing truncation/ellipsis. Obviously results may vary with different strings, fonts etc, but this example seems a reasonable proxy for instances where our existing string just barely fit inside the button. What do you think? I'll attach a patch as well so you can take it for a ride.
Flags: needinfo?(firefoxos-ux-bugzilla)
(Assignee)

Comment 8

4 years ago
Correction, we don't need to touch shared/style/buttons.css here, just the dialog buttons in apps/system/style/themes/default/buttons.css - so much less ocean to boil.
(Assignee)

Comment 9

4 years ago
Comment on attachment 8599493 [details] [review]
[gaia] sfoster:shared-button-padding-bug-1158740 > mozilla-b2g:master

Similar to bug 1157159, adjust dialog buttons styles to restore previous behavior after the overflow fix in bug 1010675
Attachment #8599493 - Flags: review?(kgrandon)
(Assignee)

Comment 10

4 years ago
With patch applied.
(Assignee)

Comment 11

4 years ago
Cancelling UX need-info, if we do this right there's no visual change. Also, see dev-gaia thread: https://groups.google.com/forum/#!topic/mozilla.dev.gaia/s3HyGQzk-Y4
Flags: needinfo?(firefoxos-ux-bugzilla)
Comment on attachment 8599493 [details] [review]
[gaia] sfoster:shared-button-padding-bug-1158740 > mozilla-b2g:master

LGTM, thanks!
Attachment #8599493 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

4 years ago
Depends on: 1010675
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Hi Sam,
Could you help to raise approval request to land on 2.2? Thanks!
Flags: needinfo?(sfoster)
Keywords: verifyme
(Assignee)

Comment 15

4 years ago
Comment on attachment 8599493 [details] [review]
[gaia] sfoster:shared-button-padding-bug-1158740 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Permission dialog buttons, fix necessitated by Bug 1010675.
[User impact] if declined: Some button labels will be truncated in some languages, with their meaning perhaps unclear
[Testing completed]: Tested on device in multiple languages
[Risk to taking this patch] (and alternatives if risky): Low as patch is stylistic only, and affects these buttons specifically. Note that these CSS rules do apply to many dialogs system-wide however
[String changes made]: None
Flags: needinfo?(sfoster)
Attachment #8599493 - Flags: approval-gaia-v2.2?
This issue is verified fixed on Flame 3.0. See screenshot for fixed behavior.

Device: Flame 3.0
BuildID: 20150506010204
Gaia: 3e6fd1e0a478af2c95d09ce95c2c6de2de2fec14
Gecko: ba44099cbd07
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Leaving verifyme tag for 2.2 verification after uplifting.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
Attachment #8599493 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Elie, could you help verify v2.2?
Flags: needinfo?(zikui.yang)
(Reporter)

Comment 19

4 years ago
(In reply to Hermes Cheng[:hermescheng] from comment #18)
> Elie, could you help verify v2.2?

This issue verified successfully on flame 2.2
Device: Flame 2.2 user
Build ID               20150512002502
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.041710
Firmware Date          Tue May 12 04:17:22 EDT 2015
Bootloader             L1TC000118D0
Refer to picture    Don't share_verified pass.png
Flags: needinfo?(zikui.yang)
(Reporter)

Comment 20

4 years ago
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Portuguese Brazil, [systemsfe] → LocRun2.2, [systemsfe]
Per Comment 16 & Comment 19, clear verifyme
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.