[l10n][Settings]Portuguese Brazil:The string message Settings is truncated.

VERIFIED FIXED

Status

Mozilla Localizations
pt-BR / Portuguese (Brazil)
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 wontfix, b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.2,)

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8597918 [details]
Portuguese Brazil_meesage settings.png

[1.Description]:
[l10n][2.1&2.2][Settings]Portuguese Brazil:Enter Settings main view,the string message Settings are truncated.
see attachment:Portuguese Brazil_meesage settings.png

[2.Testing Steps]: 
1.launch Settings
2.Observe the string of message settings.

[3.Expected Result]: 
2.The string Call Settings should not be truncated.

[4.Actual Result]: 
2.The string message Settings is truncated.

[5.Reproduction build]: 
Device: Flame 2.1 user (Affected)
Build ID               20150426001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/82a14be0462c
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.035220
Firmware Date          Sun Apr 26 03:52:31 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user (affected)
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.040327
Firmware Date          Sun Apr 26 04:03:38 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
16040
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
(caution: Step 3 in STRs is incorrect. It should read The string Message Settings should not be truncated.)

Once more, let's see if localizer can change this string. FWIW here's what pt-PT put: https://transvision.mozfr.org/?recherche=message+settings&repo=gaia&sourcelocale=en-US&locale=pt-PT&search_type=strings Not sure if relevant.
Flags: needinfo?(mv.nsaad)

Comment 2

3 years ago
Totally relevant. Fixed as well!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mv.nsaad)
Resolution: --- → FIXED
(Reporter)

Comment 3

3 years ago
Created attachment 8599660 [details]
Portuguese Brazil_meesage settings_verified failed.png

This issue has been failed verified on flame2.1&2.2
Reproduece rate:5/5

Device: Flame 2.2 user[Verified  failed]
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.040640
Firmware Date          Wed Apr 29 04:06:52 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 user[Verified  failed]
Build ID               20150429001202
Gaia Revision          9fda4aec7f9495a27a335ccaf3b1a4dc9c4c6db0
Gaia Date              2015-04-28 19:33:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/38ab00c01159
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.034244
Firmware Date          Wed Apr 29 03:42:55 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Comment 4

3 years ago
Hi marcus,could you help to check this issue agian?
Flags: needinfo?(mv.nsaad)

Comment 5

3 years ago
Hi Alissa, yes, sure. I've just fixed it for 2.1 too. What might have happened, is that the version that is on pootle might not have been pushed to HG yet, and I can't do it manually since I do not have HG commit privileges.
Flags: needinfo?(mv.nsaad)

Comment 6

3 years ago
Hi Marcus,
This issue verified successfully on flame 2.1,the UI looks OK.The string "Message settings" displays as 1 line in Portuguese Brazil.But why not the string "Message settings" displays as 2 line on 2.2 branch?
Please refer to picture: Message_settings.png

Build infomation:
Device: Flame 2.1 user:
Build ID               20150510001201
Gaia Revision          3e7bd686ecd852f4dfa4605b45f558e6bd34f02a
Gaia Date              2015-05-07 15:12:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/de4ebfdc7db6
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.035540
Firmware Date          Sun May 10 03:55:51 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user:
Build ID               20150510002505
Gaia Revision          528ef60e7cda09ad43478065f5d33bda398fbeb7
Gaia Date              2015-05-08 23:40:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d04cc085cf5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.043421
Firmware Date          Sun May 10 04:34:32 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(mv.nsaad)

Comment 7

3 years ago
Created attachment 8603922 [details]
Message_settings.png

Comment 8

3 years ago
Elie, what you're seeing over there isn't updated. Also, the issue is that the strings aren't the same, being the first one longer than the later, thus why it's a two liner instead of one.

Anyhow, you should be able to see "Definições de Mensagens" on both 2.1 and 2.2
Flags: needinfo?(mv.nsaad)

Comment 9

3 years ago
(In reply to Marcus Saad (:msaad) from comment #8)
> Elie, what you're seeing over there isn't updated. Also, the issue is that
> the strings aren't the same, being the first one longer than the later, thus
> why it's a two liner instead of one.
> 
> Anyhow, you should be able to see "Definições de Mensagens" on both 2.1 and
> 2.2
Hi Marcus,
Thanks for your reply.

This issue verified successfully on flame 2.2
But verified fail on flame 2.1,it seems that the patch does not land to 2.1 branch
Please refer to picture 2.2pass_2.1fail.png
Flame 2.2:
Build ID               20150512002502
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.041644
Firmware Date          Tue May 12 04:16:55 EDT 2015
Bootloader             L1TC000118D0

Flame2.1:
Build ID               20150512161201
Gaia Revision          c80865cb0bf73f1b97defbc646083b404feb3ac4
Gaia Date              2015-05-12 06:26:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/2fd3ef3fc14a
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.194519
Firmware Date          Tue May 12 19:45:28 EDT 2015
Bootloader             L1TC000118D0
status-b2g-v2.2: affected → verified

Comment 10

3 years ago
Created attachment 8605027 [details]
2.2pass_2.fail.png
(Reporter)

Comment 11

3 years ago
Hi, Delphine
According to comment5, could you help Marcus to fix this issue on v2.1.
Flags: needinfo?(lebedel.delphine)
This is more likely to be an UI change than a translation issue. Both strings are already the same.
For 2.1, we're way past the time line to get a UI fix there IMO. Marcus has done the best he could and I believe we can still understand the string from the context. Let's put 2.1 as wontfix and please reopen if needed or if you don't agree :)
status-b2g-v2.1: affected → wontfix
Flags: needinfo?(lebedel.delphine)
(Reporter)

Comment 14

3 years ago
According to comment13, v2.1 is wontfix, and this issue has been verified as pass on v2.2, so switch status as verified.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

3 years ago
QA Whiteboard: [MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Portuguese Brazil → LocRun2.2,
You need to log in before you can comment on or make changes to this bug.