console.groupCollapsed() should not expand

RESOLVED DUPLICATE of bug 1088360

Status

defect
RESOLVED DUPLICATE of bug 1088360
4 years ago
a year ago

People

(Reporter: michael.heuberger, Unassigned)

Tracking

37 Branch

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150417180024

Steps to reproduce:

On Firefox v37.0.2 for Ubuntu 14.10 I have this JS code on https://www.videomail.io to group some output on the dev console with:

console.groupCollapsed()

but they appear expanded. It should remain collapsed. Google Chrome does this correctly.


Actual results:

Firefox:

```
Visuals: buildChildren() videomail-client.js:14902
console.trace(): videomail-client.js:14903
require<[82]</module.exports/this.debug() videomail-client.js:14903
buildChildren() videomail-client.js:16155
require<[92]</Visuals/this.build() videomail-client.js:16210
buildChildren() videomail-client.js:15818
require<[90]</Container/this.build() videomail-client.js:15893
buildForm() videomail-client.js:14469
change() videomail-client.js:8053
change() videomail-client.js:7936

Notifier: initEvents()
```

Chrome:

```
Visuals: buildChildren()
collectLogger.js:24 Notifier: initEvents()
```


Expected results:

I expect the grouped output to be collapsed like Chrome does.

Updated

4 years ago
Component: Untriaged → Developer Tools: Console
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1088360

Updated

a year ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.