Europe evangelism division map

RESOLVED WONTFIX

Status

()

bugzilla.mozilla.org
Administration
--
enhancement
RESOLVED WONTFIX
16 years ago
6 years ago

People

(Reporter: Pavol Vaskovic, Assigned: asa)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
We are getting a lot of misplaced bugs into Tech Evangelism -> Central European
component. Our europe division is working quite good (as far as CE component is
considered - can't speak for others), but especialy Germans find it tricky to
correctly place their bugs in Wester European Component...

Therefore I've drawn "Mozilla Evangelism Europe Division Map" which is placed at
URL. Is there a chance that this map will be ?linked? somehow for people that
are in doubt when choosing Tech Evangelism Europe? I think it could be
incorporated into Bugzilla "Wizard" somehow.

--mondo

Comment 1

16 years ago
I think we could stick a url into the comment description.

gerv: can you do something about the bz helper?
I can't reach this URL.

Is this really so much of a problem? Misfiled bugs happen in all components -
it's just something you have to live with.

Gerv
(Reporter)

Comment 3

16 years ago
Maybe it could be put here...? 
http://bugzilla.mozilla.org/describecomponents.cgi?product=Tech%20Evangelism
If people are reading that page, they can just check the list of countries.

Live with it, people - misfiled bugs are a fact of life. :-)

Gerv
(Reporter)

Comment 5

16 years ago
OK. I could live with it, but someone has to educate at least Netscape
engineers, who are constantly misplacing bugs into our component. That shouldn't
be too hard, should it? It's a bit strange that such smart guys can't learn a
bit about Europe, huh?

Comment 6

16 years ago
The component/module owners page (http://www.mozilla.org/owners.html) should
list the Tech Evangelism components and their fields of responsibility (like
countries in the case of Europe components). Otherwise how can anyone know which
component is (for example) Germany in?

Adding shaver to CC: as he is the most visible author of that document (except
despotdaemon who is obviously a bot). Anyway we need someone with check-in
permission to modify the owners list.  
(Assignee)

Comment 7

16 years ago
>The component/module owners page (http://www.mozilla.org/owners.html) should
list the Tech Evangelism components

Jacek, bugzilla components and Mozilla modules are not the same thing. Maybe one
day they will be but they are not now. A Mozilla module represents a file or set
of files in cvs.mozilla.org and a Mozilla module owner is responsible for those
files. A Bugzilla component assignee may in some cases also be the Mozilla
module owner for a module of same or similar name. But right now modules are
code and evangelism is not about the code. Evangelism is an activity. Perhaps we
need to add a new catagory of ownership to the www.mozilla.org/owners.html page
for "activity owners" but that has not happened yet. 

>Otherwise how can anyone know which component is (for example) Germany in?

Bug reporters can read the Component descriptions at
http://bugzilla.mozilla.org/describecomponents.cgi?product=Tech+Evangelism  If
the descriptions are deficient then we should update them.

(Assignee)

Comment 8

16 years ago
>someone has to educate at least Netscape engineers, who are constantly
misplacing bugs into our component.

Pavol, bugs are going to be misfiled. People are lazy. Reading the Component
Description page is one more step in an already long bug reporting process. Be
thankful that the bug is even filed on the correct Product ;-)  

>It's a bit strange that such smart guys can't learn a bit about Europe, huh?

Will you learn a bit about XPCOM? Just kidding. 

We don't have a mechanism in Bugzilla for forcing people to look at the map
before reporting a bug and we certainly don't have anything in place to force
them to look at a map before _moving_ a bug to Tech Evangelism (which seems to
be the primary occurrence of this problem). 

The only pages a person is required to look at before reporting a bug are the
"pick a product" page <http://bugzilla.mozilla.org/enter_bug.cgi> and the actual
"enter bug" page
<http://bugzilla.mozilla.org/enter_bug.cgi?product=Tech%20Evangelism> We can't
add anything to the enter bug page.  We could add a link to your map in the Tech
Evangelism product description. We could also add a link to it in each of the
European component descriptions. 

Putting the URL in the Product or Component description may effect a small
change for people reporting bugs (product more than component since no one looks
at component descriptions) but won't do a thing for people moving bugs. 

I don't think you'll see any change in behavior as a result of linking to that
map. Perhaps you could make your life easier with a query like
http://bugzilla.mozilla.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&product=Tech+Evangelism&component=Europe%3A+Central&component=Europe%3A+East&field0-0-0=bug_file_loc&type0-0-0=anywordssubstr&value0-0-0=.de+.fr+.it+.mc+.uk+.ch+.is+.gi+.pt+.va+.mt+.at+.li+.ad+.es+.no+.se+.fi+.lu+.nl+.je+.gg+.be+.fo
 You could run it each day or every few days and it'll probably give you the
list of misfiled bugs. (You could improve the query by moving to regexps rather
than substrings but it seems to generate a small enough list, about 7, with
decent enough accuracy, about 70% need to be moved to West, to leave it as it is). 

Bugs will always be misfiled. My component, Browser-General, has about 50 bugs a
day that are misfiled. I've done a couple queries and they suggest that there
haven't been more than about 12 bugs ever moved from East or Central to West. I
think that a misfiled bug every week or two isn't unreasonable. I'm going to
mark this bug as Won'tFix. Please reopen the bug if you still want a link to the
map added to the product of component description (I'll repeat, I really don't
think this will do anything for your problem). 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 9

16 years ago
> Bug reporters can read the Component descriptions at
> http://bugzilla.mozilla.org/describecomponents.cgi?product=Tech+Evangelism If
> the descriptions are deficient then we should update them.

The descriptions are correct, at least for Europe.

Comment 10

16 years ago
Asa: actually those are partially bugs.

I'm hoping to get a banner added to some of the bugzilla pages describing the 
currently selected product/component, so i suppose we could let the banner be 
html and then let evangelism include the map for the reassign page.  it really 
would be useful.  anyways, that requires me to carefully map out my thougts.

Comment 11

16 years ago
s/thougts/thoughts/. proof that now is not the time for me to do that.
(Reporter)

Comment 12

16 years ago
I got some idea. So please tell me if I'm completely off here:
All evangelism bugs ought to have URL field filled. 
Why can't bugzilla decide correct evangelism component (eg. Central Europe)
based on that and let error prone humans interfere only when in doubt or when
specificaly asked to?
The whole European division can be easily done by top level domains. See the
picture for all european TLDs.
What do you think?
Because this would require a custom mod. to Bugzilla, and that would be using a
sledgehammer to crack a nut.

Read Asa's comments and get over it. :-) This bug is WONTFIXed.

Gerv
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.