This page gets messed up, and shows buggy GFX.

VERIFIED FIXED in M17

Status

()

Core
Layout: Tables
P3
normal
VERIFIED FIXED
19 years ago
10 months ago

People

(Reporter: Magnus Näslund, Assigned: buster)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Well i don't know what creates this problem, but it might have something to do
with tables + images, coz that what the page is built from.
When i go to this page i get pieces of the mozilla GUI in the webpage and so on.
I have had this in all of the latest versions of mozilla.

Magnus

Comment 1

19 years ago
Created attachment 1200 [details]
testcase

Updated

19 years ago
Whiteboard: [TESTCASE]

Updated

19 years ago
Assignee: don → troy
Component: Browser-General → Layout

Updated

19 years ago
Assignee: troy → karnaze
Component: Layout → HTMLTables

Comment 2

19 years ago
Chris, the table ends up being way too wide. My guess is it's because of the
floated right image being the only thing in the table cell of the nested table.
I think this used to work, so we must have a regression somewhere or it's a
nested table problem

Updated

19 years ago
Assignee: karnaze → kipp

Comment 3

19 years ago
The nested table in the attachment is returning a reasonable max element width
during pass 1, but the area frame of the cell (of the top level table)
containing it is returning an unreasonable max element width, hence the wide top
level table. Reassigning to Kipp.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15

Updated

19 years ago
QA Contact: leger → chrisd

Comment 4

19 years ago
Updating QA Contact.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
Fixed by recent floater related checkins.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Using 9/28 Apprunner, verified bug fixed.
You need to log in before you can comment on or make changes to this bug.