Utility tray often disappears briefly when dragging it open

RESOLVED DUPLICATE of bug 1155091

Status

defect
RESOLVED DUPLICATE of bug 1155091
4 years ago
4 years ago

People

(Reporter: cwiiis, Assigned: cwiiis)

Tracking

({regression})

unspecified
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [systemsfe], URL)

(Assignee)

Description

4 years ago
STR:

1. Drag utility tray to become visible

Expected:

Utility tray follows finger and gradually reveals.

Actual:

Utility tray follows finger and gradually reveals, but completely disappears for a frame sometimes.


Note, this isn't 100% reproduceable, it seems to depend on some prior state, either what apps are open, or perhaps if you have notifications. When it does reproduce, it seems to happen every time, but you need to be in the state for it to reproduce.

I see this very frequently on my dogfood device.

I believe this is being caused by the faulty progressive tiled rendering/low-preicison rendering coherent region code, and thus it should be possible to work around it, in a similar fashion to bug 1151081.
Adding qawanted to see if they see this behavior. cwiiis, what build are you on ?
Keywords: qawanted
I could not reproduce this on 3.0. I tried with having multiple notifications, having multiple apps opened etc. Notification tray seems to be animating smoothly without disappearing when expanding or minimizing it.

Also, a video will really help in a bug like this.

Device: Flame
BuildID: 20150427010202
Gaia: b4c949cdc780893897c9b45c1adea46e2eb694ff
Gecko: 37d60e3b8be6
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Leaving qawanted for others to attempt.
Flags: needinfo?(ktucker)
Chris, can you we get a video of this issue occurring?
Flags: needinfo?(ktucker) → needinfo?(chrislord.net)
(Assignee)

Comment 4

4 years ago
(In reply to KTucker [:KTucker] from comment #3)
> Chris, can you we get a video of this issue occurring?

I've managed to get more reliable STR - it seems to happen fairly consistently if the music app is loaded and the playing controls are visible in the utility tray. I can get a video of it.

I've been testing in 2.2, but I've seen this in master last time I was dogfooding master. I'll try to verify it still occurs in master, but it's definitely occurring in 2.2.
Flags: needinfo?(chrislord.net)
(Assignee)

Comment 5

4 years ago
Added video in URL field.
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → chrislord.net
STR:
1) Go to Music app and start playing a song
2) Drag notification tray down half way and hold finger there (like shown in video at comment 5)

- observe utility tray disappear. Repro frequency: 5 out of 5.

This issue occurs on Flame 3.0 and 2.2.

Device: Flame 3.0
BuildID: 20150428010206
Gaia: 0636405f0844bf32451a375b2d61a2b16fe33348
Gecko: caf25344f73e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150428002500
Gaia: 9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gecko: e79c19bf19bf
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

----

This issue does NOT occur on 2.1. Following STR, utility tray does not disappear when drag-holding it halfway on screen.

Device: Flame 2.1
BuildID: 20150428001200
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: 5f2c57b580ff
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ktucker
Mozilla Inbound

Last working
Environmental Variables:
Device: Flame 3.0
BuildID: 20150211190942
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 6ed69c4d2c15
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken
Environmental Variables:
Device: Flame 3.0
BuildID: 20150211230942
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 07479758ab68
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 07479758ab68

First Broken Gaia Last Working Gecko: Issue DOES NOT reproduce
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 6ed69c4d2c15

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6ed69c4d2c15&tochange=07479758ab68

This might have been caused by Bug 1127066 

------------------------------------------

Botond, can you take a look at this please? Looks like the work done for Bug 1127066.
Blocks: 1127066
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(botond)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(botond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1155091
You need to log in before you can comment on or make changes to this bug.