Cookies set via <meta http-equiv> ignored if set to "ask me every time"

RESOLVED WONTFIX

Status

()

Core
Networking: Cookies
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: benjaminmoody, Unassigned, Mentored)

Tracking

({testcase})

31 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20150331141458

Steps to reproduce:

Set Firefox to "ask me every time" about cookies.

Load a page, on a site for which you have *not* already set cookie preferences, that sets cookies using <meta http-equiv="Set-Cookie" content="...">.  (Although this is a strange way to set cookies, Firefox does normally allow it, so some sites do so.)

A test page may be found at http://ecg.mit.edu/cgi-bin/cookietest .


Actual results:

The cookies set in the meta tag are silently ignored.


Expected results:

Firefox should prompt the user to accept these cookies, just as if they were set in an HTTP response header.

This might be related to bug 783358; I don't know.

Updated

3 years ago
Component: Untriaged → Networking: Cookies
Keywords: testcase
Product: Firefox → Core

Comment 1

3 years ago
For anybody who wants to investigate why this occurs, nsContentSink::ProcessHeaderData is the place to start, as that's where we end up calling nsCookieService::SetCookieString.
Mentor: josh@joshmatthews.net

Comment 2

3 years ago
That being said, the test page from the URL field in this bug shows cookie values for every one of the links I clicked on that page, so maybe I can't reproduce in Firefox Nightly?

Comment 3

3 years ago
Benjamin, do you see this behaviour in more recent versions of FF?
Flags: needinfo?(benjaminmoody)
(Reporter)

Comment 4

3 years ago
Yes, I have just tried using a fresh profile and Firefox 37.0.2.

http://ecg.mit.edu/cgi-bin/cookietest?op=session-http -> "The site ecg.mit.edu wants to set a cookie"

http://ecg.mit.edu/cgi-bin/cookietest?op=session-meta -> no prompt, existing cookie value is not changed.
Flags: needinfo?(benjaminmoody)

Comment 5

3 years ago
Oh right, I forgot to change the preference about automatically accepting cookies.
ask me everytime is gone
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.