iiyama.nl - Fancy scrollbar doesn't work with Mozilla

VERIFIED DUPLICATE of bug 151465

Status

P3
major
VERIFIED DUPLICATE of bug 151465
17 years ago
4 years ago

People

(Reporter: marcel_mozilla, Assigned: tristan)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
The site uses some fancy Javascript scrollbar thingy in article lists. 

For example go to:
http://www.iiyama.nl/html/content/proframes_crt19.html

If you press the down arrow the indicator goes down, but the content doesn't.
Expected: the content also scrolls.
(Reporter)

Comment 1

17 years ago
Created attachment 62135 [details]
Screen shot showing the problem.

As you can see the scrollbar is scrolled down, but the content is still at the
top. I can't scroll down in any other way, so I can't see the content.
(Reporter)

Comment 2

17 years ago
Created attachment 62137 [details]
Screen shot IE5

The problem does not appear with Internet Explorer 5.
The site seems to do some browser sniffing (/indexnet.html, /indexie.html).

Comment 3

17 years ago
*** Bug 116526 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Confirming the problem exists.  Not sure what the solution is yet though...
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: PC → All
Summary: Fancy scrollbar doesn't work with Mozilla → iiyama.nl - Fancy scrollbar doesn't work with Mozilla
(Reporter)

Comment 5

17 years ago
Iiyama uses a script made by Peter Nederlof
 (see http://www.iiyama.nl/scroll/scrollbar.js). When you go to the guy's
homepage, you will see he uses a fancy scrollbar himself too. But this one works
in Mozilla. So I guess Iiyama has to replace the old scrollbar.js with the new
one: http://www.xs4all.nl/~peterned/lib/objects/scrollbar.js
(Assignee)

Comment 6

17 years ago
updating URL to a page that has the problem. 
Confirming with NS621 and Moz 098 on Windows 2000
Setting P3.
(Reporter)

Comment 7

16 years ago
It kinda works now with Moz1.1 (Gecko/20020824) on Win2K. Not sure whether it's
working because a (compatibility) change in Mozilla or because they have updated
their script.
wfm with mozilla 1.1beta too.
(Reporter)

Comment 9

16 years ago
I did found something that still doesn't work though. I'm not sure what the
problem is here, but it seems to be the same problem as before or closely related.

Go to http://www.iiyama.nl/1024x768/html/content/content_vraag.html (it's a FAQ)
and click one of the links. It's supposed to link you to the answers further in
the document, but instead I just see black. It's works in IE6.
interessting.
the link itself triggers no javascript code. it seems that IE automatically
positions the scroller at the right place. weird. mozilla goes to where the link
is, but its hidden because of the way the scroller works. I am not sure whats
going on here... needs some more testing...

Comment 11

16 years ago
I think this is the same bug as described by bug 151465. I am duping this
against that one, because bug 151465 includes both the fix and the contact.

Also bug 151465 states that this is now wfm for Windows computers, but [and i
can confirm that on Mandrake 9.1 with Moz 2003050622] does NOT work for Linux.

Finally, i think the issue described by comment 9 and comment 10 are indeed
there, but are a different issue altogether and should therefore be covered by a
different bug.

If someone files that bug, can you please report the new bug number here as well?


*** This bug has been marked as a duplicate of 151465 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → Dutch
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.