Closed Bug 1159006 Opened 5 years ago Closed 5 years ago

webide can't connect to any runtime of firefox os simulator

Categories

(DevTools :: WebIDE, defect)

37 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1159083

People

(Reporter: mozilla, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150417180400

Steps to reproduce:

1. starting webide
2. select runtime
3. click on already installed simulator


Actual results:

an error message occurs: "operation timed out: connecting to runtime firefox os 2.2"

browser console says multiple times:

Exception { message: "Component returned failure code: 0x804b000d (NS_ERROR_CONNECTION_REFUSED) [nsIInputStream.available]", result: 2152398861, name: "NS_ERROR_CONNECTION_REFUSED", filename: "resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/security/socket.js", lineNumber: 174, columnNumber: 0, inner: null, data: null, stack: "onInputStreamReady@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/security/socket.js:174:8
", location: XPCWrappedNative_NoHelper } connection-manager.js:258



Expected results:

firefox os simulator should start
Component: Untriaged → Developer Tools: WebIDE
Summary: webide can't connect to any runtime firefox os simulator → webide can't connect to any runtime of firefox os simulator
I am using firefox 37.0.2 on ubuntu gnu/linux 15.04

connection to devices like flame or flatfish works. its only the simulator it can't connect to. its also not possible to connect to fresh installed simulators.
Here are the steps I tried:

1. Boot Ubuntu 15.04 live CD (64-bit)
2. Start Firefox 37
3. Install simulator 2.2 from WebIDE
4. Start simulator 2.2

The simulator starts and WebIDE connects successfully.

Can you try these same steps?  Is there I need to do differently to reproduce?
Flags: needinfo?(mozilla)
hi, if I find something clean to boot from, I will try it also that way.
at the moment I found that as a difference to your config, there was already an update for the current ubuntu. so we are using different versions, maybe you can reproduce it after applying current updates.

I can repro it on another machine also, but it has also already firefox 37.0.2+build1-0ubuntu0.15.04.1 on it.


apt-cache policy firefox

firefox:
  Installed: 37.0.2+build1-0ubuntu0.15.04.1
  Candidate: 37.0.2+build1-0ubuntu0.15.04.1
  Version table:
 *** 37.0.2+build1-0ubuntu0.15.04.1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ vivid-security/main amd64 Packages
        100 /var/lib/dpkg/status
     37.0+build2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
Flags: needinfo?(mozilla)
I think this will end up as a duplicate of bug 1159083, which I can reproduce.  I'll post here when I have a fix you can try.
See Also: → 1159083
I just downgraded firefox to the version that comes with ubuntu 15.04 but the problem still occurs.

firefox:
  Installed: 37.0+build2-0ubuntu1
  Candidate: 37.0.2+build1-0ubuntu0.15.04.1


the browserconsole has the same output multiple times until the time out message:

Exception { message: "Component returned failure code: 0x804b000d (NS_ERROR_CONNECTION_REFUSED) [nsIInputStream.available]", result: 2152398861, name: "NS_ERROR_CONNECTION_REFUSED", filename: "resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/security/socket.js", lineNumber: 174, columnNumber: 0, inner: null, data: null, stack: "onInputStreamReady@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/security/socket.js:174:8
", location: XPCWrappedNative_NoHelper }
Can you try the following Firefox build?  For me, it resolved a similar issue from bug 1159083.

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jryans@gmail.com-2cfcfa1d5b57/try-linux64/firefox-40.0a1.en-US.linux-x86_64.tar.bz2
Flags: needinfo?(mozilla)
yes, its working with this build.


browser console output:

Connection status changed: connecting" app-manager.js:158
Connection status changed: connected" app-manager.js:158

do you need any more info?
Flags: needinfo?(mozilla)
Okay, great!  I'll land the fix shortly then.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
See Also: 1159083
Duplicate of bug: 1159083
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.